Subject: [OAUTH-WG] poll url in draft-ietf-oauth-device-flow-01

From: Samuel Erdtman <[email-masked]>
Date: Mon, 16 May 2016 21:51:26 -0700

Hi,

I just manage to take the time to read this document and in general I like
it a lot I think it fills a gap and with mapping to CBOR, and CoAP it will
work well for more constrained deceive too.

There are several details that would be great to address such as IANA
section more thorough descriptions of device_code and user_code and It
would also be good with more examples e.g. a poll example.

The above things one can figure out relatively easy but how and where are
poll requests sent. Is it new post requests to the token endpoint with the
device_code included; or is it get requests to the token endpoint with the
device_code; or is it a completely different endpoint?
A solution that I would like is to have a poll url instead of the
device_code then the client does not need to know how to construct the poll
url form the device_code.

Is there a github repo or something similar that I could send pull requests
to?

Best regards
//Samuel

---

From: Alex Bilbie <[email-masked]>
Date: Tue, 17 May 2016 07:56:15 +0000

> Is there a github repo or something similar that I could send pull
requests to?

I too have been wondering how to contribute proposed changes to
specifications?

Thanks,

Alex

On Tue, 17 May 2016 at 05:51 Samuel Erdtman <[email-masked]> wrote:

> Is there a github repo or something similar that I could send pull
> requests to?
>
> Best regards
> //Samuel
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: Mike Jones <[email-masked]>
Date: Tue, 17 May 2016 13:22:14 +0000

For now, I’d suggest contributing the usual way – writing up a proposal to the working group mailing list for discussion by the working group.  The editors can then revise the draft after there’s apparent consensus to do so in a particular way.

Thanks for taking the time to do your reviews, Samuel and Alex.  I look forward to reviewing your proposals.

                                                          Best wishes,
                                                          -- Mike

From: OAuth [mailto:[email-masked]] On Behalf Of Alex Bilbie
Sent: Tuesday, May 17, 2016 12:56 AM
To: <[email-masked]> <[email-masked]>
Subject: Re: [OAUTH-WG] poll url in draft-ietf-oauth-device-flow-01

> Is there a github repo or something similar that I could send pull requests to?

I too have been wondering how to contribute proposed changes to specifications?

Thanks,

Alex

On Tue, 17 May 2016 at 05:51 Samuel Erdtman <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
I just manage to take the time to read this document and in general I like it a lot I think it fills a gap and with mapping to CBOR, and CoAP it will work well for more constrained deceive too.
There are several details that would be great to address such as IANA section more thorough descriptions of device_code and user_code and It would also be good with more examples e.g. a poll example.
The above things one can figure out relatively easy but how and where are poll requests sent. Is it new post requests to the token endpoint with the device_code included; or is it get requests to the token endpoint with the device_code; or is it a completely different endpoint?
A solution that I would like is to have a poll url instead of the device_code then the client does not need to know how to construct the poll url form the device_code.

Is there a github repo or something similar that I could send pull requests to?
Best regards
//Samuel
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth