Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant

From: Oleg Gryb <[email-masked]>
Date: Fri, 1 Jul 2016 17:05:09 +0000 (UTC)

"Browsers now re-append  fragments across 302 redirects unless they are explicitly cleared this makes fragment encoding less safe than it was  when originally specified" - thanks Jim. Looks like a good reason for vetting this flow out.
John,Please provide more details/links about re-appending fragments. 
Thanks,Oleg.

      From: Jim Manico <[email-masked]>
 To: Oleg Gryb <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; Liyu Yi <[email-masked]>
 Sent: Thursday, June 30, 2016 10:25 PM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant
   
Oleg! Hello! Great to see you pop up here with a similar concern.
John Bradley just answered this thread with the details I was looking for (thanks John, hat tip your way).
He also mentioned details about fragment leakage:
"Browsers now re-append  fragments across 302 redirects unless they are explicitly cleared this makes fragment encoding less safe than it was when originally specified"
Again, I'm new here but I'm grateful for this conversation.
Aloha,--Jim Manico@Manicode
On Jul 1, 2016, at 1:24 AM, Oleg Gryb <[email-masked]> wrote:

We've discussed access tokens in URI back in 2010 (https://www.ietf.org/mail-archive/web/oauth/current/msg04043.html). There were two major objectives when I was saying that it's not secure:
1. Fragment is not sent to a server by a browser. When I've asked if this is true for every browser in the world, nobody was able to answer.2. Replacing with POST would mean a significant performance impact in some high volume implementations (I think it was Goole folks who were saying this, but I don't remember now).
AFAIR, nobody was arguing about browsing history, so it's valid.
So, 6 years later we're at square one with this and I hope that this time the community will be more successful with getting rid of secrets in URL.
BTW, Jim, if you can come up with other scenarios when fragments can leak, please share. It'll probably help the community with solving this problem faster than in 6 years.
Thanks,Oleg.

      From: Jim Manico <[email-masked]>
 To: Liyu Yi <[email-masked]>; [email-masked] 
 Sent: Wednesday, June 29, 2016 7:30 AM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant
  
 > Shouldn’t it be more secure if we change to use a post method for access token, similar to the SAML does? I say yes. But please note I'm very new at this and someone with more experience will have more to say or correct my comments. Here are a few more details to consider.
  1) OAuth is a framework and not a standard, per se. Different authorization servers will have different implementations that are not necessarily compatible with other service providers. So there is no standard to break, per se.
  2) Sensitive data in a URI is a bad idea. They leak all over the place even over HTTPS. Even in fragments.
  3) Break the "rules" and find a way to submit sensitive data like access tokens, session information or any other (even short term) sensitive data in a secure fashion. This includes POST, JSON data payloads over PUT/PATCH and other verbs - all over well configured HTTPS.
  4) If you really must submit sensitive data over GET , consider JWT/JWS/JWE (with limited scopes/lifetimes) to provide message level confidentiality and integrity.
  Aloha,
 Jim Manico
Manicode Security
https://www.manicode.com 
 On 6/27/16 9:30 PM, Liyu Yi wrote:
  
  While we are working on a project with OAuth2 implementation, one question arises from our engineers. We noticed at https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30, it is specified that    (C)  Assuming the resource owner grants access, the authorization         server redirects the user-agent back to the client using the         redirection URI provided earlier.  The redirection URI includes         the access token in the URI fragment.   For my understanding, the browser keeps the URI fragment in the history, and this introduces unexpected exposure of the access token. A user without  authorization for the resource can get the access token as long as he has the access to the browser. This can happen in a shared computer in library, or for an IT staff who works on other employee’s computer.   Shouldn’t it be more secure if we change to use a post method for access token, similar to the SAML does? I feel there might be something I missed here. Any advices will be appreciated.  
  
 _______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

 -- 
 
_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 14:33:15 -0400

This behaviour started changing around 2011

From HTTP/1.1
See https://tools.ietf.org/html/rfc7231#section-7.1.2 <https://tools.ietf.org/html/rfc7231#section-7.1.2>I
      f the Location value provided in a 3xx (Redirection) response does
   not have a fragment component, a user agent MUST process the
   redirection as if the value inherits the fragment component of the
   URI reference used to generate the request target (i.e., the
   redirection inherits the original reference's fragment, if any).

   For example, a GET request generated for the URI reference
   "http://www.example.org/~tim" might result in a 303 (See Other)
   response containing the header field:

     Location: /People.html#tim

   which suggests that the user agent redirect to
   "http://www.example.org/People.html#tim”

   Likewise, a GET request generated for the URI reference
   "http://www.example.org/index.html#larry" might result in a 301
   (Moved Permanently) response containing the header field:

     Location: http://www.example.net/index.html

   which suggests that the user agent redirect to
   "http://www.example.net/index.html#larry", preserving the original
   fragment identifier.

This blog also explores the change.
https://blogs.msdn.microsoft.com/ieinternals/2011/05/16/url-fragments-and-redirects/ <https://blogs.msdn.microsoft.com/ieinternals/2011/05/16/url-fragments-and-redirects/>

> On Jul 1, 2016, at 1:05 PM, Oleg Gryb <[email-masked]> wrote:
> 
> John,
> Please provide more details/links about re-appending fragments. 
> 
> Thanks,
> Oleg.
> 
> 
> @Manicode
> On Jul 1, 2016, at 1:24 AM, Oleg Gryb <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> We've discussed access tokens in URI back in 2010 (https://www.ietf.org/mail-archive/web/oauth/current/msg04043.html <https://www.ietf.org/mail-archive/web/oauth/current/msg04043.html>). There were two major objectives when I was saying that it's not secure:
>> 
>> 1. Fragment is not sent to a server by a browser. When I've asked if this is true for every browser in the world, nobody was able to answer.
>> 2. Replacing with POST would mean a significant performance impact in some high volume implementations (I think it was Goole folks who were saying this, but I don't remember now).
>> 
>> Thanks,
>> Oleg.
>> From: Jim Manico <[email-masked] <mailto:[email-masked]>>
>> To: Liyu Yi <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]> 
>> > Shouldn’t it be more secure if we change to use a post method for access token, similar to the SAML does?
>> I say yes. But please note I'm very new at this and someone with more experience will have more to say or correct my comments.
>> Here are a few more details to consider.
>> https://www.manicode.com <https://www.manicode.com/>
>>> While we are working on a project with OAuth2 implementation, one question arises from our engineers.
>>> We noticed at  <https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30>https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30 <https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30>, it is specified that
>>>   
>>> (C)  Assuming the resource owner grants access, the authorization
>>>         server redirects the user-agent back to the client using the
>>>         redirection URI provided earlier.  The redirection URI includes
>>>         the access token in the URI fragment.
>>>  
>>> For my understanding, the browser keeps the URI fragment in the history, and this introduces unexpected exposure of the access token. A user without authorization for the resource can get the access token as long as he has the access to the browser. This can happen in a shared computer in library, or for an IT staff who works on other employee’s computer.
>>>  
>>> Shouldn’t it be more secure if we change to use a post method for access token, similar to the SAML does?
>>> I feel there might be something I missed here. Any advices will be appreciated.
>>> 
>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
>> 
>> -- 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
>> 
>> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
>

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 16:51:50 -0400

Yes but POST doesn't really work for in browser apps.

If it is a server app it should be using the code flow with GET or POST as
you like.

If we do a  post message based binding it will be targeted at in browser
applications.

John B.

On Fri, Jul 1, 2016 at 4:42 PM, Liyu Yi <[email-masked]> wrote:

> BTW, I do not see any significant performance concerns for post. Parsing
> and executing the Javascript logic for post operation will be on the client
> side, no extra server load is introduced.
>
> Plus post will remove the size restriction of the URL length.
>
> -- Liyu
>
> On Fri, Jul 1, 2016 at 1:35 PM, Liyu Yi <[email-masked]> wrote:
>
>> Thanks for the great comments and advices.
>>
>> I think it is a good idea for the working group to revise the fragment
>> part in the spec, since there might be public available tools already
>> implemented this approach and people can end up with a solution with
>> serious security loopholes.
>>
>> The re-append issue can be mitigate by a logic on Resource Server which
>> carefully re-writes/removes the fragment in any redirect, if the the
>> redirect can not be avoided.
>>
>> -- Liyu
>>
>>
>> On Fri, Jul 1, 2016 at 11:33 AM, John Bradley <[email-masked]> wrote:
>>
>>> See https://tools.ietf.org/html/rfc7231#section-7.1.2I
>>> https://blogs.msdn.microsoft.com/ieinternals/2011/05/16/url-fragments-and-redirects/
>>>
>>>
>>> "Browsers now re-append  fragments across 302 redirects unless they are
>>> explicitly cleared this makes fragment encoding less safe than it was  when
>>> originally specified" - thanks Jim. Looks like a good reason for vetting
>>> this flow out.
>>>
>>> John,
>>> ------------------------------
>>> *From:* Jim Manico <[email-masked]>
>>> *To:* Oleg Gryb <[email-masked]>
>>> *Cc:* "[email-masked]" <[email-masked]>; Liyu Yi <[email-masked]>
>>> *Sent:* Thursday, June 30, 2016 10:25 PM
>>> *Subject:* Re: [OAUTH-WG] Security concern for URI fragment as Implicit
>>> grant
>>>
>>> "Browsers now re-append  fragments across 302 redirects unless they are
>>> explicitly cleared this makes fragment encoding less safe than it was when
>>> originally specified"
>>>
>>> We've discussed access tokens in URI back in 2010 (
>>> https://www.ietf.org/mail-archive/web/oauth/current/msg04043.html).
>>> There were two major objectives when I was saying that it's not secure:
>>>
>>> 1. Fragment is not sent to a server by a browser. When I've asked if
>>> this is true for every browser in the world, nobody was able to answer.
>>> 2. Replacing with POST would mean a significant performance impact in
>>> some high volume implementations (I think it was Goole folks who were
>>> saying this, but I don't remember now).
>>>
>>> So, 6 years later we're at square one with this and I hope that this
>>> time the community will be more successful with getting rid of secrets in
>>> URL.
>>>
>>> BTW, Jim, if you can come up with other scenarios when fragments can
>>> leak, please share. It'll probably help the community with solving this
>>> problem faster than in 6 years.
>>>
>>> Thanks,
>>> Oleg.
>>>
>>>
>>> ------------------------------
>>> *From:* Jim Manico <[email-masked]>
>>> *To:* Liyu Yi <[email-masked]>; [email-masked]
>>> *Sent:* Wednesday, June 29, 2016 7:30 AM
>>> *Subject:* Re: [OAUTH-WG] Security concern for URI fragment as Implicit
>>> grant
>>>
>>> I say yes. But please note I'm very new at this and someone with more
>>> experience will have more to say or correct my comments.
>>> 1) OAuth is a framework and not a standard, per se. Different
>>> authorization servers will have different implementations that are not
>>> necessarily compatible with other service providers. So there is no
>>> standard to break, per se.
>>> 3) Break the "rules" and find a way to submit sensitive data like access
>>> tokens, session information or any other (even short term) sensitive data
>>> in a secure fashion. This includes POST, JSON data payloads over PUT/PATCH
>>> and other verbs - all over well configured HTTPS.
>>> 4) If you really must submit sensitive data over GET , consider
>>> JWT/JWS/JWE (with limited scopes/lifetimes) to provide message level
>>> confidentiality and integrity.
>>> Aloha,
>>>
>>> Jim Manico
>>> Manicode Securityhttps://www.manicode.com
>>>
>>>
>>> We noticed at
>>> <https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30>
>>> https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30, it is
>>> specified that
>>>
>>> For my understanding, the browser keeps the URI fragment in the history,
>>> and this introduces unexpected exposure of the access token. A user without
>>> authorization for the resource can get the access token as long as he has
>>> the access to the browser. This can happen in a shared computer in library,
>>> or for an IT staff who works on other employee’s computer.
>>>
>>> OAuth mailing [email-masked]://www.ietf.org/mailman/listinfo/oauth
>>>
>>>
>>> --
>>>
>>>

---

From: Oleg Gryb <[email-masked]>
Date: Fri, 1 Jul 2016 20:52:48 +0000 (UTC)

John,
Thanks, very useful. However, I'm still trying to figure out why it's dangerous. Fragment doesn't travel to a server in this new flow either. Appending it to Location header is done by the browser who needs to memorize what the original request was. If the original request had a fragment and the browser got redirected, Location header will be appended by the browser.
Are you saying that this is dangerous because the browser would *always* need to store the fragment somewhere in its memory just in case if a server decides to redirect?
So an attack vector here is that an imposter can try to retrieve the fragment from the browser's memory somehow. Is my understanding correct?
Oleg.

      From: John Bradley <[email-masked]>
 To: Oleg Gryb <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; Liyu Yi <[email-masked]>
 Sent: Friday, July 1, 2016 11:33 AM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant
   
>From HTTP/1.1See https://tools.ietf.org/html/rfc7231#section-7.1.2I      f the Location value provided in a 3xx (Redirection) response does   not have a fragment component, a user agent MUST process the

This blog also explores the change.https://blogs.msdn.microsoft.com/ieinternals/2011/05/16/url-fragments-and-redirects/

  

  

 --

---

From: Josh Mandel <[email-masked]>
Date: Fri, 1 Jul 2016 16:56:31 -0400

John,

Could you clarify what you mean by "POST doesn't really work"? Do you just
mean that CORS support (e.g., http://caniuse.com/#feat=cors) isn't
universal, or something more?

On Fri, Jul 1, 2016 at 4:51 PM, John Bradley <[email-masked]> wrote:

>>>> "Browsers now re-append  fragments across 302 redirects unless they
>>>> are explicitly cleared this makes fragment encoding less safe than it was
>>>>  when originally specified" - thanks Jim. Looks like a good reason for
>>>> vetting this flow out.
>>>>
>>>> John,
>>>> *Subject:* Re: [OAUTH-WG] Security concern for URI fragment as
>>>> Implicit grant
>>>>
>>>> "Browsers now re-append  fragments across 302 redirects unless they
>>>> are explicitly cleared this makes fragment encoding less safe than it was
>>>> when originally specified"
>>>>
>>>> *Subject:* Re: [OAUTH-WG] Security concern for URI fragment as
>>>> Implicit grant
>>>>
>>>> 3) Break the "rules" and find a way to submit sensitive data like
>>>> access tokens, session information or any other (even short term) sensitive
>>>> data in a secure fashion. This includes POST, JSON data payloads over
>>>> PUT/PATCH and other verbs - all over well configured HTTPS.
>>>> For my understanding, the browser keeps the URI fragment in the
>>>> history, and this introduces unexpected exposure of the access token. A
>>>> user without authorization for the resource can get the access token as
>>>> long as he has the access to the browser. This can happen in a shared
>>>> computer in library, or for an IT staff who works on other employee’s
>>>> computer.
>>>>

---

From: Justin Richer <[email-masked]>
Date: Fri, 1 Jul 2016 17:00:00 -0400

POST will send things to the server, which isn’t desirable if your client is solely in the browser. postMessage is a browser API and not to be confused with HTTP POST. postMessage messages stay (or can stay) within the browser, which is the intent here.

 — Justin

> On Jul 1, 2016, at 4:56 PM, Josh Mandel <[email-masked]> wrote:
> 
> John,
> 
> Could you clarify what you mean by "POST doesn't really work"? Do you just mean that CORS support (e.g., http://caniuse.com/#feat=cors <http://caniuse.com/#feat=cors>) isn't universal, or something more?
> 
> On Fri, Jul 1, 2016 at 4:51 PM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
> If it is a server app it should be using the code flow with GET or POST as you like.
> 
> If we do a  post message based binding it will be targeted at in browser applications.
> 
> John B.
> 
> On Fri, Jul 1, 2016 at 4:42 PM, Liyu Yi <[email-masked] <mailto:[email-masked]>> wrote:
> BTW, I do not see any significant performance concerns for post. Parsing and executing the Javascript logic for post operation will be on the client side, no extra server load is introduced.
> 
> On Fri, Jul 1, 2016 at 1:35 PM, Liyu Yi <[email-masked] <mailto:[email-masked]>> wrote:
> I think it is a good idea for the working group to revise the fragment part in the spec, since there might be public available tools already implemented this approach and people can end up with a solution with serious security loopholes.
> 
> The re-append issue can be mitigate by a logic on Resource Server which carefully re-writes/removes the fragment in any redirect, if the the redirect can not be avoided.
> 
> -- Liyu
>  
> 
> On Fri, Jul 1, 2016 at 11:33 AM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
>    "http://www.example.org/~tim <http://www.example.org/~tim>" might result in a 303 (See Other)
>    "http://www.example.org/People.html#tim <http://www.example.org/People.html#tim>”
> 
>    "http://www.example.org/index.html#larry <http://www.example.org/index.html#larry>" might result in a 301
>      Location: http://www.example.net/index.html <http://www.example.net/index.html>
> 
>    "http://www.example.net/index.html#larry <http://www.example.net/index.html#larry>", preserving the original
>    fragment identifier.
> 
> 
>> On Jul 1, 2016, at 1:05 PM, Oleg Gryb <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> To: Oleg Gryb <[email-masked] <mailto:[email-masked]>> 
>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>; Liyu Yi <[email-masked] <mailto:[email-masked]>>

---

From: Oleg Gryb <[email-masked]>
Date: Fri, 1 Jul 2016 21:01:52 +0000 (UTC)

AFAIR, they were talking about cost of this additional POST on the server side, which was not good for high volume traffic (millions requests per day). I'll try to dig it out to find more details. 

      From: Liyu Yi <[email-masked]>
 To: John Bradley <[email-masked]> 
Cc: Oleg Gryb <[email-masked]>; Jim Manico <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Friday, July 1, 2016 1:42 PM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant

  

  

 --

---

From: Oleg Gryb <[email-masked]>
Date: Fri, 1 Jul 2016 21:09:57 +0000 (UTC)

> POST will send things to the server, which isn’t desirable if your client is solely in the browserWhy it's not desirable, assuming that we disregard performance? You can generate HTTP POST from JS, e.g. through an AJAX call. What is wrong with this?

      From: Justin Richer <[email-masked]>
 To: Josh Mandel <[email-masked]> 
Cc: Oleg Gryb <[email-masked]>; "<[email-masked]>" <[email-masked]>; Liyu Yi <[email-masked]>
 Sent: Friday, July 1, 2016 2:00 PM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant

John,
Could you clarify what you mean by "POST doesn't really work"? Do you just mean that CORS support (e.g., http://caniuse.com/#feat=cors) isn't universal, or something more?
On Fri, Jul 1, 2016 at 4:51 PM, John Bradley <[email-masked]> wrote:

  

  

 --

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 17:15:02 -0400

Justin is correct.

They may have been trying to avoid the client POST to the token endpoint with the code.  

That is a separate issue from the question of using a fragment encoded GET 302 or a JS POST redirect to return from the authorization endpoint.

The response via the browser is smaller and faster if you are using code.

The direct call via the back channel from the client to the server should not be a big deal in reality.

If they are larger than Google and have a real performance issue we can talk.

In the mean time for server based clients the recommendation is to use a confidential client with code.

John B.
> On Jul 1, 2016, at 5:01 PM, Oleg Gryb <[email-masked]> wrote:
>

---

From: Josh Mandel <[email-masked]>
Date: Fri, 1 Jul 2016 17:16:45 -0400

Thanks Justin,

To clarify: John's comment and my question were about POST. (I do
understand the behavior of HTTP POST and of window.postMessage; these are
totally different things.) From my perspective in SMART Health IT, we use
the OAuth 2.0 authorization code flow, including HTTP POST, in our
authorization
spec <http://docs.smarthealthit.org/authorization/> even for public
clients, and it has worked very well for us, with about a dozen electronic
health record servers supporting this approach. That's why I was curious to
hear John's perspective about limitations.

  -J

On Fri, Jul 1, 2016 at 5:09 PM, Oleg Gryb <[email-masked]> wrote:

> > POST will send things to the server, which isn’t desirable if your
> client is solely in the browser
> Why it's not desirable, assuming that we disregard performance? You can
> generate HTTP POST from JS, e.g. through an AJAX call. What is wrong with
> this?
>
>
> *From:* Justin Richer <[email-masked]>
> *To:* Josh Mandel <[email-masked]>
> *Cc:* Oleg Gryb <[email-masked]>; "<[email-masked]>" <[email-masked]>;
> Liyu Yi <[email-masked]>
> *Sent:* Friday, July 1, 2016 2:00 PM
>
> POST will send things to the server, which isn’t desirable if your client
> is solely in the browser. postMessage is a browser API and not to be
> confused with HTTP POST. postMessage messages stay (or can stay) within the
> browser, which is the intent here.
>
>  — Justin
>
> Could you clarify what you mean by "POST doesn't really work"? Do you
> just mean that CORS support (e.g., http://caniuse.com/#feat=cors) isn't
> https://www.ietf.org/mail-archive/web/oauth/current/msg04043.html). There
> were two major objectives when I was saying that it's not secure:
>
> 1. Fragment is not sent to a server by a browser. When I've asked if this
> is true for every browser in the world, nobody was able to answer.
> 2. Replacing with POST would mean a significant performance impact in some
> high volume implementations (I think it was Goole folks who were saying
> this, but I don't remember now).
>
> So, 6 years later we're at square one with this and I hope that this time
> the community will be more successful with getting rid of secrets in URL.
>
> BTW, Jim, if you can come up with other scenarios when fragments can leak,
> please share. It'll probably help the community with solving this problem
> faster than in 6 years.
>
> Thanks,
> Oleg.
>
>
> We noticed at <https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30>

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 17:21:49 -0400

If the attacker can modify the redirect URI to anything like an embedded add that will do a 302 redirect then the recipient of the redirect can load JS to extract the access token.

This has happened at Facebook so many times I have lost count.   It is not theoretical, it happens all the time.
One reason you need to do exact redirect_uri matching in the AS but people are not so good at following that and take redirects to any URI on the host in some cases.

When used correctly for a real in web client it is fine.  For a web server client it introduces unnecessary risks over the code flow, or hybrid flow using POST.

Others may differ with my opinion.

John B.

> On Jul 1, 2016, at 4:52 PM, Oleg Gryb <[email-masked]> wrote:
> 
> John,
>

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 17:26:45 -0400

HEART only supports web server clients at the moment.   That might change in future to support native apps if that an be made to support the security requirements of Heath IT.

So the thing HTTP POST responses won’t work well for is a type of in browser single page OAuth client.  That still needs fragment encoded responses or the new post-message Java Script API approach.

John B.

> On Jul 1, 2016, at 5:16 PM, Josh Mandel <[email-masked]> wrote:
> 
> Thanks Justin,
> 
> To clarify: John's comment and my question were about POST. (I do understand the behavior of HTTP POST and of window.postMessage; these are totally different things.) From my perspective in SMART Health IT, we use the OAuth 2.0 authorization code flow, including HTTP POST, in our authorization spec <http://docs.smarthealthit.org/authorization/> even for public clients, and it has worked very well for us, with about a dozen electronic health record servers supporting this approach. That's why I was curious to hear John's perspective about limitations.
> 
>   -J
> 
> On Fri, Jul 1, 2016 at 5:09 PM, Oleg Gryb <[email-masked] <mailto:[email-masked]>> wrote:
> > POST will send things to the server, which isn’t desirable if your client is solely in the browser
> Why it's not desirable, assuming that we disregard performance? You can generate HTTP POST from JS, e.g. through an AJAX call. What is wrong with this?
> 
> 
> From: Justin Richer <[email-masked] <mailto:[email-masked]>>
> To: Josh Mandel <[email-masked] <mailto:[email-masked]>> 
> Cc: Oleg Gryb <[email-masked] <mailto:[email-masked]>>; "<[email-masked] <mailto:[email-masked]>>" <[email-masked] <mailto:[email-masked]>>; Liyu Yi <[email-masked] <mailto:[email-masked]>>
>> On Jul 1, 2016, at 4:56 PM, Josh Mandel <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> 
> John,
>

---

From: Josh Mandel <[email-masked]>
Date: Fri, 1 Jul 2016 17:33:16 -0400

John,

I appreciate your response. I'm hoping you can clarify why you say that
"HTTP POST... won't work well for... [a] single page OAuth client"?

We commonly build single-page apps that act as OAuth clients for SMART
(e.g. this sample app
<https://github.com/smart-on-fhir/sample-apps/tree/9cd49fe5753a70795c73e1fe58297591c23ca591/authorize>
),
and we've had good experience with the technique. Could you elaborate?

  -J

On Fri, Jul 1, 2016 at 5:26 PM, John Bradley <[email-masked]> wrote:

> HEART only supports web server clients at the moment.   That might change
> in future to support native apps if that an be made to support the security
> requirements of Heath IT.
>
> So the thing HTTP POST responses won’t work well for is a type of in
> browser single page OAuth client.  That still needs fragment encoded
> responses or the new post-message Java Script API approach.
>
> John B.
>
>
> the OAuth 2.0 authorization code flow, including HTTP POST, in our authorization

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 17:45:18 -0400

I don’t think the post response mode is supported by heart so I suspect that we are talking about different things.

You are probably using the supported code flow that uses a 302 get to return the code to the OAuth client on the server.  
The Web server is then acting as a confidential client to exchange the code via a POST (different POST) with the AS token_endpoint.

The Token endpoint will return a access token (AT) and optional refresh token (RT).

The web page may be getting the server to make the OAuth calls on it’s behalf to the Resource Server, or possibly you are passing the AT from the server back to a Java script app that is using CORES to make calls directly to the RS without going through the Web server.

Passing the AT back to the user agent from the client is not recommended. 

For in browser clients where the JS is using the AT to make the calls directly to the RS via CORES the recommended approach is to use the fragment encoded response via a 302 to deliver the AT directly to the client (It never hits the backend Web server).

However I believe In browser OAuth clients are not currently supported in HEART, so I am not quite sure what you are doing.

Perhaps Justin has a better answer.

John B.

> On Jul 1, 2016, at 5:33 PM, Josh Mandel <[email-masked]> wrote:
> 
> John,
> 
> I appreciate your response. I'm hoping you can clarify why you say that "HTTP POST... won't work well for... [a] single page OAuth client"?
> 
> We commonly build single-page apps that act as OAuth clients for SMART (e.g. this sample app <https://github.com/smart-on-fhir/sample-apps/tree/9cd49fe5753a70795c73e1fe58297591c23ca591/authorize> ), and we've had good experience with the technique. Could you elaborate?
> 
>   -J
> 
> On Fri, Jul 1, 2016 at 5:26 PM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jul 1, 2016, at 5:16 PM, Josh Mandel <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Thanks Justin,
>>

---

From: Josh Mandel <[email-masked]>
Date: Fri, 1 Jul 2016 17:52:17 -0400

I think the confusion here is that I'm not using HEART's OAuth profiles :-)

I'm using the SMART profiles, where we do specify the use of an
authorization code grant even for browser-based public clients (in which
case, no client_secret is issued or used). I'm just trying to understand
your perspective eon why this "won't work well". Perhaps you didn't mean
this comment to refer to browser-based OAuth clients generally?

  -Josh

On Fri, Jul 1, 2016 at 5:45 PM, John Bradley <[email-masked]> wrote:

> I don’t think the post response mode is supported by heart so I suspect
> that we are talking about different things.
>
> You are probably using the supported code flow that uses a 302 get to
> return the code to the OAuth client on the server.
> The Web server is then acting as a confidential client to exchange the
> code via a POST (different POST) with the AS token_endpoint.
>
> The web page may be getting the server to make the OAuth calls on it’s
> behalf to the Resource Server, or possibly you are passing the AT from the
> server back to a Java script app that is using CORES to make calls directly
> to the RS without going through the Web server.
>
> For in browser clients where the JS is using the AT to make the calls
> directly to the RS via CORES the recommended approach is to use the
> fragment encoded response via a 302 to deliver the AT directly to the
> client (It never hits the backend Web server).
>
> However I believe In browser OAuth clients are not currently supported in
> HEART, so I am not quite sure what you are doing.
>
> <https://github.com/smart-on-fhir/sample-apps/tree/9cd49fe5753a70795c73e1fe58297591c23ca591/authorize> ),
>>> client is solely in the browser. postMessage is a browser API and not to be

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 18:01:40 -0400

I am making a distinction between a browser talking to a Web server that is acting as a OAuth Client POST response mode = good , and a oauth client running in the browser user agent as a Java script application (that can’t directly capture a POST response back to the server)

So it depends on where the client is actually running.

Are you saying that you are using a 302 redirect from the authorization endpoint back to the server hosting the JS and then loading the JS including the code and then using CORES  to exchange the code for a AT?

You can do that but I don’t think a public client like that is more secure than just using the fragment encoded response and is more work.
It also may give the server a false sense of security.

John B.
> On Jul 1, 2016, at 5:52 PM, Josh Mandel <[email-masked]> wrote:
> 
> I'm using the SMART profiles, where we do specify the use of an authorization code grant even for browser-based public clients (in which case, no client_secret is issued or used). I'm just trying to understand your perspective eon why this "won't work well". Perhaps you didn't mean this comment to refer to browser-based OAuth clients generally?
> 
>   -Josh
> 
> On Fri, Jul 1, 2016 at 5:45 PM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jul 1, 2016, at 5:33 PM, Josh Mandel <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> John,
>>

---

From: Jim Manico <[email-masked]>
Date: Sat, 2 Jul 2016 00:13:08 +0200

HTTP POST requests are also a lot more difficult to cache server side compared to URI's which are easier to cache. I'm likely not explaining this well, but I believe it's a webscale concern.

--
Jim Manico
@Manicode

> On Jul 1, 2016, at 11:01 PM, Oleg Gryb <[email-masked]> wrote:
> 
>>>> We noticed at https://tools.ietf.org/html/draft-ietf-oauth-v2-31#page-30, it is specified that
>>>>

---

From: Josh Mandel <[email-masked]>
Date: Fri, 1 Jul 2016 18:13:51 -0400

Thanks John! Yes, we're following the CORS based flow you've described
below (though I should note that the actual redirection back to the client
could be a 302, or could be a simple Web link that the user follows from an
authorization page; this is up to the authorization server).

Overall I don't argue that this flow is "more secure" than the implicit
flow -- though I believe it does help client developers avoid some common
pitfalls. (For example, clients that, through careless programming or poor
understanding of the spec, fail to validate incoming "state" are still not
susceptible to arbitrary token injection, which means at least they won't
readily be tricked into using a token designated for an entirely different
client. With poorly written implicit flow clients, this is an issue.)

That said, I wasn't aiming to discuss the relative security; just wanted to
make sure I knew what you meant by "won't work well".

Thanks again!

-Josh
On Jul 1, 2016 18:02, "John Bradley" <[email-masked]> wrote:

> I am making a distinction between a browser talking to a Web server that
> is acting as a OAuth Client POST response mode = good , and a oauth client
> running in the browser user agent as a Java script application (that can’t
> directly capture a POST response back to the server)
>
> Are you saying that you are using a 302 redirect from the authorization
> endpoint back to the server hosting the JS and then loading the JS
> including the code and then using CORES  to exchange the code for a AT?
>
> You can do that but I don’t think a public client like that is more secure
> than just using the fragment encoded response and is more work.
>>> HEART only supports web server clients at the moment.   That might
>>> change in future to support native apps if that an be made to support the
>>> security requirements of Heath IT.
>>>
>>>> just mean that CORS support (e.g., http://caniuse.com/#feat=cors)
>>>> isn't universal, or something more?
>>>>
>>>> BTW, I do not see any significant performance concerns for post.
>>>> Parsing and executing the Javascript logic for post operation will be on
>>>> the client side, no extra server load is introduced.
>>>>

---

From: Oleg Gryb <[email-masked]>
Date: Fri, 1 Jul 2016 22:44:35 +0000 (UTC)

I'm aware about exploits related to improper redirect_url validation, which was FB case, no qs here,  but I still can't understand if appending a fragment to Location by a browser makes this exploit simpler or can lead to other exploits that have not been described yet.

 Sent: Friday, July 1, 2016 2:21 PM
   
If the attacker can modify the redirect URI to anything like an embedded add that will do a 302 redirect then the recipient of the redirect can load JS to extract the access token.
This has happened at Facebook so many times I have lost count.   It is not theoretical, it happens all the time.One reason you need to do exact redirect_uri matching in the AS but people are not so good at following that and take redirects to any URI on the host in some cases.
When used correctly for a real in web client it is fine.  For a web server client it introduces unnecessary risks over the code flow, or hybrid flow using POST.
Others may differ with my opinion.
John B.

 

  

  

 --

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 18:48:35 -0400

If the in browser JS checks that it is talking to the correct AS making a authorization request that is no worse that making a request to exchange code via CORS.  Attacks where code is stolen and replayed to the client to impersonate the user are also possable That is the reason for the id_token with signed nonce, as state can be manipulated in some cases as it is not signed. 

That is a different discussion however.

John B.

> On Jul 1, 2016, at 6:13 PM, Josh Mandel <[email-masked]> wrote:
> 
> Thanks John! Yes, we're following the CORS based flow you've described below (though I should note that the actual redirection back to the client could be a 302, or could be a simple Web link that the user follows from an authorization page; this is up to the authorization server).
> 
> Overall I don't argue that this flow is "more secure" than the implicit flow -- though I believe it does help client developers avoid some common pitfalls. (For example, clients that, through careless programming or poor understanding of the spec, fail to validate incoming "state" are still not susceptible to arbitrary token injection, which means at least they won't readily be tricked into using a token designated for an entirely different client. With poorly written implicit flow clients, this is an issue.)
> 
> That said, I wasn't aiming to discuss the relative security; just wanted to make sure I knew what you meant by "won't work well".
> 
> Thanks again!
> 
> -Josh
> 
> On Jul 1, 2016 18:02, "John Bradley" <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jul 1, 2016, at 5:52 PM, Josh Mandel <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 19:06:45 -0400

I take it that Web-hosted client resource is part of the client.

I think perhaps you have client and resource serve r mixed up a bit in your diagram.

Yes you could do that but it is not a great way to build the client as it will blow away context.  
You can do it but people generally want to start the application in the browser first and then call out to the IdP  in a iFrame.

What you propose would work more or less.  I don’t see it as a pattern that I would necessarily recommend over the current fragment encoding.

If we mover to post message it would include API  for logout and session management, not just login.

John B.

> On Jul 1, 2016, at 6:43 PM, Liyu Yi <[email-masked]> wrote:
> 
> Understood there is an Authorization Code grant type; here I am more focusing on the Implicit grant type. 
>   
> also when I mentioned POST, I did not mean postMessage, it is simply the HTTP POST. Specifically it is more like this ...
> 
> 
> 
> 4.2 <https://tools.ietf.org/html/rfc6749#section-4.2>.  Implicit Grant (modified)
> 
>      +----------+
>      | Resource |
>      |  Owner   |
>      |          |
>      +----------+
>           ^
>           |
>          (B)
>      +----|-----+          Client Identifier     +---------------+
>      |         -+----(A)-- & Redirection URI --->|               |
>      |  User-   |                                | Authorization |
>      |  Agent  -|----(B)-- User authenticates -->|     Server    |
>      |          |                                |               |
>      |          |<---(C)- Response embedded JS -<|               |
>      |          |          with Access Token     +---------------+
>      |          |            in JS content, which will be posted to Resource Server
>      |          |                                +---------------+
>      |          |----(D)-- JS post to RS URI --->|   Web-Hosted  |
>      |          |         with Access Token      |     Client    |
>      |          |                                |    Resource   |
>      |     (F)  |<---(E)----- RS Script --------<|               |
>      |          |         with Access Token      +---------------+
>      +-|--------+
>        |    |
>       (A)  (G) Access Token
>        |    |
>        ^    v
>      +---------+
>      |         |
>      |  Client |
>      |         |
>      +---------+
> 
> 
> 
>                        Figure 4: Implicit Grant Flow
> 
>    The flow illustrated in Figure 4 includes the following steps:
> 
>    (A)  The client initiates the flow by directing the resource owner's
>         user-agent to the authorization endpoint.  The client includes
>         its client identifier, requested scope, local state, and a
>         redirection URI to which the authorization server will send the
>         user-agent back once access is granted (or denied).
> 
>    (B)  The authorization server authenticates the resource owner (via
>         the user-agent) and establishes whether the resource owner
>         grants or denies the client's access request.
> 
>         server responds with a JavaScript logic which automatically posts to 
>         "redirection" URI provided earlier.  The JavaScript includes
>    (D)  The user-agent does the post with the access token. Granted,  
>                   user agent can actually do post without the access token  in a different iframe, 
>                   then use postMessage to pass the token over, but I do not see why get it need that compexity.
> 
> 
> On Fri, Jul 1, 2016 at 3:13 PM, Josh Mandel <[email-masked] <mailto:[email-masked]>> wrote:

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 20:18:24 -0400

No not if it is a GET back to the same URI that loaded the JS and it is cashed.   At least that was the design by Facebook, Google and other at the time.

John B.

> On Jul 1, 2016, at 7:26 PM, Liyu Yi <[email-masked]> wrote:
> 
> John,
> 
> I am a little bit confused :)
> Are you talking about a SPA type of client application and concerning the POST will reload the browser DOM from the RS domain? If that is the case, even the current spec using a redirect with fragment in URL will have the same behavior, right?  
> 
> On Fri, Jul 1, 2016 at 4:06 PM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jul 1, 2016, at 6:43 PM, Liyu Yi <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Oleg Gryb <[email-masked]>
Date: Sat, 2 Jul 2016 00:39:31 +0000 (UTC)

I think, the intention was not to share AT with the web-hosted client resource. As you can see in the original flow the latter never receives the AT, it simply provides code that can get AT from a fragment and some UI. In the modified flow AT is sent to the web-hosted client resource, which makes security worse in my view, because you have your AT exposed in two places now - in the User Agent *and* in the web-hosted client resource.

      From: John Bradley <[email-masked]>
 To: Liyu Yi <[email-masked]> 
Cc: Oleg Gryb <[email-masked]>; "<[email-masked]>" <[email-masked]>
 Sent: Friday, July 1, 2016 4:06 PM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant
   
Yes you could do that but it is not a great way to build the client as it will blow away context.  You can do it but people generally want to start the application in the browser first and then call out to the IdP  in a iFrame.

On Jul 1, 2016, at 6:43 PM, Liyu Yi <[email-masked]> wrote:
Understood there is an Authorization Code grant type; here I am more focusing on the Implicit grant type.   also when I mentioned POST, I did not mean postMessage, it is simply the HTTP POST. Specifically it is more like this ...

4.2. Implicit Grant (modified)
     +----------+
     | Resource |
     |  Owner   |
     |          |
     +----------+
          ^
          |
         (B)

   (D)  The user-agent does the post with the access token. Granted,                    user agent can actually do post without the access token  in a different iframe,                   then use postMessage to pass the token over, but I do not see why get it need that compexity.

On Fri, Jul 1, 2016 at 3:13 PM, Josh Mandel <[email-masked]> wrote:

Thanks John! Yes, we're following the CORS based flow you've described below (though I should note that the actual redirection back to the client could be a 302, or could be a simple Web link that the user follows from an authorization page; this is up to the authorization server). Overall I don't argue that this flow is "more secure" than the implicit flow -- though I believe it does help client developers avoid some common pitfalls. (For example, clients that, through careless programming or poor understanding of the spec, fail to validate incoming "state" are still not susceptible to arbitrary token injection, which means at least they won't readily be tricked into using a token designated for an entirely different client. With poorly written implicit flow clients, this is an issue.) That said, I wasn't aiming to discuss the relative security; just wanted to make sure I knew what you meant by "won't work well".Thanks again! -JoshOn Jul 1, 2016 18:02, "John Bradley" <[email-masked]> wrote:

I am making a distinction between a browser talking to a Web server that is acting as a OAuth Client POST response mode = good , and a oauth client running in the browser user agent as a Java script application (that can’t directly capture a POST response back to the server)
So it depends on where the client is actually running.
Are you saying that you are using a 302 redirect from the authorization endpoint back to the server hosting the JS and then loading the JS including the code and then using CORES  to exchange the code for a AT?
You can do that but I don’t think a public client like that is more secure than just using the fragment encoded response and is more work.It also may give the server a false sense of security.
John B.

You are probably using the supported code flow that uses a 302 get to return the code to the OAuth client on the server.  The Web server is then acting as a confidential client to exchange the code via a POST (different POST) with the AS token_endpoint.

On Jul 1, 2016, at 5:33 PM, Josh Mandel <[email-masked]> wrote:
John,
I appreciate your response. I'm hoping you can clarify why you say that "HTTP POST... won't work well for... [a] single page OAuth client"?
We commonly build single-page apps that act as OAuth clients for SMART (e.g. this sample app ), and we've had good experience with the technique. Could you elaborate?
  -J

On Jul 1, 2016, at 5:16 PM, Josh Mandel <[email-masked]> wrote:
Thanks Justin,
To clarify: John's comment and my question were about POST. (I do understand the behavior of HTTP POST and of window.postMessage; these are totally different things.) From my perspective in SMART Health IT, we use the OAuth 2.0 authorization code flow, including HTTP POST, in our authorization spec even for public clients, and it has worked very well for us, with about a dozen electronic health record servers supporting this approach. That's why I was curious to hear John's perspective about limitations.
  -J

 

John,

  

  

 --

---

From: John Bradley <[email-masked]>
Date: Fri, 1 Jul 2016 20:53:56 -0400

yes
> On Jul 1, 2016, at 8:39 PM, Oleg Gryb <[email-masked]> wrote:
>

---

From: Oleg Gryb <[email-masked]>
Date: Sat, 2 Jul 2016 01:14:53 +0000 (UTC)

As John has already pointed out - you're confusing RS with the web-hosted client resource.

 Sent: Friday, July 1, 2016 6:11 PM
   
I would say AT is supposed to be consumed by the Resource Server. Although the original spec does not show how AT is used by the client, but the AT will be sent out, most likely by the browser directly, or in a rare case if the client application has another channel, indirectly.
The fact is that the AT is not sent in the 1st GET request does leave the RS JavaScript a chance to choose the right method, say an ajax POST. But AT is NOT  a secrete to RS.

On Fri, Jul 1, 2016 at 5:53 PM, John Bradley <[email-masked]> wrote:

yes

 

 

John,

  

  

 --

---

From: Oleg Gryb <[email-masked]>
Date: Sat, 2 Jul 2016 01:43:33 +0000 (UTC)

You know, I've tried to solve this problem 6 years ago and I failed, but I'm glad that community is looking to this again and I hope that John and others will eventually come up with something better than what we have now.
If I come up with a sane idea, I'll definitely share.

      From: Liyu Yi <[email-masked]>
 To: Oleg Gryb <[email-masked]> 
Cc: John Bradley <[email-masked]>; "<[email-masked]>" <[email-masked]>
 Sent: Friday, July 1, 2016 6:37 PM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant
   
John and Oleg, good point. I missed that. So in this case the "web-hosted client resource" is a party different from the RS and is also different from AS and is not supposed to access to AT. But I guess this "web-hosted client resource" must be trusted, since its JS has access the the AT on the browser side anyways.
Maybe the secure way is to let the AS return an HTML with embedded JS and AT. It does make the AS do more work, but it cuts out the need of "web-hosted client resource".
Comments?
-- Liyu
On Fri, Jul 1, 2016 at 6:14 PM, Oleg Gryb <[email-masked]> wrote:

   

yes

 

 

John,

  

  

 --

---

From: Oleg Gryb <[email-masked]>
Date: Sat, 2 Jul 2016 05:26:03 +0000 (UTC)

Here is actually some idea. John, please let me know if there is anything wrong with this.
1. At step "C" Auth Server instead of serving a redirect will return a payload in a response with a JS  called on page load that will do the redirect.
Something like below where I use JsRender, but it can be any HTML renderer implemented in JS
<script>function doRedirect() {var redirect_uri = "yyyy"; // we got it from ASvar data = [    "access_token": "xxxxx", // we got it from AS    ....                                    // other params if needed]$.get(redirect_uri, function(response) {  var script = document.createElement('script'); script.setAttribute('type', 'text/x-jsrender'); script.id = 'template'; script.innerHTML = response;
 var template = $.templates(script); var html = template.render(data); $("#result").html(html);});</script>
<body onload='doRedirect()'><div id="result"></div></body>
Template returned from the web hosted client resource should include something like this:
<form id='token'>   <input type='hidden' value='{{:access_token}}'>   ... other params if needed</form> 
The generated page will be rendered in a browser with all params including access token provided in hidden fields.
Security risk here is the same - user agent has access to AT, but it's the same risk as in the original flow. The benefit - no secrets in URI.

      From: Oleg Gryb <[email-masked]>
 To: Liyu Yi <[email-masked]>; Oleg Gryb <[email-masked]> 
Cc: "<[email-masked]>" <[email-masked]>
 Sent: Friday, July 1, 2016 6:43 PM
 Subject: Re: [OAUTH-WG] Security concern for URI fragment as Implicit grant

 

   

yes

 

 

John,

  

  

 --

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 13:35:22 -0700

I think it is a good idea for the working group to revise the fragment part
in the spec, since there might be public available tools already
implemented this approach and people can end up with a solution with
serious security loopholes.

-- Liyu

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 13:42:03 -0700

-- Liyu

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 15:43:50 -0700

Understood there is an Authorization Code grant type; here I am more
focusing on the Implicit grant type.

also when I mentioned POST, I did not mean postMessage, it is simply the
HTTP POST. Specifically it is more like this ...

4.2 <https://tools.ietf.org/html/rfc6749#section-4.2>.  Implicit Grant
(modified)

     +----------+
     | Resource |
     |  Owner   |
     |          |
     +----------+
          ^
          |
         (B)
     |          |            in JS content, which will be posted to
Resource Server

                  user agent can actually do post without the access
token  in a different iframe,

                  then use postMessage to pass the token over, but I
do not see why get it need that compexity.

On Fri, Jul 1, 2016 at 3:13 PM, Josh Mandel <[email-masked]> wrote:

> That said, I wasn't aiming to discuss the relative security; just wanted
> to make sure I knew what you meant by "won't work well".
>
> Thanks again!
>
> -Josh
>> You can do that but I don’t think a public client like that is more
>> secure than just using the fragment encoded response and is more work.
>>> However I believe In browser OAuth clients are not currently supported
>>> in HEART, so I am not quite sure what you are doing.
>>>
>>>>> Why it's not desirable, assuming that we disregard performance? You
>>>>> can generate HTTP POST from JS, e.g. through an AJAX call. What is wrong
>>>>> with this?
>>>>>
>>>>>
>>>>> The re-append issue can be mitigate by a logic on Resource Server
>>>>> which carefully re-writes/removes the fragment in any redirect, if the the

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 16:05:01 -0700

For Jim's comment

"HTTP POST requests are also a lot more difficult to cache server side
compared to URI's which are easier to cache. I'm likely not explaining this
well, but I believe it's a webscale concern."

I would say, most of the OAuth case will be using HTTPS.  and caching with
HTTPS is only possible at the end point where SSL/TLS is terminated. when
it goes to the server side, it is all about turning the post data to the
cache key,  some logic is required, but does this have a serious
performance issue?

However, I do realized that if fetching the resource is implemented as a
POST, the POST response is typically not cached. For this, we might be able
to use the POST to establish HTTP session and then use the GET to fetch the
resource, and with right logic to control the caching behavior. BTW,
caching itself also has security implication.

On Fri, Jul 1, 2016 at 3:44 PM, Oleg Gryb <[email-masked]> wrote:

> I'm aware about exploits related to improper redirect_url validation,
> which was FB case, no qs here,  but I still can't understand if appending a
> fragment to Location by a browser makes this exploit simpler or can lead to
> other exploits that have not been described yet.
>
>
> *From:* John Bradley <[email-masked]>
> *Sent:* Friday, July 1, 2016 2:21 PM
>
> If the attacker can modify the redirect URI to anything like an embedded
> add that will do a 302 redirect then the recipient of the redirect can load
> JS to extract the access token.
>
> One reason you need to do exact redirect_uri matching in the AS but people
> are not so good at following that and take redirects to any URI on the host
> in some cases.
>
> When used correctly for a real in web client it is fine.  For a web server
> client it introduces unnecessary risks over the code flow, or hybrid flow
> using POST.
>
> Thanks, very useful. However, I'm still trying to figure out why it's
> dangerous. Fragment doesn't travel to a server in this new flow either.
> Appending it to Location header is done by the browser who needs to
> memorize what the original request was. If the original request had a
> fragment and the browser got redirected, Location header will be appended
> by the browser.
>
> Are you saying that this is dangerous because the browser would *always*
> need to store the fragment somewhere in its memory just in case if a server
> decides to redirect?
>
> So an attack vector here is that an imposter can try to retrieve the
> fragment from the browser's memory somehow. Is my understanding correct?
>
> Oleg.
>
>
> *From:* John Bradley <[email-masked]>
> *Sent:* Friday, July 1, 2016 11:33 AM

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 16:26:22 -0700

John,

I am a little bit confused :)
Are you talking about a SPA type of client application and concerning the
POST will reload the browser DOM from the RS domain? If that is the case,
even the current spec using a redirect with fragment in URL will have the
same behavior, right?

On Fri, Jul 1, 2016 at 4:06 PM, John Bradley <[email-masked]> wrote:

> You can do it but people generally want to start the application in the
> browser first and then call out to the IdP  in a iFrame.
>
> What you propose would work more or less.  I don’t see it as a pattern
> that I would necessarily recommend over the current fragment encoding.
>
>>>>>> Could you clarify what you mean by "POST doesn't really work"? Do
>>>>>> you just mean that CORS support (e.g., http://caniuse.com/#feat=cors)
>>>>>> I think it is a good idea for the working group to revise the
>>>>>> fragment part in the spec, since there might be public available tools
>>>>>> already implemented this approach and people can end up with a solution
>>>>>> with serious security loopholes.
>>>>>>
>>>>>> 2) Sensitive data in a URI is a bad idea. They leak all over the
>>>>>> place even over HTTPS. Even in fragments.

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 18:11:01 -0700

I would say AT is supposed to be consumed by the Resource Server. Although
the original spec does not show how AT is used by the client, but the AT
will be sent out, most likely by the browser directly, or in a rare case if
the client application has another channel, indirectly.

The fact is that the AT is not sent in the 1st GET request does leave the
RS JavaScript a chance to choose the right method, say an ajax POST. But AT
is NOT  a secrete to RS.

On Fri, Jul 1, 2016 at 5:53 PM, John Bradley <[email-masked]> wrote:

> I think, the intention was not to share AT with the web-hosted client
> resource. As you can see in the original flow the latter never receives the
> AT, it simply provides code that can get AT from a fragment and some UI. In
> the modified flow AT is sent to the web-hosted client resource, which makes
> security worse in my view, because you have your AT exposed in two places
> now - in the User Agent *and* in the web-hosted client resource.
>
>
>
> *To:* Liyu Yi <[email-masked]>
> *Cc:* Oleg Gryb <[email-masked]>; "<[email-masked]>" <[email-masked]>
> *Sent:* Friday, July 1, 2016 4:06 PM

---

From: Liyu Yi <[email-masked]>
Date: Fri, 1 Jul 2016 18:37:10 -0700

John and Oleg, good point. I missed that. So in this case the "web-hosted
client resource" is a party different from the RS and is also different
from AS and is not supposed to access to AT. But I guess this "web-hosted
client resource" must be trusted, since its JS has access the the AT on the
browser side anyways.

Maybe the secure way is to let the AS return an HTML with embedded JS and
AT. It does make the AS do more work, but it cuts out the need of
"web-hosted client resource".

Comments?

-- Liyu

On Fri, Jul 1, 2016 at 6:14 PM, Oleg Gryb <[email-masked]> wrote:

> *From:* Liyu Yi <[email-masked]>
> *To:* John Bradley <[email-masked]>
> *Sent:* Friday, July 1, 2016 6:11 PM
>