Subject: [OAUTH-WG] Downloading and uploading files by using OAuth in C# language on the Dropbox Platform without creating a new app on the Dropbox Platform to get applicationkey and secretkey?

From: Riyadh Biyram <[email-masked]>
Date: Thu, 22 Dec 2016 12:49:35 +0100

Hello,

I use currently the OAuth technique and I have a question and I hope,
you can help me?

I would like to know how can I use OAuth 2.0 (within C# WPF
application or any langauge to achieve the request) to download and
upload files from Dropbox. It appears that the OAuth 2.0 works by
forwarding you to a Dropbox Platform and getting you confirm details
for example that is means registering the application with external
providers(Dropbox Platform API) to get the application key and secret
key.

(creating a new application on the Dropbox platform

to get applicationkey and secret key

 https://www.dropbox.com/developers/apps/create).

How can I use it without application key and secret key direct to
connect and maybe get the application key with secret key in
background without showing anything to the user of the application for
example like "Screenpresso" software with this software you don't need
to get applciation key or secret key only you sign in by the email and
password to grant access the features.

If there are other extra techniques, please write them to my email.

Thanks in advance.

Best regards,

Riyadh Biyram

*Riyadh Biyram*
Software Engineer & Software Developer
m:  + <555-77777>49 (0) 1577 858 6688   |    e:[email-masked]
<[email-masked]> Skype :riyadh.biyram

---

From: Jim Manico <[email-masked]>
Date: Tue, 27 Dec 2016 07:52:37 -1000

Riyadh,

You best off reading the Dropbox OAuth guide and asking Dropbox support with your questions. Each provider does OAuth a little bit differently.

https://www.dropbox.com/developers/reference/oauth-guide

Respectfully,
--
Jim Manico
@Manicode

> On Dec 22, 2016, at 1:49 AM, Riyadh Biyram <[email-masked]> wrote:
> 
> 
> Hello,
> 
> I use currently the OAuth technique and I have a question and I hope, you can help me?
> 
> I would like to know how can I use OAuth 2.0 (within C# WPF application or any langauge to achieve the request) to download and upload files from Dropbox. It appears that the OAuth 2.0 works by forwarding you to a Dropbox Platform and getting you confirm details for example that is means registering the application with external providers(Dropbox Platform API) to get the application key and secret key.
> How can I use it without application key and secret key direct to connect and maybe get the application key with secret key in background without showing anything to the user of the application for example like "Screenpresso" software with this software you don't need to get applciation key or secret key only you sign in by the email and password to grant access the features.
>  
> m:  +49 (0) 1577 858 6688   |    e:[email-masked] Skype :riyadh.biyram 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth