Subject: [OAUTH-WG] More Criticism of JOSE

From: Mike Schwartz <[email-masked]>
Date: Wed, 15 Mar 2017 10:43:06 -0500

Sorry to be the bearer of bad news, but here's a negative review of 
JOSE:

JOSE (Javascript Object Signing and Encryption) is a Bad Standard That 
Everyone Should Avoid
  
https://paragonie.com/blog/2017/03/jwt-json-web-tokens-is-bad-standard-that-everyone-should-avoid

- Mike

---

From: Sergey Beryozkin <[email-masked]>
Date: Wed, 15 Mar 2017 15:46:22 +0000

and everyone should now start using the most secure alternative proposed 
in that very light in analysis article :-)

Sergey
On 15/03/17 15:43, Mike Schwartz wrote:
> Sorry to be the bearer of bad news, but here's a negative review of JOSE:
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Wed, 15 Mar 2017 19:50:02 +0000

The bulk of this seems to be about applications that don't verify that the crypto algorithms that were used in a JWT are acceptable in the application context.  While I know that some people would like crypto to be magic pixie dust that you can sprinkle on an application to get crypto goodness, it will never be that simple.  Crypto algorithms that are thought to be good today will be deprecated later.  Apps that keep allowing them to be used will be vulnerable.  The JOSE specs requiring that applications be aware of the algorithms used is a good and necessary thing for long-term security - not a problem with the specs.

That said, of course some implementers will get things wrong.  To the extent that we can help them understand what they actually need to do to use the specifications securely, we obviously should.  Perhaps we should write an article for oauth.net talking about some of these issues?  Maybe a few of us can get together in Chicago and work on that.

I'm looking forward to seeing many of you in 1.5 weeks!

				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of Sergey Beryozkin
Sent: Wednesday, March 15, 2017 8:46 AM
To: [email-masked]
Subject: Re: [OAUTH-WG] More Criticism of JOSE

and everyone should now start using the most secure alternative proposed in that very light in analysis article :-)

Sergey

---

From: Antonio Sanso <[email-masked]>
Date: Wed, 15 Mar 2017 20:40:01 +0000

hi Mike,

while I am the original author of one of the mentioned article in the blog post (http://blog.intothesymmetry.com/2017/03/critical-vulnerability-in-json-web.html) I do not share entirely the criticism.
Said that, I must really admit that some of the cryptographic choices made specially in JWE are really questionable.

regards

antonio

---

From: Mike Jones <[email-masked]>
Date: Wed, 15 Mar 2017 21:06:43 +0000

Will you be in Chicago, Antonio?  If so, maybe you can sit down with us and work on advice to implementers.

				Cheers,
				-- Mike

-----Original Message-----
From: Antonio Sanso [mailto:[email-masked]] 
Sent: Wednesday, March 15, 2017 1:40 PM
To: Mike Jones <[email-masked]>
Cc: Sergey Beryozkin <[email-masked]>; [email-masked]
Subject: Re: [OAUTH-WG] More Criticism of JOSE

hi Mike,

regards

antonio

On Mar 15, 2017, at 8:50 PM, Mike Jones <[email-masked]> wrote:

> and everyone should now start using the most secure alternative 
> proposed in that very light in analysis article :-)
> 
> Sergey
>> JOSE (Javascript Object Signing and Encryption) is a Bad Standard 
>> That Everyone Should Avoid
>> 
>> https://paragonie.com/blog/2017/03/jwt-json-web-tokens-is-bad-standar
>> d
>> -that-everyone-should-avoid
>> 
>> 
>> - Mike
>>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Mar 2017 22:16:45 +0100

> On 15 Mar 2017, at 22:06, Mike Jones <[email-masked]> wrote:
> 

And maybe we can also work out what part of that advice (and possibly which additional advice) applies to COSE.

Grüße, Carsten

---

From: Antonio Sanso <[email-masked]>
Date: Thu, 16 Mar 2017 08:31:40 +0000

hi Mike

> Will you be in Chicago, Antonio?  If so, maybe you can sit down with us and work on advice to implementers.

Unluckily not. FWIW I will be at https://zisc.ethz.ch/oauth-security-workshop-2017-cfp/. And I’d be glad to sit down with you and try to help if you are around….

regards

antonio

---

From: Mike Jones <[email-masked]>
Date: Thu, 16 Mar 2017 19:36:11 +0000

It would be great to talk to you at the OAuth security worship, Antonio.

Cheers,

-- Mike

From: Antonio Sanso<mailto:[email-masked]>
Sent: Thursday, March 16, 2017 1:31 AM
To: Mike Jones<mailto:[email-masked]>
Cc: Sergey Beryozkin<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [OAUTH-WG] More Criticism of JOSE

hi Mike

regards

antonio