Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-jwt-introspection-response-01.txt

From: [email-masked]
Date: Wed, 22 Aug 2018 12:09:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Web Authorization Protocol WG of the IETF.

        Title           : JWT Response for OAuth Token Introspection
        Authors         : Torsten Lodderstedt
                          Vladimir Dzhuvinov
	Filename        : draft-ietf-oauth-jwt-introspection-response-01.txt
	Pages           : 11
	Date            : 2018-08-22

Abstract:
   This draft proposes an additional JSON Web Token (JWT) based response
   for OAuth 2.0 Token Introspection.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-oauth-jwt-introspection-response/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-oauth-jwt-introspection-response-01
https://datatracker.ietf.org/doc/html/draft-ietf-oauth-jwt-introspection-response-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-oauth-jwt-introspection-response-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Torsten Lodderstedt <[email-masked]>
Date: Wed, 22 Aug 2018 21:12:18 +0200

Hi all,

we just published a new revision of the JWT Introspection Response Draft.

Changes:
* adapted wording to preclude any accept header except "application/jwt" if encrypted responses are required
* use registered alg value RS256 for default signing algorithm
* added text on claims in the token introspection response

We are looking forward for your feedback. 

kind regards,
Torsten. 

> Anfang der weitergeleiteten Nachricht:
> 
> Von: [email-masked]
> Betreff: [OAUTH-WG] I-D Action: draft-ietf-oauth-jwt-introspection-response-01.txt
> Datum: 22. August 2018 um 21:09:10 MESZ
> An: <[email-masked]>
> Kopie: [email-masked]
> Antwort an: [email-masked]
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth