Subject: [OAUTH-WG] Question regarding RFC 7800

From: Robert Lembree <[email-masked]>
Date: Wed, 3 Apr 2019 10:14:48 +0000

Hello folks,

                What is the status of RFC 7800?  We’re finding the need for
this, and wonder what we might be able to do to help move this along?

Regards,

rob

--

Robert Lembrée
Lead Cybersecurity Architect
Innovation & Technology
Industrial Automation Business
Schneider Electric

D  +1 978 975 9971
M  +1 603 494 0559
E   <mailto:[email-masked]> [email-masked]

800 Federal St.
3W-WS179
Andover, MA 01810
United States

 <https://www.schneider-electric.com/en/work/solutions/cybersecurity/>

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 8 Apr 2019 08:35:12 +0200

On 03/04/2019 12:14, Robert Lembree wrote:
> Hello folks,
> 
>                  What is the status of RFC 7800?  We’re finding the need 
> for this, and wonder what we might be able to do to help move this along?
> 
> Regards,
> 
> rob
> 

If I may be so bold to drop a shameless plug for the ACE WG here [1]. As 
you are working with Schneider Electric, the work in ACE (based on 
OAuth, but for Contrained Environments) might be more relevant for you.

We have adopted a constrained profile of RFC 7800 (among other things):
https://datatracker.ietf.org/doc/draft-ietf-ace-cwt-proof-of-possession/

Regards,

Ludwig

[1] https://datatracker.ietf.org/group/ace/documents/

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 8 Apr 2019 12:05:10 +0000

Hi Robert,

the work on RFC 7800 has been completed from the point of view of the OAuth working group.

As Ludwig mentioned below, it is being used by other working groups in the IETF but also by companies as-is.
Even in the OAuth working group we have other documents that build on top of it, such as draft-ietf-oauth-mtls.

Ciao
Hannes

-----Original Message-----
From: OAuth <[email-masked]> On Behalf Of Ludwig Seitz
Sent: Montag, 8. April 2019 08:35
To: [email-masked]
Subject: Re: [OAUTH-WG] Question regarding RFC 7800

On 03/04/2019 12:14, Robert Lembree wrote:
> Hello folks,
>
>                  What is the status of RFC 7800?  We're finding the
> need for this, and wonder what we might be able to do to help move this along?
>
> Regards,
>
> rob
>

If I may be so bold to drop a shameless plug for the ACE WG here [1]. As you are working with Schneider Electric, the work in ACE (based on OAuth, but for Contrained Environments) might be more relevant for you.

Regards,

Ludwig

--
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Apr 2019 14:10:18 +0200

Hi Robert,

This raises the $64000 question: What piece of information made you consider that this draft might need more help?  Maybe there is some miscommunication that we can fix.

Grüße, Carsten

> On Apr 3, 2019, at 12:14, Robert Lembree <Robert.Lembree=[email-masked]> wrote:
> 
> Hello folks,
>                 What is the status of RFC 7800?  We’re finding the need for this, and wonder what we might be able to do to help move this along?
>  
> Regards,
> rob
>  
> --
> Robert Lembrée
> E  [email-masked]
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Robert Lembree <[email-masked]>
Date: Mon, 8 Apr 2019 15:28:14 +0000

Hi Carsten,
	I didn't see any specific issues.  I'm trying to understand where the RFC stands, and why or why not it might be smart to implement and use it as it stands.  My primary concern is compatibility with any anticipated changes to the RFC in advance of wide acceptance.

Regards,
rob

Hi Robert,

Grüße, Carsten

> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Foauth&amp;data=02%7C01%7CRobert.Lembree%40se.com%7C380e5a2c66ee403c895308d6bc1b3992%7C6e51e1adc54b4b39b5980ffe9ae68fef%7C0%7C1%7C636903222454083023&amp;sdata=7WHGrasoqhizYah%2BenrVNEhbizupkYiS5Lnob4azLIs%3D&amp;reserved=0

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
______________________________________________________________________