Subject: [OAUTH-WG] Early IANA registration for Token Exchange Draft

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 1 Apr 2019 11:33:39 +0000

Hi all

The authors of the token exchange draft asked IANA for an early registration of URIs and parameters, token types, claims, etc.

IANA asked me for review and I unfortunately do not know (or remember) why this early registration is needed.

Any reason to do this early registration?

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Brian Campbell <[email-masked]>
Date: Thu, 4 Apr 2019 11:49:09 -0600

The request originated from Ben Kaduk's Discuss ballot on the draft and
suggestion that the URI values be registered.

Some of the relevant messages in the thread:
https://mailarchive.ietf.org/arch/msg/oauth/QiA5PDBsKlApNZIRy3QOttd-JDM
https://mailarchive.ietf.org/arch/msg/oauth/E2eOLE576c_Zw6MK0ysouEbmrrw
https://mailarchive.ietf.org/arch/msg/oauth/GKh_vAtvD3bAcuBJ7OXxquVcrmM
https://mailarchive.ietf.org/arch/msg/oauth/f4tBwgOO2NlhOJobUKNdw2wCPAU

On Mon, Apr 1, 2019 at 5:33 AM Hannes Tschofenig <[email-masked]>
wrote:

> Hi all
>
>
>
> The authors of the token exchange draft asked IANA for an early
> registration of URIs and parameters, token types, claims, etc.
>
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._