Subject: [OAUTH-WG] IETF105 OAuth WG Draft Agenda

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Wed, 10 Jul 2019 18:17:28 -0400

All,

Here is our draft agenda for the two sessions we have planned for Montreal:
https://datatracker.ietf.org/meeting/105/materials/agenda-105-oauth-00

Please, take a look and let us know if you have any comments.

Regards,
 Rifaat & Hannes

---

From: Dick Hardt <[email-masked]>
Date: Wed, 10 Jul 2019 15:19:38 -0700

+1

I like it! :)

On Wed, Jul 10, 2019 at 3:17 PM Rifaat Shekh-Yusef <[email-masked]>
wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Wed, 17 Jul 2019 18:28:29 +0000

I’m coming in late to this party, but I’ve been asked by a few people about how AWS handles request signing and our experiences with it. Given the renewed interest in HTTP request signing and the ongoing work on DPoP, is this something the working group would be interested in hearing about during one of the sessions? I could put together a quick 5-10 minute overview of AWS SigV4 signing and some of the lessons that went into its design.

Thoughts?

--
Annabelle Richard Backman
AWS Identity

From: OAuth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Wednesday, July 10, 2019 at 3:20 PM
To: Rifaat Shekh-Yusef <[email-masked]>
Cc: oauth <[email-masked]>
Subject: Re: [OAUTH-WG] IETF105 OAuth WG Draft Agenda

+1

I like it! :)

On Wed, Jul 10, 2019 at 3:17 PM Rifaat Shekh-Yusef <[email-masked]<mailto:[email-masked]>> wrote:
All,

Regards,
 Rifaat & Hannes

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Wed, 17 Jul 2019 18:46:30 +0000

I’d be interested in hearing that presentation – particularly the “lessons” part.

                                                       -- Mike

From: OAuth <[email-masked]> On Behalf Of Richard Backman, Annabelle
Sent: Wednesday, July 17, 2019 11:28 AM
To: Dick Hardt <[email-masked]>; Rifaat Shekh-Yusef <[email-masked]>
Cc: oauth <[email-masked]>
Subject: Re: [OAUTH-WG] IETF105 OAuth WG Draft Agenda

Thoughts?

From: OAuth <[email-masked]<mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 10, 2019 at 3:20 PM
To: Rifaat Shekh-Yusef <[email-masked]<mailto:[email-masked]>>
Cc: oauth <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OAUTH-WG] IETF105 OAuth WG Draft Agenda

+1

I like it! :)

Here is our draft agenda for the two sessions we have planned for Montreal:
https://datatracker.ietf.org/meeting/105/materials/agenda-105-oauth-00<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F105%2Fmaterials%2Fagenda-105-oauth-00&data=02%7C01%7CMichael.Jones%40microsoft.com%7C442f8853170b476765a608d70ae49ae9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636989849300196584&sdata=GyYwRFPizRnBvNb1u6uAGYNoO816WoyITsbkrsV0rqc%3D&reserved=0>

Regards,
 Rifaat & Hannes

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Foauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7C442f8853170b476765a608d70ae49ae9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636989849300196584&sdata=eMCi%2Bw8gFY6DdSaRcZijuYER%2FrMdu2ZoQg5%2FS4ZEZJE%3D&reserved=0>

---

From: Brian Campbell <[email-masked]>
Date: Fri, 19 Jul 2019 05:39:27 -0600

I'd also be interested.

On Wed, Jul 17, 2019 at 12:47 PM Mike Jones <Michael.Jones=
[email-masked]> wrote:

> *From:* OAuth <[email-masked]> *On Behalf Of * Richard Backman,
> Annabelle
> *Sent:* Wednesday, July 17, 2019 11:28 AM
> *To:* Dick Hardt <[email-masked]>; Rifaat Shekh-Yusef <
> [email-masked]>
> *Cc:* oauth <[email-masked]>
> *Subject:* Re: [OAUTH-WG] IETF105 OAuth WG Draft Agenda
>
>
>
> I’m coming in late to this party, but I’ve been asked by a few people
> about how AWS handles request signing and our experiences with it. Given
> the renewed interest in HTTP request signing and the ongoing work on DPoP,
> is this something the working group would be interested in hearing about
> during one of the sessions? I could put together a quick 5-10 minute
> overview of AWS SigV4 signing and some of the lessons that went into its
> design.
>
>
>
> Thoughts?
>
>
>
> --
>
> *From: *OAuth <[email-masked]> on behalf of Dick Hardt <
> [email-masked]>
> *Date: *Wednesday, July 10, 2019 at 3:20 PM
> *To: *Rifaat Shekh-Yusef <[email-masked]>
> *Cc: *oauth <[email-masked]>
> *Subject: *Re: [OAUTH-WG] IETF105 OAuth WG Draft Agenda
>
>
>
> +1
>
>
>
> I like it! :)
>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F105%2Fmaterials%2Fagenda-105-oauth-00&data=02%7C01%7CMichael.Jones%40microsoft.com%7C442f8853170b476765a608d70ae49ae9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636989849300196584&sdata=GyYwRFPizRnBvNb1u6uAGYNoO816WoyITsbkrsV0rqc%3D&reserved=0>
>
>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Foauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7C442f8853170b476765a608d70ae49ae9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636989849300196584&sdata=eMCi%2Bw8gFY6DdSaRcZijuYER%2FrMdu2ZoQg5%2FS4ZEZJE%3D&reserved=0>
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Fri, 19 Jul 2019 07:50:41 -0400

Annabelle,

Go ahead and prepare slides to cover this topic, and I will try to squeeze
it in.

Regards,
 Rifaat