Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-jwt-introspection-response-09.txt

From: [email-masked]
Date: Sat, 25 Apr 2020 06:55:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Web Authorization Protocol WG of the IETF.

        Title           : JWT Response for OAuth Token Introspection
        Authors         : Torsten Lodderstedt
                          Vladimir Dzhuvinov
	Filename        : draft-ietf-oauth-jwt-introspection-response-09.txt
	Pages           : 18
	Date            : 2020-04-25

Abstract:
   This specification proposes an additional JSON Web Token (JWT)
   secured response for OAuth 2.0 Token Introspection.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-oauth-jwt-introspection-response/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-oauth-jwt-introspection-response-09
https://datatracker.ietf.org/doc/html/draft-ietf-oauth-jwt-introspection-response-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-oauth-jwt-introspection-response-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Torsten Lodderstedt <[email-masked]>
Date: Sat, 25 Apr 2020 15:59:29 +0200

Hi all,

the new revision puts the data of the introspected token into a top level claim “token_introspection”. This allows to clearly distinguish the claims of the  JWT serving as representation of the introspection response from the actual token claims with same name, e.g. “iat”.

The new revision will be presented in the virtual meeting next Monday. 

best regards,
Torsten.  

> On 25. Apr 2020, at 15:55, [email-masked] wrote:
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth