Subject: [OFF-PATH-BOF] Fwd: [P2Prg] RG participation.

From: Aaron Falk <[email-masked]>
Date: Sun, 8 Oct 2006 14:28:58 -0700

OFFPATH/EMMERG folks-

See the proposal below to re-scope the P2PRG to be tied to a  
(proposed) IETF P2P-SIP working group.  Are there any issues of  
overlap or conflict the (proposed) IRTF EMMERG RG?  It's OK for RGs  
to have overlapping scope but it's not good to unnecessarily fracture  
the community.

P2PRG-  The current draft EMMERG charter can be found here: http:// 
www.irtf.org/chairfiles/emmerg-charter-v5a.txt.

--aaron

Begin forwarded message:

> From: "Henry Sinnreich" <[email-masked]>
> Date: October 2, 2006 2:31:01 PM PDT
> To: "John Buford" <[email-masked]>, "Samrat  
> Bhattacharjee" <[email-masked]>, <[email-masked]>,  
> <[email-masked]>
> Subject: RE: [P2Prg] RG participation.
>
> John Buford writes:
>
>> the most likely scenario to re-activate it would be to couple it
>> directly to P2P-SIP, which is having its second BOF soon (San Diego
> IETF).
>
> I believe this is a very constructive proposal. Since new P2P  
> protocols
> are still emerging and their research is out of scope for the proposed
> P2P SIP WG, the P2P RG could provide a very effective support by  
> taking
> on the research topics that can support P2P SIP.
>
> Examples of topics of interest include such as:
>
> - Neighbor node discovery based on latency,
> - Overlays for range queries, for example searching by last name,
> - Overlays for searching by attribute (location, business, etc.),
> - Addressing the security vulnerabilities on overlays for P2P SIP,
> - Hierarchical overlays,
> - etc.,
>
> We can almost promise there will be no shortage of challenges :-)
>
> Thanks, Henry
>
> -----Original Message-----
> From: John Buford [mailto:[email-masked]]
> Sent: Monday, October 02, 2006 12:45 PM
> To: Samrat Bhattacharjee; [email-masked]; [email-masked]
> Subject: RE: [P2Prg] RG participation.
>
>
> Active RGs seem to have one or more
> of the following characteristics:
> 1. the RG is coupled to a specific WG (e.g. HIP)
> 2. the work is closely related to the historical
>    activity of the IETF so that there is a critical
>    mass of interested researchers already in the IETF
>    to participate
> 3. the research topic hasn't reached a scale where
>    it has its own conference forums outside IETF
> 4. the chair(s) own/drive/energize the RG activities
>    to a large extent
> 5. there is a sizeable commercial motivation for
>    research & subsequent standardization of a network
>    protocol problem space
>
> Regarding P2P as an RG:
> 1. there is no coupling yet, possibly P2P-SIP
>    might be in the future, and P2P-SIP parties made
>    requests at Dallas P2PRG meeting for support
> 2. P2P is an area which has no standardization
>    history in IETF to draw from
> 3. P2P has many conferences, and most researchers
>    seem to prefer the peer-review process, recognition and
>    collaboration in those venues
> 4. this might succeed, but doesn't seem to be a preferred
>    model.  the extended efforts of Bill & Bobby should
>    be noted and are certainly appreciated by many.
> 5. most p2p systems have been closed protocols
>    which have succeeeded without standardization and
>    related research.
>
> In the long run it seems that something like P2PRG
> will be needed and important for the IETF.
>
> In the near term, the most likely scenario to re-activate
> it would be to couple it directly to P2P-SIP, which is having
> its second BOF soon.  The best time to work that
> out would be if and after its charter is approved.
>
> The general idea would be 1) to scope the RG
> charter so that it addresses specific open issues
> that are outside of the WG charter, (e.g, decentralized
> security)
> 2) survey the P2P-SIP WG and P2P RG to see how many people
> would actively work on IDs for these open issues.
> 3) have some type of active cross-over coordination between
> RG and WG, as in HIP RG/WG, and one or more "owner"
> individuals who want to drive the RG work.
>
> Regarding the P2PRG service discovery subgroup I hope
> to continue that work if the RG continues.
>
> John
>
> -----Original Message-----
> From: Samrat Bhattacharjee [mailto:[email-masked]]
> Sent: Tuesday, September 26, 2006 1:18 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [P2Prg] RG participation.
>
>
>
> Hello...
>
> Our research group has been dormant for some time now, and the IRTF
> chair (cc'ed) has enquired if it makes sense to continue the P2P-RG.
> It is clear that all who are members here are working on their own P2P
> research; however, the RG has not (yet) been quite the forum for
> exchanging ideas that we had initially hoped.  This is not to take
> away from the work that the RG has already produced, however, lately,
> there does not seem to be much activity, and this is of concern.
>
>   Bottom line: Should we still keep this RG open?  If you have a
>   strong opinion one way or another, please drop us a line.
>
> Note that silence implies that we recommend to the IRTF that the RG be
> shut down, so if you are in favor of continuing this group, please
> include some ideas on how to generate more research activity.
>
> Thanks.
>
> Bill and Bobby
>
>
> _______________________________________________
> P2prg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2prg
>

_______________________________________________
OFF-PATH-BOF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/off-path-bof

---

From: "Henry Sinnreich" <[email-masked]>
Date: Sun, 8 Oct 2006 15:11:41 -0700

Thanks Aaron!

>re-scope the P2PRG to be tied to a (proposed) IETF P2P-SIP working
group

The background and I-Ds for the P2P SIP work on the IETF can be found at
http://www.p2psip.org 

I have taken the liberty to copy some folks preparing the way to charter
the P2P SIP WK after the BOF in San Diego.

Thanks again, Henry

-----Original Message-----
From: Aaron Falk [mailto:[email-masked]] 
Sent: Sunday, October 08, 2006 4:29 PM
To: [email-masked]
Cc: Internet Steering Group; [email-masked]
Subject: [OFF-PATH-BOF] Fwd: [P2Prg] RG participation.

OFFPATH/EMMERG folks-

--aaron

---

From: Aaron Falk <[email-masked]>
Date: Sun, 8 Oct 2006 16:32:11 -0700

Bill-

Understood.  However, I submit that the RG agenda should follow the  
interests and energy of the participants.  Another thing to keep in  
mind is that the charter of the RG can be broader than the near-term  
work plan.  An RG may choose to work on a broad array of topics in a  
serial fashion, focusing on a narrower set at any one time.

--aaron

On Oct 8, 2006, at 4:24 PM, Bill Yeager wrote:

> Hi aaron,
>
> I personally think that P2P SIP is too narrow a scope for the P2P  
> RG. I would think that yes, the P2P RG can do research on P2P SIP,  
> but strongly discourage limiting its scope too narrowly.
>
> Bill
>
> co-chair P2P RG
>
> On Oct 8, 2006, at 2:28 PM, Aaron Falk wrote:
>
>> OFFPATH/EMMERG folks-
>>
>> IRSG mailing list
>> [email-masked]
>> http://mailman.isi.edu/mailman/listinfo/irsg

---

From: Scott W Brim <[email-masked]>
Date: Sun, 8 Oct 2006 17:28:24 -0700

> www.irtf.org/chairfiles/emmerg-charter-v5a.txt.

I don't think there's that much overlap in goal between P2P SIP and
EMERG, although they'll touch some of the same territory.  IMHO the
essence of P2P SIP is to free the peer discovery process from the Borg
(plus a couple of other things like support for anonymity and NAT
traversal).  All of the P2PRG work would support it directly.  OTOH it
seems that the implicit issue in EMERG is to *control* the discovery
process, and to make it work well when a lot of control exists,
assuming strong A&A.  

swb

---

From: "Paul Francis" <[email-masked]>
Date: Mon, 9 Oct 2006 08:38:30 -0400

I agree with Scott...the two groups seem more complementary than overlapping.
As someone pointed out, P2PSIP could utilize whatever comes out of EMMERG.

PF

-----Original Message-----
From: Scott W Brim [mailto:[email-masked]] 
Sent: Sunday, October 08, 2006 8:28 PM
To: Aaron Falk
Cc: [email-masked]; Internet Steering Group; [email-masked]
Subject: Re: [OFF-PATH-BOF] Fwd: [P2Prg] RG participation.

On Sun, Oct 08, 2006 02:28:58PM -0700, Aaron Falk allegedly wrote:
> overlap or conflict the (proposed) IRTF EMMERG RG?  It's OK for RGs to 
> have overlapping scope but it's not good to unnecessarily fracture the 
> community.
> 

I don't think there's that much overlap in goal between P2P SIP and EMERG,
although they'll touch some of the same territory.  IMHO the essence of P2P
SIP is to free the peer discovery process from the Borg (plus a couple of
other things like support for anonymity and NAT traversal).  All of the P2PRG
work would support it directly.  OTOH it seems that the implicit issue in
EMERG is to *control* the discovery process, and to make it work well when a
lot of control exists, assuming strong A&A.  

swb