Subject: Plug-ins and PGP/MIME (was RE: Java Implementation)

From: [email-masked]
Date: Sun, 8 Apr 2001 13:03:31 +0000 (GMT+01:00)

That makes sense, since we were testing against the Outlook plug-in.  It 
seems that this issue is a real barrier against adoption of PGP/MIME, though. 
 Outlook is so far and away the dominant email client that it doesn't seem 
likely that PGP/MIME will get far if it can't be used in a plug-in.  (I 
don't really see Microsoft building in an OpenPGP implementation anytime 
in the near future.)

Brian Smith

At Sat, 7 Apr 2001 10:46:05 -0400, "Damon Gallaty" <[email-masked]> wrote:

>
>Actually, we do implement PGP/MIME where we can. Naturally, it requires
>access to the mail headers, and not all mail apps give plug-ins that 
>kind of
>control. Unfortunately, out of all the plug-ins we currently have, only 
>the
>Eudora plug-in is able to both create and interpret PGP/MIME.
>
>- Damon Gallaty
>
>> -----Original Message-----
>> From: [email-masked]
>> [mailto:[email-masked]]On Behalf Of [email-masked]
>> Sent: Saturday, April 07, 2001 6:13 AM
>> To: [email-masked]
>> Subject: Re: Java Implementation
>>
>>
>> Since the toolkit is intended for use with the same key servers that 
>are
>> used for HushMail.com, our standard licensing is on a per-key-registered
>> basis.  I'm sure we could work something out for use outside that 
>context.
>>
>> It is fully compliant with 2440, but some of the "SHOULD"
>> algorithms aren't
>> packaged with it at this point.  Our approach to MIME is
>> initially not standard,
>>  because, among other things, we wanted interoperability with the 
>Network
>> Associates PGP users, and Network Associates PGP doesn't seem to
>> implement
>> PGP/MIME, even though there's a checkbox for it?!?
>>
>> Get in touch with me off the list, let me know what your specific
>> requirements
>> are, and we'll see what we can work out.
>>
>> Thanks,
>> Brian
>>
>> At Sat, 7 Apr 2001 10:11:26 +0000 (GMT+01:00), [email-masked] wrote:
>>
>> >
>> >    Under what kind of licensing will it be released ?
>> >    Will this SDK comply fully with OpenPGP ?
>> >
>> >    Thanks in advance,
>> >    Jacques
>> >
>> >----- Original Message -----
>> >From: <[email-masked]>
>> >To: <[email-masked]>; <[email-masked]>
>> >Sent: Sunday, April 01, 2001 9:30 AM
>> >Subject: Java Implementation
>> >
>> >
>> >> Jacques Exelrud was recently inquiring about the availability of 
>a
>> >complete
>> >> Java implementation of OpenPGP.  We have one in our SDK, which 
>will
>> >be
>> >powering
>> >> the soon-to-be-released HushMail Version 2.  It's intended for 
>use
>> >with
>> >> our keyserver network and OpenPGP CA.  The source will be published
>> >with
>> >> the release of HushMail V2.  If interested, let me know.
>> >>
>> >> Regards,
>> >> Brian Smith
>> >>
>> >>
>> >> * * * * * * * * * * * * * * * * * * * * *
>> >> S. Brian Smith
>> >> Director of Research and Development
>> >> Hush Communications
>> >> Email: [email-masked]
>> >> Mobile: +353 86 809 2163
>> >> Tel: +353 1 241 0325
>> >> Fax:  +353 1 241 0370
>> >> Website: www.hush.com
>> >>
>> >>

Free, encrypted, secure Web-based email at www.hushmail.com

---

From: Florian Weimer <[email-masked]>
Date: 10 Apr 2001 18:22:32 +0200

[email-masked] writes:

> That makes sense, since we were testing against the Outlook plug-in.
> It seems that this issue is a real barrier against adoption of
> PGP/MIME, though.

Is it possible to write a plug-in for Exchange which removes or adds
some additional transport armor before a message distributed using
proprietary technology over the LAN is injected into the Net?

This way, access to message headers would not be strictly necessary at
the client system.

-- 
Florian Weimer 	                  [email-masked]
University of Stuttgart           http://cert.uni-stuttgart.de/
RUS-CERT                          +49-711-685-5973/fax +49-711-685-5898