Subject: GOST information in Applied Crypography 2nd Ed.

From: David Crick <[email-masked]>
Date: Sat, 22 Jan 2005 12:33:56 +0000

Section 14.1, pages 331 - 334
GOST Block Cipher (GOST 28147-89)

Mentions use of random S-Boxes, but also states:

"More recently, a set of S-Boxes used in an application
for the Central Bank of the Russian Federation surfaced.
These S-Boxes are also used in the GOST one-way hash
function."

S-Box 1:
  4 10  9  2 13  8  0 14  6 11  1 12  7 15  5  3

S-Box 2:
14 11  4 12  6 13 15 10  2  3  8  1  0  7  5  9

S-Box 3:
  5  8  1 13 10  3  4  2 14 15 12  7  6  0  9 11

S-Box 4:
  7 13 10  1  0  8  9 15 14  4  6 12 11  2  5  3

S-Box 5:
  6 12  7  1  5 15 13  8  4 10  9 14  0  3 11  2

S-Box 6:
  4 11 10  0  7  2  1 13  3  6  8  5  9 12 15 14

S-Box 7:
13 11  4  1  3 15  5  9  0 10 14  7  6  8  2 12

S-Box 8:
  1 15 13  0  5  7 10  4  9  2  3 14  6 11  8 12

Section 18.11, page 454
GOST Hash Function (GOST R 34.11-94)

NB errata: "XOR of all the message blocks" SHOULD BE
"sum of the message blocks as if they were 256-bit
integers"

Section 20.3, pages 495 - 496
GOST Digital Signature Algorithm (GOST R 34.10-94)

Schneier notes that q is 256 bits compared to DSA's 160.

Part V, pages 643 - 647
GOST C source code (uses ECB mode)

---

From: "Vlad \"SATtva\" Miller" <[email-masked]>
Date: Sun, 23 Jan 2005 15:49:09 +0600

> GOST Digital Signature Algorithm (GOST R 34.10-94)

This standard is outdated, and has been replaced with GOST R 34.10-2001.