Subject: RE: Split Implementations of PGP

From: Eric Burger <[email-masked]>
Date: Sun, 13 Mar 2005 17:24:15 -0500

The problem is that the client does not want to download the object at all,
either because they only want to look at a particular body part and the
entire message is encrypted (Cyrus' example) or they wish to forward the
message without downloading it to their client.

> -----Original Message-----
> From: pgut001 [mailto:[email-masked]]
> Sent: Saturday, March 12, 2005 10:34 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: Split Implementations of PGP
> 
> 
> Eric Burger <[email-masked]> writes:
> 
> >So, the question is, are there implementations of PGP where one can:
> >1. Extract the encrypted session key from the PGP-encrypted object
> >2. An API for handing over the encrypted session key and the 
> client key,
> >returning the clear session key (this would run on the 
> remote client).
> >3. An API that takes the clear session key and the 
> PGP-encrypted object and
> >returns the cleartext object.
> 
> Why not have the client decrypt the session key, re-encrypt 
> it with the
> server's public key, and send it back?  Any version of PGP 
> supports this, and
> it solves the difficult problem of "an API for [...] the 
> client returning the
> session key".
> 
> Peter.
>

---

From: [email-masked] (Peter Gutmann)
Date: Tue, 15 Mar 2005 21:23:44 +1300

>message without downloading it to their client.

You don't download it, the server sends out the RSA/Elgamal-encrypted message
encryption key (MEK) from the message (and nothing else) and the client
returns the MEK re-encrypted with the server's public key.  This works with
anything (including for example crypto hardware like smart cards that won't
reveal a key), has minimal messaging overhead, and doesn't require any
additional security measures to protect the MEK.

Peter.