Subject: Re: DSA2 test material

From: <[email-masked]>
Date: Tue, 06 Jun 2006 15:39:54 -0400

On Tue, 06 Jun 2006 12:09:39 -0400 David Shaw 
<[email-masked]> wrote:

>I have put together some sample keys and signatures to help test 
>DSA2
>interoperability and posted the lot at
>http://www.jabberwocky.com/openpgp/dsa2.tar.gz
>
>Note that the current released version of GnuPG (1.4.3) can 
>verify,
>but will not generate a DSA2 signature or key.  

tested them in gnupg (1.4.3 mingw32 on win2k pro)

got a few error messages:
all involving the '224' type

was this meant to be tested in 1.4.3 ?

here is the ouptut summary of gpg --version

gpg (GnuPG) 1.4.3
Copyright (C) 2006 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

Home: V:/
Supported algorithms:
Pubkey: RSA, RSA-E, RSA-S, ELG-E, DSA
Cipher: IDEA (S1), 3DES (S2), CAST5 (S3), BLOWFISH (S4), AES (S7), 
AES192 (S8),
        AES256 (S9), TWOFISH (S10)
Hash: MD5 (H1), SHA1 (H2), RIPEMD160 (H3), SHA256 (H8), SHA384 
(H9),
      SHA512 (H10)
Compression: Uncompressed (Z0), ZIP (Z1), ZLIB (Z2), BZIP2 (Z3)

a hash of 224 is not listed

so, 
not unexpectely,
upon importing the key,
since gnupg didn't recognize the 224 hash,
it also didn't recognize the self-sig

here are the gnupg error messages (using verbose verbose setting):

[1] 
gpg: pub  2048D/41FBF40E 2006-05-26  
gpg: key 41FBF40E: invalid self-signature on user ID "DSA-2048-224"
gpg: key 41FBF40E: skipped user ID "DSA-2048-224"
gpg: key 41FBF40E: no valid user IDs
gpg: this may be caused by a missing self-signature
gpg: Total number processed: 1
gpg:           w/o user IDs: 1

File: V:\dsa2tf\DSA2-Tests\keys\DSA-2048-224.pub
Time: 6/6/2006 2:37:52 PM (6/6/2006 6:37:52 PM UTC)

[2]
gpg: original file name='dsa-1024-224-sign'
gpg: md_enable: algorithm 11 not available
gpg: Signature made 5/27/2006 23:03:25 using DSA key ID 94D38E40
gpg: Can't check signature: unknown digest algorithm

File: V:\dsa2tf\DSA2-Tests\sigs\dsa-1024-224-sign.gpg
Time: 6/6/2006 2:47:01 PM (6/6/2006 6:47:01 PM UTC)

[3]
gpg: original file name='dsa-2048-224-sign'
gpg: md_enable: algorithm 11 not available
gpg: Signature made 5/27/2006 19:33:49 using DSA key ID 41FBF40E
gpg: Can't check signature: unknown digest algorithm

File: V:\dsa2tf\DSA2-Tests\sigs\dsa-2048-224-sign.gpg
Time: 6/6/2006 3:04:25 PM (6/6/2006 7:04:25 PM UTC)

vedaal

Concerned about your privacy? Instantly send FREE secure email, no account required
http://www.hushmail.com/send?l=480

Get the best prices on SSL certificates from Hushmail
https://www.hushssl.com?l=485

---

From: David Shaw <[email-masked]>
Date: Tue, 6 Jun 2006 16:39:55 -0400

> was this meant to be tested in 1.4.3 ?

No.  This is meant for people developing OpenPGP implementations other
than GPG.

David