Subject: Re: [openpgp] Issuer Fingerprint (issue#3)

From: Werner Koch <[email-masked]>
Date: Mon, 24 Oct 2016 18:55:21 +0200

Hi!

I have seen no more comments on the second version of an Issuer
Fingerprint signature sub packet.  Thus unless I hear a strong opinion
against it by Thursday, I will push that to the repo so that it gets
included in the next draft version.  For convenience I copy the diff below.

Salam-Shalom,

   Werner

[https://gitlab.com/openpgp-wg/rfc4880bis/issues/3]

--8<---------------cut here---------------start------------->8---
@@ -1055,6 +1055,7 @@ #### {5.2.3.1} Signature Subpacket Specification
           30   Features
           31   Signature Target
           32   Embedded Signature
+          33   Issuer Fingerprint
   100 to 110   Private or experimental
 
 An implementation SHOULD ignore any subpacket of a type that it does
@@ -1155,7 +1156,9 @@ #### {5.2.3.5} Issuer
 
 (8-octet Key ID)
 
-The OpenPGP Key ID of the key issuing the signature.
+The OpenPGP Key ID of the key issuing the signature.  If the version
+of that key is greater than 4, this subpacket MUST NOT be included in
+the signature.
 
 #### {5.2.3.6} Key Expiration Time
 
@@ -1615,6 +1618,19 @@ #### {5.2.3.26} Embedded Signature
 in Section 5.2 above.  It is useful when one signature needs to refer
 to, or be incorporated in, another signature.
 
+#### Issuer Fingerprint
+
+(1 octet key version number, N octets of fingerprint)
+
+The OpenPGP Key fingerprint of the key issuing the signature.  This
+subpacket SHOULD be included in all signatures.  If the version of the
+issuing key is 4 and an Issuer subpacket is also included in the
+signature, the key ID of the Issuer subpacket MUST match the low
+64 bits of the fingerprint.
+
+Note that the length N of the fingerprint for a version 4 key is 20
+octets.
+
 ### {5.2.4} Computing Signatures
 
 All signatures are formed by producing a hash over the signature data,
--8<---------------cut here---------------end--------------->8---

-- 
Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

---

From: Werner Koch <[email-masked]>
Date: Fri, 28 Oct 2016 20:54:21 +0200

> against it by Thursday, I will push that to the repo so that it gets

I just pushed it to the repo and closed issue 3.

Shalom-Salam,

   Werner