Subject: [openpgp] ProtonMail moving to default X25519 keys

From: Sunny Rajan <[email-masked]>
Date: Tue, 15 Jan 2019 10:24:54 +0000

Hello all,

At ProtonMail we are moving towards generating Ed25519/Curve25519 keys for our users by default on all clients. We realize this will cause interoperability issues with OpenPGP implementations that don't yet support X25519 encryption and signature verification, so we wanted to provide some advance notice in case you receive an increased number of reports from your users who are trying to communicate with ProtonMail users.
Please let us know if you have any concerns!

Best,
Sunny

---

From: Andre Heinecke <[email-masked]>
Date: Tue, 15 Jan 2019 15:38:33 +0100

Hi,

On Tuesday, January 15, 2019 10:24:54 AM CET Sunny Rajan wrote:
> At ProtonMail we are moving towards generating Ed25519/Curve25519 keys for
> our users by default on all clients. We realize this will cause
> interoperability issues with OpenPGP implementations that don't yet support
> X25519 encryption and signature verification, so we wanted to provide some
> advance notice in case you receive an increased number of reports from your
> users who are trying to communicate with ProtonMail users.

*thumbs up* I would turn the request around a bit. Please let us, or the 
OpenPGP Email list ( [email-masked] ), know if you face interop or 
other problems. A status update in some months time which basically says "No 
Problems happened" would also be appreciated. 
I guess that there are some other implementations (me included) out there that 
think about taking the step to change the default.
So congratulations for the courage to be on the forefront of progress. :-)

Best Regards and I hope all goes well,
Andre

-- 
GnuPG e.V., Rochusstr. 44, D-40479 Düsseldorf.  VR 11482 Düsseldorf
Vorstand: W.Koch, M.Gollowitzer, A.Heinecke.    Mail: [email-masked]
Finanzamt D-Altstadt, St-Nr: 103/5923/1779.   Tel: +49-2104-4938799

---

From: Vincent Breitmoser <[email-masked]>
Date: Tue, 15 Jan 2019 15:46:59 +0100

As discussed at the summit, Autocrypt and OpenKeychain will follow suit.

See https://github.com/autocrypt/autocrypt/pull/393

 - V

---

From: Bart Butler <[email-masked]>
Date: Tue, 15 Jan 2019 19:04:54 +0000

Excellent, and we will certainly ping people here if we receive any compatibility complaints.

-Bart

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Tuesday, January 15, 2019 6:46 AM, Vincent Breitmoser <[email-masked]> wrote:

>     Andre Heinecke [email-masked] wrote:
>     

> > thumbs up I would turn the request around a bit. Please let us, or the

> openpgp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/openpgp