Subject: Re: [openpgp] [Technical Errata Reported] RFC4880 (5491)

From: Marco Bellaccini <[email-masked]>
Date: Sat, 8 Jun 2019 16:07:48 +0200

Hi all,
any update on this?

Cheers

Marco

On 9/4/18 4:12 PM, RFC Errata System wrote:
> The following errata report has been submitted for RFC4880,
> "OpenPGP Message Format".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5491
> 
> --------------------------------------
> Type: Technical
> Reported by: Marco Bellaccini <[email-masked]>
> 
> Section: 6.1
> 
> Original Text
> -------------
> #define CRC24_POLY 0x1864CFBL
> 
> Corrected Text
> --------------
> #define CRC24_POLY 0x864CFBL
> 
> Notes
> -----
> In the C reference implementation of CRC-24, the generator is wrong: the correct one is reported in Section 6.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
> 
> --------------------------------------
> RFC4880 (draft-ietf-openpgp-rfc2440bis-22)
> --------------------------------------
> Title               : OpenPGP Message Format
> Publication Date    : November 2007
> Author(s)           : J. Callas, L. Donnerhacke, H. Finney, D. Shaw, R. Thayer
> Category            : PROPOSED STANDARD
> Source              : An Open Specification for Pretty Good Privacy
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Werner Koch <[email-masked]>
Date: Sat, 08 Jun 2019 22:45:36 +0200

> any update on this?

Sorry, I must have overlooked this one.  Just fixed in the repo so that
it will be in the next I-D.

Thanks for reporting.

Salam-Shalom,

   Werner

-- 
Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

---

From: Heiko Stamer <[email-masked]>
Date: Mon, 10 Jun 2019 20:11:04 +0200

On 08 June 2019 at 16:07, Marco Bellaccini wrote:

>> In the C reference implementation of CRC-24, the generator is wrong:

Just for the records: The wording "generator is wrong" seems to be a bit
misleading, because the highest degree term of CRC-24-Radix64 polynomial
is x^{24} [1] and the reference implementation takes care of the special
form of the constant. However, as there exists an established
representation for those polynomials [2], the proposed change is at
least of some editorial relevance.

[1] https://en.wikipedia.org/wiki/Cyclic_redundancy_check
[2]
https://en.wikipedia.org/wiki/Mathematics_of_cyclic_redundancy_checks#Polynomial_representations
--
Heiko