Subject: Re: [openpgp] v5 sample key

From: Daniel Huigens <[email-masked]>
Date: Fri, 07 Jun 2019 16:59:15 +0000

On 30 April 2019 23:28, Heiko Stamer <[email-masked]> wrote:

> I've attached a detached v5 signature of this key for testing purposes.

It seems this signature didn't hash the 6 zero bytes from the new fields described at https://tools.ietf.org/html/draft-ietf-openpgp-rfc4880bis-07#page-44, right?

(I'm trying to implement V5 signatures in OpenPGP.js.)

Best,
Daniel

---

From: Heiko Stamer <[email-masked]>
Date: Fri, 7 Jun 2019 21:52:33 +0200

> It seems this signature didn't hash the 6 zero bytes from the new fields described at https://tools.ietf.org/html/draft-ietf-openpgp-rfc4880bis-07#page-44, right?

Yes. It was generated before I recognized this obscurity of v5 signatures.

I have attached a corrected v5 signature on the same file.

Good luck.
--
Heiko