Subject: RE: no-transform & Warning

From: "Reinaldo Penno"<[email-masked]>
Date: Tue, 16 Apr 2002 10:34:07 -0700

You need to understand HTTP 1.1. Sometimes you just want to send the host:
header (request URL filtering). Sometimes the entire payload. Sometimes you
want (for web mail virus scanning), send only part of a payload. 

regards,

Reinaldo 

>-----Original Message-----
>From: Yang, Lily L [mailto:[email-masked]]
>Sent: Tuesday, April 16, 2002 9:15 AM
>To: 'Markus Hofmann'; Mark Nottingham
>Cc: [email-masked]; [email-masked]
>Subject: RE: no-transform & Warning
>
>
>
>
>
>> -----Original Message-----
>> From: Markus Hofmann [mailto:[email-masked]]
>> Sent: Tuesday, April 16, 2002 7:43 AM
>> To: Mark Nottingham
>> Cc: [email-masked]; [email-masked]
>> Subject: Re: no-transform & Warning
>> 
>> 
>> 
>> Mark Nottingham wrote:
>> 
>> > These mechanisms are required in order to be 
>> HTTP-compliant; therefore, 
>> > I'd say they should be part of the ICAP server's HTTP stack.
>> 
>> Hm, this assumes that the payload (i.e. the content-path 
>protocol) is 
>> NOT transparent to the OPES/Callout protocol, i.e. the OPES/Callout 
>> protocol needs to have knowledge about the sematics of the 
>> encapsulated application protocol (HTTP in this case).
>
>I thought this has been the case. The callout protocol is 
>going to transport
>and transform the encapsulated application protocol data 
>stream, and hence
>has to understand the interaction with that application protocol.
>
>> 
>> Do we want to make this assumption? Comments?
>> 
>> -Markus
>> 
>

---

From: Markus Hofmann <[email-masked]>
Date: Tue, 16 Apr 2002 13:51:13 -0400

Reinaldo Penno wrote:

> You need to understand HTTP 1.1. Sometimes you just want to send the 
> host: header (request URL filtering). Sometimes the entire payload. 
> Sometimes you want (for web mail virus scanning), send only part of a 
> payload.

The question is whether the callout protocol itself needs "to 
understand HTTP", or whether the application logic can be build around 
a generic callout protocol.

-Markus