Subject: LateClearance content encoding

From: "Martin Stecher" <[email-masked]>
Date: Wed, 6 Nov 2002 18:33:14 +0100

Hi,

in a prominent OPES scenario a virus filter is deployed as an OPES service of an intermediate proxy.
That filter belongs to the group of services that wants to see all data of a file completly before it starts to respond. In HTTP this huge latency effect results in an inacceptable surfing experience for the end user when requesting large files; there is no feedback, no progress dialog until the complete files has been received by the filter service.

Today only workarounds are known to this problem that all have a bunch of disadvantages.

I created a draft about a new content encoding for HTTP which could solve this problem for the majority of file types:
http://www.ietf.org/internet-drafts/draft-stecher-lclr-encoding-00.txt
It also explains the problem in more detail.

I would appreciate very much if this group is interested in looking into this and in starting a discussion about this problem and possible solutions.

Regards
Martin

---

From: "The Purple Streak, Hilarie Orman" <[email-masked]>
Date: Wed, 6 Nov 2002 12:20:55 -0700

It's a nice solution, but it's important to know what the problem is.

I'm unclear about why the data must be encrypted.  The only point is to
keep the enduser from using the data, so it would seem sufficient to
just have the late clearance flag alone - let the client decide how it
wants to handle data while it is in the uncleared state.  Why is this
insufficient?

Hilarie