Subject: RE: OCP Core version head_sid8 available

From: "Martin Stecher" <[email-masked]>
Date: Fri, 30 May 2003 10:15:45 +0200

Hi,

while reading I only found two things:

- Section 3.1: comment for named-parameters says "comma separated"
- Section 8.16: data-need message has no abbreviation

And two questions regarding abbreviations:

- How do you pick upper- and lowercase characters for the abbreviations?
Often it looks like you use lowercase if it is a second char from the same word, as in DEd for data-end.
But this "rule" does not match for data-pause (DPE), data-paused (DPD) and data-ack (DAK)

- And why has data-have a two character abbreviation (DH) but data-end has three characters (DEd)?

Regards
Martin

> -----Original Message-----
> From: Alex Rousskov [mailto:[email-masked]]
> Sent: Thursday, May 29, 2003 4:33 AM
> To: OPES WG
> Subject: OCP Core version head_sid8 available
> 
> 
> 
> 
> The [major] change log is quoted below. The latest snapshot, including
> XML sources for those doing hands-on modifications, is available at
> 
> 	http://www.measurement-factory.com/tmp/opes/
> 
> Please continue to comment and work on the to-do list. Personally, I
> plan to add negotiation-specific messages next, based on a summary
> posted to this list two weeks or so ago.
> 
> Thank you,
> 
> Alex.
> 
> -------------- change log ----------------
> 
> head-sid8
> 
>   *  Added structure and list values to ABNF syntax.
> 
>   *  Messages with multiple equally-named parameters are
>      semantically invalid.
> 
>   *  Added types for message parameters.
> 
>   *  Started replacing complicated, error-prone, and probably mostly
>      useless "modified" parameter with a clear and simple "as-is"
>      parameter.
> 
>   *  Converted parameter descriptions from list items to
>      subsections.
> 
>   *  OCP syntax requires one or two character lookups to determine
>      the next message part. Fixed a comment for implementors saying
>      that one lookup is always sufficient.
> 
> 
> ------------------------------------------------------------
> This mail has been scanned by wwsmtp
> (WebWasher 4.4 beta Build 514)
> ------------------------------------------------------------
>

---

From: Alex Rousskov <[email-masked]>
Date: Fri, 30 May 2003 09:15:07 -0600 (MDT)

> - Section 8.16: data-need message has no abbreviation

Will fix.

> - How do you pick upper- and lowercase characters for the
> abbreviations? Often it looks like you use lowercase if it is a
> second char from the same word, as in DEd for data-end. But this
> "rule" does not match for data-pause (DPE), data-paused (DPD) and
> data-ack (DAK)

I tried to follow the following algorithm:

	- use the first letter from each word of the full name,
	  upper case

	- add semi-arbitrary letters to abbreviations
	  that are prefixes of other abbreviations or are
	  the same as other abbreviations (e.g., data-pause and
	  data-paused)

> data-end has three characters (DEd)?

I guess that's a consistency bug. Should we make all names three
characters long? Four? If you have any better algorithm/suggestions,
please let me know. I am not particularly happy with the current
naming scheme. I doubt 2, 3, or 4 characters will matter much, but we
should strive to be consistent.

BTW, I still need to apply your comment that talks about removing full
names from message summaries and leaving only one [short] "name", to
avoid confusion.

Thanks,

Alex.