Subject: RE: what-parts-to-send-or-skip

From: "Martin Stecher" <[email-masked]>
Date: Mon, 27 Oct 2003 10:08:25 +0100

> 
> > > Wont-Look-Body: 2147483647
> > > rather than
> > > Wont-Send-Body: 2147483647
> >
> > It will be
> >
> > Wont-Look-Body: 0
> 
> Agreed. Wont-Send offset semantics (will not send anything up to the
> specified point) is going to be different from the Wont-Look semantics
> (will not look at anything beyond the specified point). Right?
> 
Yes.

> I hope that is OK. If not, we can have more explicit names:
> 
> 	Wont-Look-Body-After:
> 	Wont-Send-Body-Before:
> 
> or something of that kind.

Not needed I think.

For clarification:
Wont-Look-Body: 0 is NOT a good value for URL blocking tools. Actually the Wont-Look-Body parameter for NR cannot be used by URL blocking servies at all (unless they block all requests).

Reason: Depending on the URL, the service will either send the request back unchanged or it will short-circuit and send back an error message.
Thus, it will need to wait for the request-header part and then decide whether it sends a DWO message or a DWLY message.
Because Wont-Look-Body: 0 means to behave as if DWLY is sent for all transactions, it cannot be used here.

Right?

Martin

---

From: Alex Rousskov <[email-masked]>
Date: Mon, 27 Oct 2003 02:16:07 -0700 (MST)

On Mon, 27 Oct 2003, Martin Stecher wrote:
> For clarification:
>
> Wont-Look-Body: 0 is NOT a good value for URL blocking tools.
> Actually the Wont-Look-Body parameter for NR cannot be used by URL
> blocking servies at all (unless they block all requests).
>
> Reason: Depending on the URL, the service will either send the
> request back unchanged or it will short-circuit and send back an
> error message. Thus, it will need to wait for the request-header
> part and then decide whether it sends a DWO message or a DWLY
> message. Because Wont-Look-Body: 0 means to behave as if DWLY is
> sent for all transactions, it cannot be used here.

The above looks correct to me.

It looks like Wont-Look-Body in NR is only useful for services that
generate responses from scratch, possibly based on header and meta
info. Such services may be useful if they are activated based on some
dynamic conditions (errors, blocked pages, overload, etc.). For
example, perhaps the service that blocks is different from the service
that generates the final "your transaction has been blocked" response
in a user-friendly language.

Alex.