Subject: RE: capability negotiations

From: "Martin Stecher" <[email-masked]>
Date: Tue, 7 Oct 2003 23:43:16 +0200

Hi,

> 
> > Are you ok with the suggested member names?
> >   Optional-Parts, Skip-Parts, Transfer-Encodings, Content-Encodings
> 
> Do we assume that these negotiations will happen infrequently in most
> cases (because negotiated service group will be reused for many
> transactions)? If yes, then I have no problems with the above names.
> If we assume rather frequent negotiations, I would suggest
> abbreviating the above: PO, PS, ET, EC.
> 

I assume only few negotiations per connection, just to get service group features negotiated. The SG parameter of NO/NR was the important thing we introduced earlier.
Connections should then stay open and handle many transactions.
There will probably be some number of parallel open connections, so negotiation will be repeated here and there, but this will still be infrequently compared with the number of transactions handled.

If there are no further comments, I will use the long names here.

Regards
MArtin

---

From: Alex Rousskov <[email-masked]>
Date: Tue, 7 Oct 2003 16:08:47 -0600 (MDT)

> If there are no further comments, I will use the long names here.

Sounds good to me.

Alex.