Subject: RE: feedback on draft-ietf-opes-end-comm-04

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 21 Oct 2003 13:57:50 -0400

> -----Original Message-----
> From: Alex Rousskov [mailto:[email-masked]] 
> Sent: Tuesday, October 21, 2003 1:38 PM
> To: OPES WG
> Subject: RE: feedback on draft-ietf-opes-end-comm-04
> 
> 
> 
SNIP

> I am talking about specific requirements you have in the 
> draft. There is no "OPES tracing is a MUST" requirement. 
> However, there is a requirement quoted above that implies 
> that an OPES System MUST trace every OPES processor. Since 
> OPES System has to delegate actual actions to processors, the 
> above really means that an OPES processor MUST trace itself. 
> There is also a requirement on page 6 that "OPES processor 
> SHOULD add its entry to the trace". For me, there is a 
> requirement level conflict here. Either it is a SHOULD or a 
> MUST, it cannot be both.
> 

Ok, I see. 
I could make it both a SHOULD. But does this result that tracing in the
system is not a MUST.

> >
> > > > Each OPES processor MUST support tracing, policy can be used to 
> > > > turn tracing on and to determine its granularity.
> > >
> > > I continue to note that the above requirement does not make much 
> > > sense to me. If a policy can be used, can I use a policy 
> that always 
> > > turns tracing off and have that as the only, hard-coded policy? I 
> > > think this is a failed attempt to appear directly 
> compliant with an 
> > > IAB consideration and it should be removed.
> > >
> >
> > Alex, if your ploicy trun all processor off, then u r not compliant.
> 
> Why? I am not violating the "support" requirement above.
> 
> Alex.
> 

If tracing is off for all, then u r not supporting tracing.

Abbie

---

From: Alex Rousskov <[email-masked]>
Date: Tue, 21 Oct 2003 12:16:58 -0600 (MDT)

On Tue, 21 Oct 2003, Abbie Barbir wrote:

> I could make it both a SHOULD. But does this result that tracing in
> the system is not a MUST.

OPES System MUST still trace itself, right?
> If tracing is off for all, then u r not supporting tracing.

What does it mean to support tracing, then? The way you wrote it, I
interpret "support" as "having a feature in the code" (that can be
configured to be enabled or disabled). Does it mean something else?

This argument is exactly why I think the requirement in question is
bogus (not well defined, unclear, or imprecise) and should be deleted.

Alex.