Subject: RE: capability negotiations

From: "Martin Stecher" <[email-masked]>
Date: Wed, 8 Oct 2003 23:22:14 +0200

> 
> > Agreed, regarding the syntax of structures.
> 
> Great.
> 
> > I don't like yet that payload is separated with an empty line from
> > headers in case of named parameters but starts on a new line if
> > there are only anonymous params.
> 
> Yeah.
> 
> > And the semicolon should either always or never start on a new line,
> > I think.
> 
> I like being able to write simple messages on one line
> 
> 	CMD 1 2 3 4;
> 
> This would look worse, IMO:
> 
> 	CMD 1 2 3 4
> 	;
> 
> There is virtually no difference for the parser, I think. This is a
> purely visual/presentational effect. One-liners are nice when you brag
> about how compact OCP can be.
> 
> > So, how about this little change?
> >
> >   message = name [SP anonym-parameters] CRLF
> >             [named-parameters CRLF]
> >             [payload CRLF]
> >             ";" CRLF
> >
> > Every element, but anonymous parameters, starts on a new line.
> 
> This does not allow for fast separation of "header" and payload using
> a unique CRLFCRLF sequence. The latter is useful to make avoid parsing
> partial input buffers until they are likely to contain complete
> message headers.
> 
> I would like to keep simple messages on one line. How about always
> separating payload with CRLFCRLF while still allowing for one-liners:
> 
>    message = name [SP anonym-parameters]
> 	     [CRLF named-parameters]
> 	     [CRLF CRLF payload]
>              ";" CRLF
> 
[...]
> 
> This is probably equivalent to your last proposal except I preserved
> one-liners and made payload easier to find without parsing.

Yes, great. Let's do it that way.

Martin

---

From: Alex Rousskov <[email-masked]>
Date: Wed, 8 Oct 2003 17:22:21 -0600 (MDT)

> Yes, great. Let's do it that way.

This BNF change and new rendering caveats are now committed.
The web site has an updated version. Thank you.

Now, what I really want is to add optional namespace prefixes to
parameter and message names: "opes://vendorA/BU1::My-Extension".
Just kidding.

We do need i18n-related review of the BNF though. We already support
Unicode in quoted strings, but I am worried that ASCII-restricted bare
names go against current internationalization requirements.

Alex.