Subject: RE: P work in new charter

From: "Abbie Barbir" <[email-masked]>
Date: Fri, 2 Jul 2004 08:25:32 -0400

All,

interesting so far.
I really suggest that you read about WSDL, CDL, BPEl etc and draw lines on
what can be done in OPES vs Not. Mnay of your concerns regarding service
discovery, security, composition, binding etc has been addressed there.

Abbie

> -----Original Message-----
> From: Geetha Manjunath [mailto:[email-masked]] 
> Sent: Friday, July 02, 2004 7:38 AM
> To: Markus Hofmann
> Cc: [email-masked]
> Subject: Re: P work in new charter
> 
> 
> 
> > > > (d) defining mechanisms by which a user can communicate 
> rulesets 
> > > > to the OPES processor.
> > >
> > > Such mechanism is needed (one might default to existing 
> ones), but 
> > > out of scope of the WG.
> 
> > > Can you please give me specific pointers to existing mechanisms 
> > > here? I would like
> > to evaluate their sufficiency  for the intended usage.
> 
> > For example, use a CLI to load a rules file locally on the machine, 
> > use FTP to transfer a rules file, you might use HTTP....
> >
> > -Markus
> 
> Oh! I guess these are fine! I was wondering whether there 
> were any protocols along the lines of WPAD (Web Proxy 
> Auto-Discovery Protocol) for this.
> 
> The reason I raised the point about "mechanisms to 
> communicate the rules" was based on my trials of using IRML 
> in a practical OPES env. Though IRML did talk about rule sets 
> that included 3 classes of rules - (i)Rules set by OPES 
> administrator, (ii)Rules set by Content Provider and (iii) 
> Rules set by the user/client  - there were several practical 
> problems  in effecting the latter two cases. I guess the 
> question then boils down to  "who are the targetted authors 
> that would use P language to write rulesets?". Clearly it is 
> (i) but do we include (ii) and (iii) ?
> 
> Thanks and regards
> geetha
> 
> 
>

---

From: Geetha Manjunath <[email-masked]>
Date: Fri, 02 Jul 2004 18:27:06 +0530

Thanks I will do that

Abbie Barbir wrote:

>
>
> All,
>
> interesting so far.
> I really suggest that you read about WSDL, CDL, BPEl etc and draw
> lines on what can be done in OPES vs Not. Mnay of your concerns
> regarding service discovery, security, composition, binding etc has
> been addressed there.
>
> Abbie
>