Subject: RE: P-services interface in Strawman OPES Charter

From: "Abbie Barbir" <[email-masked]>
Date: Wed, 14 Jul 2004 11:11:24 -0400

All,
Can we state that we will investigate that and if needed we will try to
re-use other technologies such as WSDl.

abbie

> -----Original Message-----
> From: Markus Hofmann [mailto:[email-masked]] 
> Sent: Wednesday, July 14, 2004 10:34 AM
> To: OPES Group
> Subject: Re: P-services interface in Strawman OPES Charter
> 
> 
> 
> Alex Rousskov wrote:
> 
> > I am worried that if we want to define WSDL profile for 
> OCP, some of 
> > us (or some of IESG) will find that extending W3C 
> technology like WSDL 
> > is out of current charter scope. We do not know whether 
> using WSDL is 
> > the right way to go, but should we just mention that we need to
> > 
> > 	Define P-services interface, based on existing interface
> > 	description standards like WSDL, if possible, or OPES-specific
> > 	description otherwise.
> 
> What about the following:
> 
>    In addition, the WG will define a rules language to control
>    selection and invocation of services by an OPES processor. This
>    includes a mechanism allowing an OPES processor to perform 
> a runtime
>    check of service parameters, leveraging existing interface
>    description standards like WSDL, if possible, or OPES-specific
>    description otherwise.
> 
> -Markus
> 
>

---

From: Markus Hofmann <[email-masked]>
Date: Wed, 14 Jul 2004 11:28:54 -0400

> re-use other technologies such as WSDl. 

Isn't that implied by the proposed phrasing?

>>   [...] This 

-Markus