Subject: RE: Strawman OPES Charter

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 13 Jul 2004 15:57:45 -0400

see inline,

abbie

> -----Original Message-----
> From: Alex Rousskov [mailto:[email-masked]] 
> Sent: Tuesday, July 13, 2004 11:54 AM
> To: Barbir, Abbie [CAR:1A11:EXCH]
> Cc: Markus Hofmann; OPES Group
> Subject: RE: Strawman OPES Charter
> 
> 
> 
> On Tue, 13 Jul 2004, Abbie Barbir wrote:
> 
> > > Would it be appropriate to mention that the rules work 
> will be based 
> > > on P language specification that WG has already worked 
> on? Or are we 
> > > going to re-select among P, IRML, and others as a starting point?
> > >
> > > If we are going to re-select, should we start with a "language 
> > > requirements" document?
> > >
> >
> > obsultly, yes we should do a requirement document.
> 
> Abbie,
> 
> Just to make sure: which of the following you consider essential:
> 
> 	a) forget about P choice, start from scratch, write a
> 	   formal "language requirements" document, then select among
> 	   IRML, P, and possibly other candidates.
> 
> 	b) confirm past P choice, but write a "language requirements"
> 	   document or section, before proceeding with polishing P
> 
> 	c) confirm P choice, and do not write a "language
> 	   requirements" document/section

well, I go for option a) to be frank. However, I can live with b) or c) if
the WG wants that.
> 
> > > 	- Defining an interface between rules language
> > > 	  and service (at least OCP-speaking service)
> > > 	  How to pass parameters to services? How to
> > > 	  get the result of service application, including
> > > 	  errors, back to the language/program?
> > >
> >
> > this is a muddy situation. we can rely on other work or at least 
> > reference how they handel it (examples, BPEL, CDL etc..)
> 
> I think there is an important difference between reusing 
> existing work and not doing any work.
> 
> First, we need to decide whether we should define the said 
> interface. The first charter draft does not seem to include 
> it. Iff we are chartered to define the rules-services 
> interface, then I would look at reusing WSDL core for 
> describing OCP-talking callout services and describing a 
> P:WSDL mapping of sorts (a BPEL equivalent for OPES?). 
> However, if we are not chartered to define the rules-services 
> interface, then WSDL and other W3C-technologies reuse becomes 
> irrelevant/future work.

abbie,

Agree, u read my mind there.

> 
> It seems to me that we must have a P-services interface 
> because without it, how will P interpreters map service calls 
> to OCP transactions? How will they make service parameters 
> available to P programmers to set? Will P interpreters report 
> service failures in a consistent way across implementations? 
> All these questions were already on P and even IRML to-do list, IIRC.
> 

--abbie
Was that raised in a REQUIREMENTS document?
Just being a devil advocate here!!!!

> If we decide to go down that path, the second question 
> becomes whether the P-services interface is OCP specific or 
> more general? Do we want to restrict P-invokable services to 
> OCP-talking services? To any WSDL-describable services? To 
> something else? Should this important decision be done now or 
> after we finish the new charter. That is, do we add the 
> answer or just the action item to the charter?
> 

---abbie
This is why I said it is muddy. I really do not know the answere right now
(It is a matter of scoping). 
However, I think we should explore these issues ASAP.

SNIP

abbie

---

From: Markus Hofmann <[email-masked]>
Date: Tue, 13 Jul 2004 16:55:40 -0400

Abbie Barbir wrote:

> well, I go for option a) to be frank. However, I can live with b) or c)
> if the WG wants that. 

Are there any new insights or developments that came up after our 
earlier discussions we had on "P" and other approaches? If not, I 
don't want to re-iterate the discussions we already had.

-Markus