Subject: Fwd: WG Review: Sieve Mail Filtering (sieve)

From: "Alex Rousskov" <[email-masked]>
Date: Wed, 03 Nov 2004 10:09:54 -0700

Looks like a handy summary of extensions, many of which I was not aware of.
There is a strong indication that Sieve has been widely implemented.

Alex.

------- Forwarded message -------
From: "The IESG" <[email-masked]>
To: [email-masked]
Subject: WG Review: Sieve Mail Filtering (sieve)
Date: Wed, 03 Nov 2004 11:26:11 -0500

A new IETF working group has been proposed in the Applications Area.
The IESG has not made any determination as yet. The following description
was submitted, and is provided for informational purposes only. Please send
your comments to the IESG mailing list ([email-masked]) by November 10th.

Sieve Mail Filtering (sieve)
============================

Current Status: Proposed Working Group

Description of the group:

The sieve mail filtering language specified in RFC 3028 has now been
implemented in a wide variety of user agents (UAs), mail delivery agents
(MDAs), and mail transfer agents (MTAs). Several extensions have been
specified (RFCs 3431, 3598, 3685, 3894) and have also been widely
implemented. Several additional sieve extensions have been defined in
various internet-drafts.

All of these documents are individual submissions; up to this point
work on sieve has been done informally and not under the auspices of
any IETF working group.

The sieve working group is being chartered to:

(1) Revise the base sieve specification, RFC 3028, with the intention of
moving it to draft standard. Substantive additions or revisions to the
base specification are out of scope of this working group. However, the
need to loosen current restrictions on side effects of tests as well as
the need for a normative reference to the newly-defined comparators
registry may necessitate a recycle at proposed.

(2) Produce updated sieve relational (RFC 3431), subaddress (RFC 3598),
spamtest/virustest (RFC 3685), and copy (RFC 3894) extension
specifications, again with the intention of making a move to
draft standard possible. It may be necessary to recycle some or all
of these documents at proposed, depending on the scope of any changes.

(3) Finalize and publish the sieve extensions as proposed standards:

(a) Variables (draft-homme-sieve-variables-04.txt)
(b) Vacation action (draft-showalter-sieve-vacation-05.txt)
(c) Message body tests (draft-degener-sieve-body-02.txt)
(d) Regular expressions (draft-murchison-sieve-regex-07.txt)
(e) MIME part tests (draft-daboo-sieve-mime-00.txt)
(f) Notification action (draft-martin-sieve-notify-02.txt)
(g) IMAP flags (draft-melnikov-sieve-imapflags-06.txt)
(h) Header editing actions (draft-degener-sieve-editheader-01.txt)
(i) Reject before delivery (draft-elvey-refuse-sieve-01.txt)

Additional drafts may be added this list, but only via a charter
revision. There must also be demonstrable willingness in the sieve
development community to actually implement a given extension before
it can be added to this charter.

Some aspects of sieve have complex internationalization issues; the working
group will seek out internationalization expertise as needed to complete  
its
work.

_______________________________________________
IETF-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf-announce

---

From: "Abbie Barbir" <[email-masked]>
Date: Thu, 4 Nov 2004 03:48:44 -0500

fyi,

abbie

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of The IESG
> Sent: Wednesday, November 03, 2004 11:26 AM
> Cc: [email-masked]
> The sieve mail filtering language specified in RFC 3028 has 
> now been implemented in a wide variety of user agents (UAs), 
> mail delivery agents (MDAs), and mail transfer agents (MTAs). 
> Several extensions have been specified (RFCs 3431, 3598, 
> 3685, 3894) and have also been widely implemented. Several 
> additional sieve extensions have been defined in various 
> internet-drafts.
> 
> All of these documents are individual submissions; up to this 
> point work on sieve has been done informally and not under 
> the auspices of any IETF working group.
> 
> (1) Revise the base sieve specification, RFC 3028, with the 
> intention of moving it to draft standard. Substantive 
> additions or revisions to the base specification are out of 
> scope of this working group. However, the need to loosen 
> current restrictions on side effects of tests as well as the 
> need for a normative reference to the newly-defined 
> comparators registry may necessitate a recycle at proposed.
> 
> (2) Produce updated sieve relational (RFC 3431), subaddress 
> (RFC 3598), spamtest/virustest (RFC 3685), and copy (RFC 
> 3894) extension specifications, again with the intention of 
> making a move to draft standard possible. It may be necessary 
> to recycle some or all of these documents at proposed, 
> depending on the scope of any changes.
> 
> Additional drafts may be added this list, but only via a 
> charter revision. There must also be demonstrable willingness 
> in the sieve development community to actually implement a 
> given extension before it can be added to this charter.
> 
> Some aspects of sieve have complex internationalization 
> issues; the working group will seek out internationalization 
> expertise as needed to complete its work.
> 
> 
> https://www1.ietf.org/mailman/listinfo/ietf-> announce
> 
>