Subject: Re: [OPSEC] Start of 2nd WGLC for draft-ietf-opsec-bgp-security

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Wed, 16 Apr 2014 11:55:32 +0000

Please find this reminder to query for your feedback.

Brgds,
G/

From: Gunter Van de Velde (gvandeve)
Sent: 08 April 2014 11:18
To: opsec wg mailing list
Cc: KK ([email-masked]); [email-masked]
Subject: Start of 2nd WGLC for draft-ietf-opsec-bgp-security

Dear OpSec WG,

This starts a 2nd Working Group Last Call for draft-ietf-opsec-bgp-security.

Due to the time taken to integrate all comments from the first WGLC this 2nd WGLC is initiated.

All three authors have replied, stating that they do not know of any IPR associated with this draft.

The draft is available here: https://datatracker.ietf.org/doc/draft-ietf-opsec-bgp-security/<https://datatracker.ietf.org/doc/draft-ietf-opsec-lla-only/>

Please review this draft to see if you think it is ready for publication and comments to the list, clearly stating your view.

This WGLC ends 22-April-2014.

Thanks,

G/

---

From: Ronald Bonica <[email-masked]>
Date: Wed, 16 Apr 2014 13:34:19 +0000

Folks,

This document is very comprehensive and well-written. Kudos to the authors.

However, please take a look at the Forward.

                                                Ron

From: OPSEC [mailto:[email-masked]] On Behalf Of Gunter Van de Velde (gvandeve)
Sent: Wednesday, April 16, 2014 7:56 AM
To: opsec wg mailing list
Cc: [email-masked]; [email-masked]
Subject: Re: [OPSEC] Start of 2nd WGLC for draft-ietf-opsec-bgp-security

Brgds,
G/

Cc: KK ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>

Dear OpSec WG,

Thanks,

G/

---

From: Ronald Bonica <[email-masked]>
Date: Wed, 16 Apr 2014 14:50:56 +0000

Folks,

In Sections 5.1.1.1 and 5.1.1.2, you say, "Only prefixes with value "False" in column "Global" MUST be discarded on Internet BGP peerings."

This statement is mostly true, but I can think of a corner case. Assume that two autonomous systems are cooperating to provide a DS-lite or some similar service. They might agree to co-ordinate assignment of non-global routes and exchange non-global routes with one another.

                                                                                  Ron

From: Ronald Bonica
Sent: Wednesday, April 16, 2014 9:34 AM
To: 'Gunter Van de Velde (gvandeve)'; opsec wg mailing list
Cc: [email-masked]; [email-masked]
Subject: RE: Start of 2nd WGLC for draft-ietf-opsec-bgp-security

Folks,

                                                Ron

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Brgds,
G/

Dear OpSec WG,

Thanks,

G/

---

From: "Jerome Durand (jerduran)" <[email-masked]>
Date: Wed, 16 Apr 2014 22:51:32 +0000

Thank you Ron for your comment and support,

Actually I believe exceptions can more or less happen for every guideline listed in the document. My view is that it is better to stay on the generic case and maybe better highlight in introduction that exceptions happen when both peers agree to do so. Idea would be that normative language only refer to classic peerings (not the exception scenario) so we don't have to change MUST for SHOULD everywhere in the doc and lower the value of the doc.

What do you think?

Thanks

Jerome

Le 16 avr. 2014 à 16:50, Ronald Bonica <[email-masked]>
 a écrit :

> Folks,
>  
> In Sections 5.1.1.1 and 5.1.1.2, you say, “Only prefixes with value "False" in column "Global" MUST be discarded on Internet BGP peerings.”
>  
> The draft is available here: https://datatracker.ietf.org/doc/draft-ietf-opsec-bgp-security/
>  
> _______________________________________________
> OPSEC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsec

--
Jerome Durand
Consulting Systems Engineer - Routing & Switching
[email-masked]  -  +33 6 35 11 60 50
blogs: http://reseauxblog.cisco.fr - http://ipv6blog.cisco.fr
twitter: @JeromeDurand
linkedin: http://fr.linkedin.com/in/jeromedurand

CISCO France
11, rue Camille Desmoulins
92782 Issy les Moulineaux
CEDEX 9
FRANCE

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 17 Apr 2014 18:44:54 +0000

Jerome,

Your approach may work. Since you can't soften the 2119 definition of the word "MUST", you will have to do something clever in the Introduction to restrict the scope if the document's recommendations. 

How will you do this?

                                                                           Ron

-----Original Message-----
From: Jerome Durand (jerduran) [mailto:[email-masked]] 
Sent: Wednesday, April 16, 2014 6:52 PM
To: Ronald Bonica
Cc: Gunter Van de Velde (gvandeve); opsec wg mailing list; [email-masked]; [email-masked]
Subject: Re: [OPSEC] Start of 2nd WGLC for draft-ietf-opsec-bgp-security

What do you think?

Thanks

Jerome

Le 16 avr. 2014 à 16:50, Ronald Bonica <[email-masked]>  a écrit :

> The draft is available here: 
> https://datatracker.ietf.org/doc/draft-ietf-opsec-bgp-security/
>  

--
Jerome Durand
Consulting Systems Engineer - Routing & Switching [email-masked]  -  +33 6 35 11 60 50
blogs: http://reseauxblog.cisco.fr - http://ipv6blog.cisco.fr
twitter: @JeromeDurand
linkedin: http://fr.linkedin.com/in/jeromedurand

CISCO France