Subject: [payload] I-D Action: draft-ietf-payload-vp8-14.txt

From: [email-masked]
Date: Tue, 03 Mar 2015 12:52:31 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Payloads Working Group of the IETF.

        Title           : RTP Payload Format for VP8 Video
        Authors         : Patrik Westin
                          Henrik F Lundin
                          Michael Glover
                          Justin Uberti
                          Frank Galligan
	Filename        : draft-ietf-payload-vp8-14.txt
	Pages           : 25
	Date            : 2015-03-03

Abstract:
   This memo describes an RTP payload format for the VP8 video codec.
   The payload format has wide applicability, as it supports
   applications from low bit-rate peer-to-peer usage, to high bit-rate
   video conferences.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-payload-vp8/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-payload-vp8-14

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-payload-vp8-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Thu, 5 Mar 2015 20:25:49 +0000

Hi,

The simulcast draft (draft-ietf-mmusic-sdp-simulcast) uses payload formats to express different simulcast encodings. This assumes the underlying payload format can express the desired encodings in its a=fmtp parameters. VP8 can express max-fs (roughly resolution) and max-fr (frame rate), which covers most simulcast use cases. However, you may want to consider adding max-br (bit rate) if you want to express simulcasting VP8 at different bit rates (for the same or different resolutions and frame rates).

Regards,
Mo

On 3/3/15, 3:52 PM, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

_______________________________________________
payload mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/payload

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 06 Mar 2015 11:51:22 +0000

On 03/05/2015 08:25 PM, Mo Zanaty (mzanaty) wrote:
> Hi,
>
> The simulcast draft (draft-ietf-mmusic-sdp-simulcast) uses payload
> formats to express different simulcast encodings. This assumes the
> underlying payload format can express the desired encodings in its
> a=fmtp parameters. VP8 can express max-fs (roughly resolution) and
> max-fr (frame rate), which covers most simulcast use cases. However,
> you may want to consider adding max-br (bit rate) if you want to
> express simulcasting VP8 at different bit rates (for the same or
> different resolutions and frame rates).

Thanks for the alert to mmusic-simulcast!

I've protested vehemently about the (ab)use of (codec-specific) a=fmtp
parameters to express (codec-independent) quality distinctions in the
past. I'll go protest again.

Harald

>
> Regards,
> Mo
>  
>
> On 3/3/15, 3:52 PM, [email-masked]
> <mailto:[email-masked]> <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
> [email-masked] <mailto:[email-masked]>
> [email-masked]

-- 
Surveillance is pervasive. Go Dark.

---

From: "Roni Even" <[email-masked]>
Date: Thu, 19 Mar 2015 13:14:41 +0200

Hi Harald,

The problem is that you cannot describe values per payload type number using
current SDP attributes the bit rate is for the whole m-line. For example if
using a=ssrc it is not mapped to a payload type number

BTW: this is one point we made in the application id document.

Roni

From: payload [mailto:[email-masked]] On Behalf Of Harald
Alvestrand
Sent: 06 March, 2015 1:51 PM
To: [email-masked]
Subject: Re: [payload] I-D Action: draft-ietf-payload-vp8-14.txt

Hi,

The simulcast draft (draft-ietf-mmusic-sdp-simulcast) uses payload formats
to express different simulcast encodings. This assumes the underlying
payload format can express the desired encodings in its a=fmtp parameters.
VP8 can express max-fs (roughly resolution) and max-fr (frame rate), which
covers most simulcast use cases. However, you may want to consider adding
max-br (bit rate) if you want to express simulcasting VP8 at different bit
rates (for the same or different resolutions and frame rates).

I've protested vehemently about the (ab)use of (codec-specific) a=fmtp
parameters to express (codec-independent) quality distinctions in the past.
I'll go protest again.

Harald

Regards,

Mo

On 3/3/15, 3:52 PM, [email-masked] <[email-masked]>
wrote:

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

This draft is a work item of the Audio/Video Transport Payloads Working
Group of the IETF.

        Authors         : Patrik Westin

                          Henrik F Lundin

                          Michael Glover

                          Justin Uberti

                          Frank Galligan

Pages           : 25

Date            : 2015-03-03

Abstract:

   video conferences.

 

payload mailing list

[email-masked]

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 19 Mar 2015 15:34:55 -0600

One small thing ... the References need to be sorted into Normative and Informative.

> On Mar 3, 2015, at 1:52 PM, [email-masked] wrote:
> 
> 
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 20 Mar 2015 12:35:31 +0100

On 03/19/2015 12:14 PM, Roni Even wrote:
>
> Hi Harald,
>
> The problem is that you cannot describe values per payload type number 
> using current SDP attributes the bit rate is for the whole m-line. For 
> example if using a=ssrc it is not mapped to a payload type number
>

Yes, this is a problem that needs solving.

Tying bitrates to payload types is also a Bad Idea; if we are ever to 
get reasonable handling of multiple SSRCs in the same media description 
with the same payload type, we need to tie them to some other 
identifier. But in the context of simulcast as described here, I guess 
that Bad Idea is already so deeply adopted that it can't be removed.

But it still doesn't excuse the misfeature of trying to do external 
imposition of parameters on the a=fmtp line.

I'll go be explicit on mmusic now.

---

From: Henrik Lundin <[email-masked]>
Date: Mon, 23 Mar 2015 21:14:31 +0100

Done in https://tools.ietf.org/html/draft-ietf-payload-vp8-15.

Thanks!
/Henrik

-- 
Henrik Lundin | WebRTC Software Eng | [email-masked] | +46 70 646 13 41