Subject: [payload] draft-ietf-payload-rtp-ancillary: trying to wrap it up

From: Thomas Edwards <[email-masked]>
Date: Tue, 15 Mar 2016 00:46:15 +0000

Dear Payload WG,

Based on feedback from members of the Video Services Forum, SMPTE, and the Advanced Media Workflow Association, I have accumulated some final potential changes for draft-ietf-payload-rtp-ancillary.   These are presented in the attached draft I-D, with these changes:

1) Changed octet-alignment of the end of ANC data with 32-bit word alignment, mainly to aid FPGA implementations.
2) Added SHOULD language regarding latency issues including upper bounds on ANC data packet retention and raster order transmission.
3) The URL listing of SMPTE Registered ANC packet types was wrong and has been corrected.

Please let me know if you have any further comments on the potential changes on the draft.

As you may know, the last submission time for Internet-Drafts before IETF-95 is 2016-03-21 23:59 UTC.

If there is consensus in the Payload WG, I would like to upload the version 3 of this I-D before that deadline, and then would like to ask the WG Chairs for a determination if that draft would then be ready to be sent to the AD.

Thanks!

-Thomas

P.S.: There is now work ongoing in SMPTE 32NF-60 Video over IP WG to standardize VSF TR-03, which references draft-ietf-payload-rtp-ancillary, so it would be super for the broadcast industry if this draft could reach RFC before the end of the SMPTE standardization process.

--
Thomas Edwards
VP Engineering & Development
FOX Networks Engineering and Operations
[email-masked]
Phone: +1.310.369.6696
10201 West Pico Blvd.
Los Angeles, CA 90035

---

From: "Ali C. Begen" <[email-masked]>
Date: Tue, 15 Mar 2016 06:08:44 +0200

Changes look good to me.

-acbegen

On Tue, Mar 15, 2016 at 2:46 AM, Thomas Edwards <[email-masked]>
wrote:

> Dear Payload WG,
>
> Based on feedback from members of the Video Services Forum, SMPTE, and the
> Advanced Media Workflow Association, I have accumulated some final
> potential changes for draft-ietf-payload-rtp-ancillary.   These are
> presented in the attached draft I-D, with these changes:
>
> 1) Changed octet-alignment of the end of ANC data with 32-bit word
> alignment, mainly to aid FPGA implementations.
> 2) Added SHOULD language regarding latency issues including upper bounds
> on ANC data packet retention and raster order transmission.
> If there is consensus in the Payload WG, I would like to upload the
> version 3 of this I-D before that deadline, and then would like to ask the
> WG Chairs for a determination if that draft would then be ready to be sent
> to the AD.
>
> Thanks!
>
> -Thomas
>
> P.S.: There is now work ongoing in SMPTE 32NF-60 Video over IP WG to
> standardize VSF TR-03, which references draft-ietf-payload-rtp-ancillary,
> so it would be super for the broadcast industry if this draft could reach
> RFC before the end of the SMPTE standardization process.
>
> --
> Thomas Edwards
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
>
>