Subject: [payload] Protocol Action: 'RTP Payload Format for Flexible Forward Error Correction (FEC)' to Proposed Standard (draft-ietf-payload-flexible-fec-scheme-18.txt)

From: The IESG <[email-masked]>
Date: Thu, 21 Mar 2019 01:41:40 -0700

The IESG has approved the following document:
- 'RTP Payload Format for Flexible Forward Error Correction (FEC)'
  (draft-ietf-payload-flexible-fec-scheme-18.txt) as Proposed Standard

This document is the product of the Audio/Video Transport Payloads Working
Group.

The IESG contact persons are Adam Roach, Alexey Melnikov and Ben Campbell.

A URL of this Internet Draft is:
https://datatracker.ietf.org/doc/draft-ietf-payload-flexible-fec-scheme/

Technical Summary:

This document defines new RTP payload formats for the Forward Error Correction (FEC) packets that are generated by the non-interleaved  and interleaved parity codes from source media encapsulated in RTP.   These parity codes are systematic codes, where a number of FEC repair packets are generated from a set of source packets from one or more source RTP streams.  These FEC repair packets are sent in a redundancy RTP stream separate from the source RTP stream(s) that  carries the source packets.  RTP source packets that were lost in   transmission can be reconstructed using the source and repair packets that were received.  The non-interleaved and interleaved parity codes   which are defined in this specification offer a good protection against random and bursty packet losses, respectively, at a cost of decent complexity. 

Working Group Summary:

The document was discussed in the meetings, and on the mailing list. The open issues were addressed and there are no open issues; there was consensus on the content of the document.

Document Quality:

The payload was developed by members from different vendors and is part of the RTCWEB deliveries. Magnus Westerlund and Steve Botzko did a thorough review of the document.
A request for a media type review was sent to ietf-types and media-types mailing lists.

Personnel:

Roni Even is the Document Shepherd.
The responsible AD is Ben Campbell.

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 21 Mar 2019 11:39:27 -0400

This is broken.

During review, serious issues were found with this document, and we were
working through the required changes with one of the authors (Varun).

Just because the editor decided to ignore the problems doesn't mean they
don't need to be fixed.

On Thu, Mar 21, 2019 at 4:42 AM The IESG <[email-masked]> wrote:

> This document defines new RTP payload formats for the Forward Error
> Correction (FEC) packets that are generated by the non-interleaved  and
> interleaved parity codes from source media encapsulated in RTP.   These
> parity codes are systematic codes, where a number of FEC repair packets are
> generated from a set of source packets from one or more source RTP
> streams.  These FEC repair packets are sent in a redundancy RTP stream
> separate from the source RTP stream(s) that  carries the source packets.
> RTP source packets that were lost in   transmission can be reconstructed
> using the source and repair packets that were received.  The
> non-interleaved and interleaved parity codes   which are defined in this
> specification offer a good protection against random and bursty packet
> losses, respectively, at a cost of decent complexity.
>
>
> Working Group Summary:
>
> The document was discussed in the meetings, and on the mailing list. The
> open issues were addressed and there are no open issues; there was
> consensus on the content of the document.
>
> Document Quality:
>
> The payload was developed by members from different vendors and is part of
> the RTCWEB deliveries. Magnus Westerlund and Steve Botzko did a thorough
> review of the document.
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
>

---

From: Giridhar Mandyam <[email-masked]>
Date: Thu, 21 Mar 2019 15:43:24 +0000

> Just because the editor decided to ignore the problems doesn't mean they don't need to be fixed.

I did not ignore any “problems”.  I just did not see an actionable  proposal for specific text that could be added to the I.-D.  If you have suggestions, please provide them.

If the discussion is going to be this contentious, I am afraid we will have trouble reaching a desired outcome – a complete and usable specification.

-Giri

From: Bernard Aboba <[email-masked]>
Sent: Thursday, March 21, 2019 8:39 AM
To: [email-masked]
Cc: [email-masked]; The IESG <[email-masked]>; [email-masked]
Subject: Re: [payload] Protocol Action: 'RTP Payload Format for Flexible Forward Error Correction (FEC)' to Proposed Standard (draft-ietf-payload-flexible-fec-scheme-18.txt)

CAUTION: This email originated from outside of the organization.
This is broken.

During review, serious issues were found with this document, and we were working through the required changes with one of the authors (Varun).

Just because the editor decided to ignore the problems doesn't mean they don't need to be fixed.

On Thu, Mar 21, 2019 at 4:42 AM The IESG <[email-masked]<mailto:[email-masked]>> wrote:
The IESG has approved the following document:
- 'RTP Payload Format for Flexible Forward Error Correction (FEC)'
  (draft-ietf-payload-flexible-fec-scheme-18.txt) as Proposed Standard

Technical Summary:

Working Group Summary:

Document Quality:

Personnel:

_______________________________________________
payload mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/payload

---

From: Ben Campbell <[email-masked]>
Date: Thu, 21 Mar 2019 13:32:53 -0500

Hi Bernard,

It’s already been pulled back to the “Point raised” sub-state. It was an error on my part to approve it prematurely.

However, last I checked I think Varun was waiting for feedback from you. (Apologies If that happened since I checked last.)

Thanks!

Ben.

> On Mar 21, 2019, at 10:39 AM, Bernard Aboba <[email-masked]> wrote:
> 
> This is broken.
> 
> On Thu, Mar 21, 2019 at 4:42 AM The IESG <[email-masked] <mailto:[email-masked]>> wrote:
> https://datatracker.ietf.org/doc/draft-ietf-payload-flexible-fec-scheme/ <https://datatracker.ietf.org/doc/draft-ietf-payload-flexible-fec-scheme/>
> 
> 
> 
> 
> Technical Summary:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/payload <https://www.ietf.org/mailman/listinfo/payload>

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 21 Mar 2019 20:39:51 -0400

I believe that Varun was looking for feedback from the WG not from me
(since I generally agreed with his proposal for rewriting the SDP section
of the document).

On Thu, Mar 21, 2019 at 2:33 PM Ben Campbell <[email-masked]> wrote:

> Hi Bernard,
>
> It’s already been pulled back to the “Point raised” sub-state. It was an
> error on my part to approve it prematurely.
>
> However, last I checked I think Varun was waiting for feedback from you.
> (Apologies If that happened since I checked last.)
>
> Thanks!
>
> Ben.
>
>> The payload was developed by members from different vendors and is part
>> of the RTCWEB deliveries. Magnus Westerlund and Steve Botzko did a thorough
>> review of the document.