Subject: [Perc] Agenda bashing

From: Magnus Westerlund <[email-masked]>
Date: Mon, 2 Nov 2015 06:01:18 +0900

Hi,

I have looked at the agenda and what topics are on it. I think the most 
important topic for this WG session is that we understand what 
information that is needed end-to-end for the RTP media, and what level 
of protection such information needs.

This includes what treatment we expect of the RTP fields by the MDDs, 
i.e. if the MDD may change them and if the original value is needed. 
Next we need to understand if the receiving endpoint needs the source 
value, and if the value in itself should be authenticated and 
confidentiality protected and the reasons behind that.

Without an agreement about this and common understanding about the 
reasons behind this agreement we will not be able to make progress on 
the solution to the end-to-end protection mechanism.

In the process of writing:
https://datatracker.ietf.org/doc/draft-westerlund-perc-rtp-field-considerations/
I found some factors that surprised me a bit, and hope people will 
prepare and review this draft.

Having started working on the discussion material for this part, I don't 
think 30 minutes is sufficient for this discussion. I think it will take 
much more time as there are some questions and trade-offs that needs WG 
discussion. Thus, I would request that we bash the agenda to allow 
sufficient time for this discussion. I think at least 1 hour should be 
used for this discussion.

Me personally think that bulk of that time should come from the solution 
topics, as they can't progress without the above agreement on what we 
think really needs protection.

This is clearly up to the chairs in the end, but I want to know if 
people agree with my views?

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 2 Nov 2015 06:47:44 +0900

+1

On Mon, Nov 2, 2015 at 6:01 AM, Magnus Westerlund <
[email-masked]> wrote:

> important topic for this WG session is that we understand what information
> that is needed end-to-end for the RTP media, and what level of protection
> such information needs.
>
> This includes what treatment we expect of the RTP fields by the MDDs, i.e.
> if the MDD may change them and if the original value is needed. Next we
> need to understand if the receiving endpoint needs the source value, and if
> the value in itself should be authenticated and confidentiality protected
> and the reasons behind that.
>
> Without an agreement about this and common understanding about the reasons
> behind this agreement we will not be able to make progress on the solution
> to the end-to-end protection mechanism.
>
> I found some factors that surprised me a bit, and hope people will prepare
> and review this draft.
>
> sufficient time for this discussion. I think at least 1 hour should be used
> for this discussion.
>
> topics, as they can't progress without the above agreement on what we think
> really needs protection.
>
> This is clearly up to the chairs in the end, but I want to know if people
> agree with my views?
>
> Cheers
>
> Magnus Westerlund
>
> _______________________________________________
> Perc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perc
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 02 Nov 2015 06:54:04 +0900

I read the draft and agree with most (perhaps all) of the conclusions. So, will you need so much time to build a case for each field?

I certainly agree we need to reach agreement on what is to be protected and how.  I just didn't think most will be controversial.

Paul

-------- Original Message --------
From: Magnus Westerlund <[email-masked]>
Sent: November 2, 2015 6:01:18 AM GMT+09:00
To: "[email-masked]" <[email-masked]>
Subject: [Perc] Agenda bashing

Hi,

Cheers

Magnus Westerlund

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 2 Nov 2015 10:15:13 +0900

Den 2015-11-02 kl. 06:54, skrev Paul E. Jones:
> I read the draft and agree with most (perhaps all) of the conclusions.
> So, will you need so much time to build a case for each field?
>
> I certainly agree we need to reach agreement on what is to be protected
> and how. I just didn't think most will be controversial.

No, but there are several that is problematic and where I think 
potential solutions are non-trivial. The ones that I top of my head 
thinks have issues needing discussions are:

PT
Header extension IDs
End-to-end Source ID
CSRC from source
The different header extensions where we have some that appear to 
warrant end-to-end confidentiality, some require end-to-end authentication.

To have the discussion of some of these issues, we need to discuss the 
attacks that are threats.

Cheers

Magnus Westerlund

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 02 Nov 2015 10:32:17 +0900

Magnus,

If we take steps to ensure the receiver can reconstruct the original packet the sender sent, many concerns are addressed.  I think. It would be possible for the MDDs to change anything in the headers.

The challenging bit, I think, is E2E encryption of header extensions.  We need a solution to do that. Getting agreement its needed is important, but we don't have to solve how to do it in your talk.  Even preserving header extensions might be a challenge.  That was why our original proposal called for HBH treatment of header extensions.

The rest seems simple to handle and you make valid arguments for allowing changes and we need to preserve the original values to ensure we can do E2E authentication.

Paul

-------- Original Message --------
From: Magnus Westerlund <[email-masked]>
Sent: November 2, 2015 10:15:13 AM GMT+09:00
To: "Paul E. Jones" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Perc] Agenda bashing

PT
Header extension IDs
End-to-end Source ID
CSRC from source

Cheers

Magnus Westerlund

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 2 Nov 2015 11:13:16 +0900

Den 2015-11-02 kl. 10:32, skrev Paul E. Jones:
> Magnus,
>
> If we take steps to ensure the receiver can reconstruct the original
> packet the sender sent, many concerns are addressed. I think. It would
> be possible for the MDDs to change anything in the headers.

Yes, but that is a particular solution, and although it could work, that 
would be without understanding the actual requirements the fileds has. 
And I would note that the conclusions from a point to point case, is not 
always applicable to end-to-end in a point to multi-point case that we 
discuss in PERC.

>
> The challenging bit, I think, is E2E encryption of header extensions. We
> need a solution to do that. Getting agreement its needed is important,
> but we don't have to solve how to do it in your talk. Even preserving
> header extensions might be a challenge. That was why our original
> proposal called for HBH treatment of header extensions.
>

No, I agree we are not going into solutions. But, the point I want to 
make is that we need to start from analyzing the information present in 
the header extensions and derive protection requirement from that, 
rather than the other way around.

> The rest seems simple to handle and you make valid arguments for
> allowing changes and we need to preserve the original values to ensure
> we can do E2E authentication.
>

I think PT and header extension IDs are actually an interesting issue. 
See the draft for the issue here.

Cheers

Magnus Westerlund

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 2 Nov 2015 13:38:09 +0900

We have 30 minutes for this. I’m sure we could discuss this for 100s of hours but it seems like 30 minutes would be enough to get to the heart of all if. 

> On Nov 2, 2015, at 6:01 AM, Magnus Westerlund <[email-masked]> wrote:
> 
> Hi,
> 
> I have looked at the agenda and what topics are on it. I think the most important topic for this WG session is that we understand what information that is needed end-to-end for the RTP media, and what level of protection such information needs.
> 
> This includes what treatment we expect of the RTP fields by the MDDs, i.e. if the MDD may change them and if the original value is needed. Next we need to understand if the receiving endpoint needs the source value, and if the value in itself should be authenticated and confidentiality protected and the reasons behind that.
> 
> Without an agreement about this and common understanding about the reasons behind this agreement we will not be able to make progress on the solution to the end-to-end protection mechanism.
> 
> I found some factors that surprised me a bit, and hope people will prepare and review this draft.
> 
> Having started working on the discussion material for this part, I don't think 30 minutes is sufficient for this discussion. I think it will take much more time as there are some questions and trade-offs that needs WG discussion. Thus, I would request that we bash the agenda to allow sufficient time for this discussion. I think at least 1 hour should be used for this discussion.
> 
> Me personally think that bulk of that time should come from the solution topics, as they can't progress without the above agreement on what we think really needs protection.
> 
> This is clearly up to the chairs in the end, but I want to know if people agree with my views?
> 
> Cheers
> 
> Magnus Westerlund
>

---

From: Richard Barnes <[email-masked]>
Date: Tue, 3 Nov 2015 13:43:59 +0900

Sorry for the delayed reply.  For some reason, this message did not
get delivered.

Given the discussion, I'm going to propose that we revise the agenda
to the following:

15min Chairs
45min draft-westerlund-perc-rtp-field-considerations
30min draft-mattsson-perc-srtp-cloud
30min draft-jones-perc-private-media-reqts
15min draft-groves-perc-clue

Magnus, if you want more than that, feel free to negotiate with John
and Cullen :)

--Richard

---------- Forwarded message ----------
From: Magnus Westerlund <[email-masked]>
Date: Sun, Nov 1, 2015 at 1:01 PM
Subject: [Perc] Agenda bashing
To: "[email-masked]" <[email-masked]>

Hi,

I have looked at the agenda and what topics are on it. I think the
most important topic for this WG session is that we understand what
information that is needed end-to-end for the RTP media, and what
level of protection such information needs.

Having started working on the discussion material for this part, I
don't think 30 minutes is sufficient for this discussion. I think it
will take much more time as there are some questions and trade-offs
that needs WG discussion. Thus, I would request that we bash the
agenda to allow sufficient time for this discussion. I think at least
1 hour should be used for this discussion.

Me personally think that bulk of that time should come from the
solution topics, as they can't progress without the above agreement on
what we think really needs protection.

Cheers

Magnus Westerlund

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 2 Nov 2015 20:50:28 -0800

So here is the updated Agenda uploaded based on Richard's response

https://datatracker.ietf.org/meeting/94/agenda/perc/

Cheers
Suhas