Subject: [Perc] I-D Action: draft-ietf-perc-private-media-framework-08.txt

From: [email-masked]
Date: Wed, 23 Jan 2019 10:51:21 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Privacy Enhanced RTP Conferencing  WG of the IETF.

        Title           : A Solution Framework for Private Media in Privacy Enhanced RTP Conferencing
        Authors         : Paul E. Jones
                          David Benham
                          Christian Groves
	Filename        : draft-ietf-perc-private-media-framework-08.txt
	Pages           : 24
	Date            : 2019-01-23

Abstract:
   This document describes a solution framework for ensuring that media
   confidentiality and integrity are maintained end-to-end within the
   context of a switched conferencing environment where media
   distributors are not trusted with the end-to-end media encryption
   keys.  The solution aims to build upon existing security mechanisms
   defined for the real-time transport protocol (RTP).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-perc-private-media-framework/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-perc-private-media-framework-08
https://datatracker.ietf.org/doc/html/draft-ietf-perc-private-media-framework-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-perc-private-media-framework-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ben Campbell <[email-masked]>
Date: Wed, 30 Jan 2019 18:29:20 -0600

Hi,

This version is much better than 07. Thanks for the work on that. I think it’s now ready for IETF Last Call. I will request that shortly.

I have a few new minor editorial comments that can be addressed along with any IETF LC feedback.

Thanks!

Ben.

——————

- (Nit) §1, 2nd paragraph:  The new text addresses my concern, but it added a comma splice. I suggest making the text starting with "this draft aims…” into its own sentence.

- Previous Comment:

> 
> §3.1.2, last paragraph: "In any deployment scenario where the call processing function is
> considered trusted, the call processing function MUST ensure the
> integrity of received messages before forwarding to other entities.”
> 
> Please describe why that is important in a PERC environment.

The text was removed. I assume the authors decided it was not specific to PERC?

- (Nit) §4.5.2, 3rd paragraph:

 The change resolves my concern, but I have one editorial suggestion:

OLD:
When a Key Distributor decides to re-key a conference, it transmits a new EKTKey message [
I-D.ietf-perc-srtp-ekt-diet  to each of the conference participants containing the new EKT Key.
NEW:
When a Key Distributor decides to re-key a conference, it transmits a new EKTKey message
containing the new EKT Key [I-D.ietf-perc-srtp-ekt-diet] to each of the conference participants.

- (Nit): New §6.1: "While the number key types is very small”
s:/“number key types”/“number of key types"

> On Jan 23, 2019, at 12:51 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Perc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perc

---

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 31 Jan 2019 01:41:03 +0000

Thanks! I'll keep this message in my inbox and make changes as requested 
when creating the next version.

For the "The text was removed. I assume the authors decided it was not 
specific to PERC?" question:

I got agreement to remove it. PERC is intended to (and does) provide 
end-to-end authentication, and the procedures spell out what 
intermediaries (trusted or otherwise) are supposed to do HBH. This text 
seemed to suggest there is something special in this case when there 
isn't. It seemed to add no value, clearly caused confusion, and we could 
not figure out why it was there in the first place.

Paul

------ Original Message ------
From: "Ben Campbell" <[email-masked]>
To: [email-masked]; [email-masked]
Sent: 1/30/2019 7:29:20 PM
Subject: Re: [Perc] I-D Action: 
draft-ietf-perc-private-media-framework-08.txt