Subject: [PMOL] Fwd: Re: cron job for the IETF doctors/directorates

From: Benoit Claise <[email-masked]>
Date: Thu, 20 Sep 2012 14:28:02 +0200

Dear all,

The first priority for this group is to be aware of performance metrics 
related drafts.
Below is a mechanism put in place in the AAA directorate.
We could use it to search, on a weekly basis, for all drafts containing 
"performance" and "metric".
I'm still hoping to host such a script on a IETF server (second 
attempt). I'll keep you posted.
Any thougths?

Regards, Benoit.

-------- Original Message --------
Subject: 	Re: cron job for the IETF doctors/directorates
Date: 	Thu, 20 Sep 2012 14:11:57 +0200
From: 	Benoit Claise <[email-masked]>
To: 	Tools Team Discussion <[email-masked]>, Henrik Levkowetz 
<[email-masked]>
CC: 	IESG IESG <[email-masked]>, [email-masked]

Dear tools expert,

I'm not sure I saw any replies to this request.
Please let me know if installing such as cron job, customized for the 
different directorates, is possible?
I now have one more use for this script: the PMOL directorate, searching 
for performance metrics related drafts

Regards, Benoit.
> Dear all,
>
> Alan Dekok has this excellent weekly script for the AAA directorates: 
> it returns all the active IETF drafts that have a reference to radius. 
> The results are sent via email.
> For example:
>
>     draft-ietf-softwire-6rd-radius-attrib-05          Active	
>     draft-ietf-abfab-arch-03                          Active	
>     draft-ietf-netmod-system-mgmt-02                  Active	
>     draft-ietf-geopriv-held-measurements-05           Active	
>     draft-ietf-dhc-dhcpv6-radius-opt-01               Active	
>     draft-ietf-abfab-aaa-saml-03                      Active	
>     draft-ietf-precis-framework-04                    Active	
>
> This script from Alan Dekok helps the doctors to list which drafts 
> reference the directorate area of interest.
> During the AAA lunch at the IETF, we discussed the script extension to 
> other directorates.
> Alan updated his script for the YANG doctors.
>
>     $ ./ietf-tech-report -r yang
>     draft-ietf-netmod-routing-cfg-04                  Active	
>     draft-ietf-netmod-iana-if-type-04                 Active	
>     draft-ietf-netmod-system-mgmt-02                  Active	
>     draft-ietf-netmod-interfaces-cfg-05               Active	
>     draft-ietf-ipfix-configuration-model-11           In IESG processing -
>     ID Tracker state <RFC Ed Queue>	
>     draft-ietf-netmod-iana-timezones-00               Active	
>     draft-ietf-netmod-snmp-cfg-00                     Active	
>     draft-ietf-netmod-ip-cfg-05                       Active
>
> Pretty cool, isn't it?
>
> The ideal solution would be
>     - to host this script on an IETF server
>     - to have multiple script instances for each doctor/directorate
> I'm trying to pursue that route.
>
> Do you think it's possible? Practically, how to proceed?
>
> Regards, Benoit.
>
> -------- Original Message --------
> Subject: 	[AAA-DOCTORS] Updated "tech report" script
> Date: 	Mon, 06 Aug 2012 13:28:30 +0200
> From: 	Alan T DeKok <[email-masked]>
> Reply-To: 	[email-masked]
> To: 	[email-masked]
>
>
>
>    I've put it up on github:
>
> https://github.com/alandekok/ietf-tech-report
>
>    With documentation and everything...
>
> $ ./ietf-tech-report -r radius
> draft-ietf-dhc-dhcpv6-radius-opt-01               Active	
> draft-ietf-softwire-6rd-radius-attrib-05          Active	
> draft-ietf-abfab-arch-03                          Active	
> draft-ietf-abfab-aaa-saml-03                      Active	
> draft-ietf-netmod-system-mgmt-02                  Active	
> draft-ietf-abfab-gss-eap-08                       In IESG processing -
> ID Tracker state <Approved-announcement to be sent::Point Raised -
> writeup needed>	
>
>
> $ ./ietf-tech-report -r yang
> draft-ietf-netmod-routing-cfg-04                  Active	
> draft-ietf-netmod-iana-if-type-04                 Active	
> draft-ietf-netmod-system-mgmt-02                  Active	
> draft-ietf-netmod-interfaces-cfg-05               Active	
> draft-ietf-ipfix-configuration-model-11           In IESG processing -
> ID Tracker state <RFC Ed Queue>	
> draft-ietf-netmod-iana-timezones-00               Active	
> draft-ietf-netmod-snmp-cfg-00                     Active	
> draft-ietf-netmod-ip-cfg-05                       Active
> _______________________________________________
> AAA-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aaa-doctors
>
>
>
>
>

---

From: Al Morton <[email-masked]>
Date: Thu, 20 Sep 2012 09:17:19 -0400

At 08:28 AM 9/20/2012, Benoit Claise wrote:
>...We could use it to search, on a weekly basis, for all drafts 
>containing "performance" and "metric".

Interesting capability, and worth a try IMO (maybe with some tweaks).
Al

---

From: Vinayak Hegde <[email-masked]>
Date: Wed, 26 Sep 2012 00:16:23 +0530

On Thu, Sep 20, 2012 at 6:47 PM, Al Morton <[email-masked]> wrote:
>> ...We could use it to search, on a weekly basis, for all drafts containing
>> I'm still hoping to host such a script on a IETF server (second attempt).
>> I'll keep you posted.
>> Any thougths?
>
>

Sounds like a good idea to me. We should try it out.

Regards
Vinayak