Subject: Re: [ppsp] PPSP Protocols

From: "Victor Pascual Ávila" <[email-masked]>
Date: Mon, 5 Jan 2009 13:58:15 +0100

On Tue, Dec 9, 2008 at 9:01 AM, Schmidt, Christian 1. (NSN -
DE/Munich) <[email-masked]> wrote:
> Hi Yunfei,
>
> in the problem statement (PDF), you mention in section 2:
> Problem: "First, the startup delay(20~30s), the latency between the
> broadcasting time and the audience view time(120s), the re-buffering time
> after a dragging or forward/backward in VoD(6~8s) and the channel switch
> time are still long. How to reduce these delays in the Internet is an open
> question"
>
> In the BAR BOF presentation,  you mention mandatory requirements, which are
> nearly the same, you mentioned to be a problem in your problem description.
> If the recommended figures are similar to the actual figures, where is the
> problem?

Is it to compete with classical TV broadcasting?

Cheers,
-Victor

> Therefore my question remain:
> What numbers do you recommend for this purpose, that this is no longer a
> problem in this area?
>
> Regards
> Christian
>
>
>
>
>
> ________________________________
> From: ext yunfei zhang [mailto:[email-masked]]
> Sent: Tuesday, December 09, 2008 7:23 AM
> To: Schmidt, Christian 1. (NSN - DE/Munich)
> Cc: Victor Pascual Ávila; [email-masked]
> Subject: Re: [ppsp] PPSP Protocols
>
> Hi,Christian,Sorry to delay the email.Attached is the draft and slides of
> the problem statement of ppsp.Please check it for reference.Looking forward
> to discussing more in PPSP with you.
>
>
>
>                          Yunfei
>
>
> 2008/12/1, Schmidt, Christian 1. (NSN - DE/Munich)
> <[email-masked]>:
>>
>> Hi Yunfei,
>>
>> Are the mentioned requirements for PPSP traffic (e.g. the rigid real-time
>> requirements) listed somewhere?
>> Can you provide some input?
>>
>> Christian
>>
>> ________________________________
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> ext yunfei zhang
>> Sent: Monday, December 01, 2008 10:27 AM
>> To: Victor Pascual Ávila
>> Cc: [email-masked]
>> Subject: Re: [ppsp] PPSP Protocols
>>
>>
>> We have discussed these issues in the mailing list.Unfortunately there
>> were something wrong with the mailing list last month and the discussion
>> didn't appear in the mailing list.
>> I'd like to answer this question once again.
>> 1)As mentioned in the presentation and the problem statement document in
>> the bar bof, PPSP signaling protocol has a similar stack position as
>> P2PSIP.But P2PSIP doesn't meet the rigid real-time requirements in live and
>> vod streaming due to the searching inefficency.Moreover the heavyweight
>> signaling overhead in P2PSIP isn't suitable for streaming applications.
>> 2)RTP seems unsuitable for PPSP transmission for the following reasons:
>>    a)The timing and syn information in RTP is of no use in one-to-many
>> envirnment which achieves the similar effect using a different means;but we
>> will still explore the feasibilty of using RTP in p2p streaming
>> envrinment.This is one of the main tasks in PPSP transmission part.
>>    b)In current practice UDP is mostly used for P2P transmission and it
>> proves to be efficent;
>>
>>                                        Yunfei
>>
>>
>> 2008/11/26, Victor Pascual Ávila <[email-masked]>:
>>>
>>> Hi,
>>> (trying to catch up with the discussion)
>>>
>>> PPSP Signaling Protocol:
>>>
>>> On Thu, 23 Oct 2008 11:02:44 +0800, Song Haibin posted a message[1]
>>> that does not seem to have generated much echo (browsing the
>>> discussion archive I failed to find any response).
>>>
>>> [1] http://www.ietf.org/mail-archive/web/ppsp/current/msg00005.html
>>>
>>> Is there any significant difference between "PPSP Signaling Procotol"
>>> and "P2PSIP Peer Protocol + SIP + OTSp2p-like algorithm"?
>>>
>>> PPSP Transmission Protocol:
>>>
>>> Why isn't RTP sufficient for this?
>>>
>>> Cheers and excuse me if it has been already discussed,
>>> --
>>> Victor Pascual Ávila
>>> _______________________________________________
>>> ppsp mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ppsp
>>
>
>

-- 
Victor Pascual Ávila
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "yunfei zhang" <[email-masked]>
Date: Thu, 15 Jan 2009 16:43:09 +0800

Hi,Victor,in my initial plan of PPSP,I'm not intented to compete with
classical TV broadcasting.Rather, we'd like to provide Internet-based TV
broadcasting.We know that currently there is trend of providing high quality
streaming program in Internet.Therefore our aim is to make the performance
of PPSP applications as good as possible.But we needn't compare every metric
with classical TV broadcasting.

                 Yunfei