Subject: [ppsp] minutes of PPSP final Bar BOF

From: "zhangyunfei" <[email-masked]>
Date: Wed, 5 Aug 2009 14:51:33 +0800

Hi all,
   The minutes of PPSP final Bar BOF is as follows.Please take a look and feel free to comment. Thanks to Victor for taking the notes!
 
                                             BR
                                               Yunfei
------------------------------------------------------------------------------------------------------------------------

A 3rd PPSP bar bof was held on Thursday July 30, 2009 at IETF 75 Stockholm meeting. This is a follow-up to meetings at IETF 73 Minneapolis and IETF 74 San Francisco.
 
Mailing list：[email-masked] http://www.ietf.org/mailman/listinfo/ppsp
 
PPSP Final bar BOF-- IETF 75, Stockholm (2000-2200 Thursday, July 30, Room 300)
Number of participants: around 50 
Previous meetings:
IETF 73: 1st Bar BOF
IETF 74: 2nd Bar BOF Minutes: http://www.ietf.org/mail-archive/web/ppsp/current/msg00158.html
 
Chairs:
Yunfei Zhang( [email-masked])
Gonzalo Camarillo ( [email-masked])
Ning Zong([email-masked])
 
AD: Lars Eggert( [email-masked]) 
 
Note taker: Victor Pascual ([email-masked])
Jabber scribe: Vijay Gurbani ([email-masked]) http://jabber.ietf.org/logs/tsvarea/2009-07-30.txt  
 
Websites:
IETF wiki page: http://trac.tools.ietf.org/area/tsv/trac/wiki/PPSP?version=10
China Mobile PPSP page: http://labs.chinamobile.com/ppsp/ietf
 
Agenda:
 
1. Agenda bashing (Chair,5')  
2. Short Introduction (Chair,5') 
                                                                      
3. Problem Statement (Yunfei Zhang, 40')
Draft: http://tools.ietf.org/html/draft-zhang-ppsp-problem-statement-04
Slides: http://www.iptel.org/victor/IETF/IETF75/PPSP/IETF75v5.ppt
 
4. Solution and survey drafts 
 
-Chunk Discovery for P2P Streaming (Ning Zong, 20’) 
Draft: http://www.ietf.org/id/draft-zong-ppsp-chunk-discovery-00.txt
Slides: http://www.iptel.org/victor/IETF/IETF75/PPSP/Chunk%20Discovery%20for%20P2P%20Streaming.ppt
 
- Protocol Analysis of PPlive, PPStream and UUSee by Interent Measurement (Yunfei Zhang,10') 
Draft: http://tools.ietf.org/html/draft-zhang-ppsp-protocol-comparison-measurement-02
Slides: http://www.iptel.org/victor/IETF/IETF75/PPSP/protocol%20comaprison.ppt
 
5. Discussion (All, 30')
6. Decisions and HUMs (All, 5')
7. Conclusions and Next Steps (Chairs/ADs, 5')   
 
Note well and agenda– Yunfei Zhang
Yunfei presented the agenda. This is the 3rd and last Bar BOF and the goal is polishing the problem statement while getting ready for an official BOF in Japan
 
Problem Statement – Yunfei Zhang
Yunfei presented slides on Problem Statement.
 
The use cases are not clear (the play out layer does only include limited commands).
Answer：This could be extended. Currently mainly for live streaming. If dealing with VoD or others, more command may be included.
Discussion on constituency for the work: is this something that people really want to deploy? Who is the customer for this? 
Vidya argued we cannot make a decision based on what existing companies do or not. It's worth asking how many people is going to spend cycles on it. Business models is not the job of the ietf
Syntax: The problem is still not clear and there are already some syntax proposals. It's just to evaluate whether we could reuse existing protocols or not.
Yunfei said that China Mobile was doing the prototype with several solutions, like meshed based and DHT based.
Gonzalo reminded that slides 7 suggested that CDN and cache vendors may also use this.
Vijay reported to the meeting that a jabber message said that he had asked with many Chinese p2p streaming vendors and these vendors said they were developing mobile P2P streaming products.
Lars suggested that it may be better that even the claim of using open P2P streaming protocols from a small streaming vendor, who may not as big as PPLive and PPStream was convincing to show the deployment condition.
Yunfei added that there would be certainly solution drafts in next IETF meeting to show this and more solution drafts were welcome to contribute.
Scope: both peer-tracker and peer-peer communications are in PPSP scope
 
Chunk Discovery for P2P Streaming – Ning Zong
Is this a use case for P2PSIP Reload? Not clear
We need terminology for P2P streaming
There are different interpretations of what is the problem to be solved
Some background on how live streaming works would be beneficial
What the querying peer needs is a list of good peers (not all peers)
Ning Zong said peer selection could be done with enhanced information in Tracker.
Ning Zong said some issues were implementations, not the scope of new protocols we want to develop in PPSP.
 
Protocol Analysis of PPLive, PPStream and UUSEee by Internet Measurements  – Yunfei Zhang
It was agreed to steer the group towards having discussion instead of going thru the last presentation.
 
Discussion: see if we can charter a WG by Hiroshima – all
Some of this work may not fall in p2psip
It may well be that this is an example where we run a BoF and the outcome is re-chartering an existing WG instead of creating a new one. Lack of agreement.
If this is coming from someone who has an existing large-scale implementation that they want to bring to IETF, then we start with that.
If we have a protocol we can extend to make work, we will do so.If not, then we will develop a new protocol for ppsp.
Discussions on clarifying the intent of this work and not make it too broad -- keep it p2p streaming instead of p2p content delivery of static content

Conclusions:
Incentives and motivations (who are going to implement and deploy it) need to be worked out.
The scope needs to be elaborated: build a generic mechanism to build swarms that could be used for things like streaming and file transfer, to build a system that supports video streaming, to build a system that supports live streaming, or combinations of these.
Terminology and concept of P2P streaming.
Proceed with an official BOF at the next IETF (Japan).

zhangyunfei
2009-08-05

---

From: "Y.J. Gu" <[email-masked]>
Date: Fri, 07 Aug 2009 09:25:28 +0800

First of all, I want to voice my support.
I find that the discussion about motivation of PPSP is very alike in IETF 74
and 75. 
It's not easy to convince existing P2P streaming applications to use PPSP,
but for those who's gona repeat the development circle and is lack of
economic support and human resource, PPSP is helpful. PPSP is also helpful
for those P2P application providers who pay more attention on
quality&quantity of content, e.g. who exceeds by unique content, than on
developing proprietary protocol. 
 
Yunfei, I notice that you use protocol over HTTP in registration and report
in page 14 of the slide, don't you think HTTP will overburden the peers,
'cause peers have to publish and report frequently. 

Regards

Yingjie Gu

---

From: Ning Zong <[email-masked]>
Date: Fri, 07 Aug 2009 11:22:19 +0800

>>HTTP will overburden the peers, 'cause peers have to publish and report
frequently. 

[Ning Zong]:  It depends on which information is to be reported to the
Tracker. If only “coarse information” such as the video name (rather than
chunk names), access type, terminal capability not changing over time, HTTP
is still a good choice.

  _____  

发件人: [email-masked] [mailto:[email-masked]] 代表 Y.J. Gu
发送时间: 2009年8月7日 9:25
收件人: 'zhangyunfei'; [email-masked]
主题: Re: [ppsp] minutes of PPSP final Bar BOF

 

Regards

Yingjie Gu

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 7 Aug 2009 14:09:18 +0800

Hi,Yingjie,
   Thanks for your interest and comments on PPSP.Please see inline reply.

       Best regards!
            Sincerely yours,
                      Yunfei 
       2009-08-07
*****************************************************

Yunfei Zhang, Ph.D.

R&D, CHINA MOBILE COMMUNICATIONS CORPORATION

Tel: +86 10 158016966688 ext. 3247

Fax: +86 10 63601087

MOBILE: 1360-1032-119

*****************************************************

zhangyunfei
2009-08-07

发件人： Y.J. Gu
发送时间： 2009-08-07 09:26:23
收件人： 'zhangyunfei'; [email-masked]
抄送： 
主题： RE: [ppsp] minutes of PPSP final Bar BOF

First of all, I want to voice my support.
I find that the discussion about motivation of PPSP is very alike in IETF 74 and 75. 
We need to consolidate the motivation of PPSP all the time before setting up the WG.So welcome to contribute to discuss more on the motivation.
It's not easy to convince existing P2P streaming applications to use PPSP, but for those who's gona repeat the development circle and is lack of economic support and human resource, PPSP is helpful. PPSP is also helpful for those P2P application providers who pay more attention on quality&quantity of content, e.g. who exceeds by unique content, than on developing proprietary protocol. 
Actually the design of PPSP is compatible with existing P2P streaming applications.You may notice that in page 8, there is a converter from existing P2P streaming applications in fixed Internet, say,pplive to PPSP. So one of the target of PPSP is to let exisiting proprietary protocols co-work with PPSP. In new envrinments like mobile Internet or converged mobile and fixed envirnment, PPSP can act as a unified protocol, while we don't exclude the usage of proprietary protocols in its own domain.
I think your point is right on the feasibility of PPSP.We also notice that now the main competition among different streaming vendors is the content itself.

Yunfei, I notice that you use protocol over HTTP in registration and report in page 14 of the slide, don't you think HTTP will overburden the peers, 'cause peers have to publish and report frequently. 
You can refer to Ning Zong's reply.

Regards
Yingjie Gu