Subject: Re: [ppsp] Review: draft-ietf-pp2p-problem-statement-01 / Security

From: "zhangyunfei" <[email-masked]>
Date: Mon, 7 Mar 2011 19:46:55 +0800

Hi Christian,
   The only thing I am not sure is the sentence"  The related information can be received from the tracker via the tracker protocol". The checksume info is often self-contained in the description files in P2P file sharing case, like the .torrent file in Bittorent rather than received from the tracker. Although P2P streaming has a different condition and maybe different technique to deal with this, I am not sure if the tracker can deal with it. Would you please say more details on this?Thanks.

BR
Yunfei

zhangyunfei
2011-03-07

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-03-07 18:34:58
收件人： ext zhangyunfei; [email-masked]
抄送： 
主题： Review: draft-ietf-pp2p-problem-statement-01 / Security

Hi Yunfei,
 
an additional proposal for the peer protocol security issues.
 
Current text:
 
   Similar to the behaviour in the tracker-peer interaction, malicious
   peers may also create fake information on chunk availability and
   exchange it with other peers. Some techniques to check the data
   integrity (e.g., using checksum) may be useful for detecting the data.
   But this part is out of scope of PPSP.
 
Proposed new text:   
 
   Similar to the behaviour in the tracker-peer interaction, malicious
   peers may also create fake information on chunk availability and
   exchange it with other peers. 
 
   Malicious peers can also modify stream contents. Some techniques 
   are available and useful to check the data integrity (e.g., using checksum).
   The related information can be received from the tracker via the tracker protocol.
   The selection of a certain mechanism for this purpose is out of scope for PPSP.

What do you think about this?
BR
Christian

zhangyunfei
2011-03-07

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 7 Mar 2011 12:58:36 +0100

Hi Yunfei,

the tracker could get this checksum information from the content provider direct.

In case of usage of the checksum in the description files.

How secure is this method? Would it be possible for a malicious peer to manipulate this information as well?

BR

Christian

From: ext zhangyunfei [mailto:[email-masked]] 
Sent: Monday, March 07, 2011 12:47 PM
To: Schmidt, Christian 1. (NSN - DE/Munich); [email-masked]
Subject: Re:Review: draft-ietf-pp2p-problem-statement-01 / Security

Hi Christian,

 

BR

Yunfei

________________________________

zhangyunfei

2011-03-07

________________________________

抄送： 

 

Hi Yunfei,

Current text:

Proposed new text:   

   

BR

Christian

________________________________

zhangyunfei

2011-03-07

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 7 Mar 2011 15:17:10 +0100

Hi Lingli,

that would mean, that the content´s checksum is provided to the peers in an encrypted mode. The peers get information to decrypt this information, but they have no possibility to modify and encrypt the message again.

I think this could work.

BR

Christian

From: ext 邓灵莉/denglingli [mailto:[email-masked]] 
Sent: Monday, March 07, 2011 2:38 PM
To: Schmidt, Christian 1. (NSN - DE/Munich); ext zhangyunfei; [email-masked]
Subject: Re: [ppsp] Review: draft-ietf-pp2p-problem-statement-01 / Security

Hi Christian,

I wonder if your problem can be solved by incorporating an enrollment service into the network, which authorizes identity certificates for the content providers, including maybe the providing peer's id, its public key signed by the issuer's private key (which can be verified by its well-known public key). The provider can then sign each content's checksum and pack this info along with the media content and distribute them to the network in a peer-to-peer fashion. 

In such setting, the tracker needs to store the corresponent provider's identity certificate and provide it to the downloading peer when the latter queries the content's location, and needs not to be bothered when the authentic provider updates the shared content (which maybe a normality in live streaming applications). Another advantage of this setting would be that in case of VoD scenarios, if the original content provider leaves the network, the scheme would also work, since it leaves enough info behind.

It would be convenient for the tracker responsible for the provider's id, or the one responsible for the shared content's hash value, to issue the correspondent certificate and provide it as required by a downloading peer.

What do you think?

BR

Lingli Deng

----- Original Message ----- 

	From: Schmidt, Christian 1. (NSN - DE/Munich) <mailto:[email-masked]>  

	To: ext zhangyunfei <mailto:[email-masked]>  ; [email-masked] 

	Sent: Monday, March 07, 2011 7:58 PM

	Subject: Re: [ppsp] Review: draft-ietf-pp2p-problem-statement-01 / Security

	Hi Yunfei,

	BR

	Christian

	Hi Christian,

	 

	BR

	Yunfei

	zhangyunfei

	2011-03-07

	抄送： 

	 

	Hi Yunfei,

	Current text:

	Proposed new text:   

	   

	BR

	Christian

	zhangyunfei

	2011-03-07

	__________ Information from ESET NOD32 Antivirus, version of virus signature database 5924 (20110303) __________
	
	The message was checked by ESET NOD32 Antivirus.
	
	http://www.eset.com

	_______________________________________________
	ppsp mailing list
	[email-masked]
	https://www.ietf.org/mailman/listinfo/ppsp

	__________ Information from ESET NOD32 Antivirus, version of virus signature database 5924 (20110303) __________
	
	The message was checked by ESET NOD32 Antivirus.
	
	http://www.eset.com

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 8 Mar 2011 09:57:41 +0800

Hi Chrisitian and Lingli,
   According to your discussion, seems it means that the tracker protocol can do the job on preventing the cheating. If there is consensus on this point, I would add what Christian proposed in the PS draft.

To David, Yingjie and Lingli,
   Is this one point to show we need peerID in the tracker protocol?Or we can just replace it by IP address?How do you think of this?

BR
Yunfei

zhangyunfei
2011-03-08

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-03-07 22:17:31
收件人： ext 邓灵莉/denglingli; ext zhangyunfei; [email-masked]
抄送： 
主题： RE: [ppsp] Review: draft-ietf-pp2p-problem-statement-01 / Security

Hi Lingli,
 
that would mean, that the content′s checksum is provided to the peers in an encrypted mode. The peers get information to decrypt this information, but they have no possibility to modify and encrypt the message again.
I think this could work.
 
BR
Christian

 
Hi Christian,

 
 
What do you think?
 
BR
Lingli Deng
 
----- Original Message ----- 
From: Schmidt, Christian 1. (NSN - DE/Munich) 
To: ext zhangyunfei ; [email-masked] 
Sent: Monday, March 07, 2011 7:58 PM
Subject: Re: [ppsp] Review: draft-ietf-pp2p-problem-statement-01 / Security
 
Hi Yunfei,

BR
Christian

 
Hi Christian,

BR
Yunfei

zhangyunfei
2011-03-07

Hi Yunfei,

Current text:

Proposed new text:   

zhangyunfei
2011-03-07

http://www.eset.com

http://www.eset.com