Subject: Re: [ppsp] Adding the security requirement for data intergrity check in the PPSPrequirement draft

From: Ning Zong <[email-masked]>
Date: Tue, 29 Mar 2011 10:48:00 +0200

Hi，all,

I agree this data integrity check is important. Just want to hear more opinion on whether to put each kind of secury check as separated requirement item?
Thanks.

BR,
Ning Zong

Hi all,
    As has added in the new version of problem statement on the security treat from the malicious peer to report fake information, shall we add the security requirement for data integrity check in the PPSP requirement draft?
    I notice that the current requirment draft has mentioned the requirement to detect the malicious peers, but regarding data integrity check, current draft doesn't include the requirement.

BR
Yunfei

zhangyunfei
2011-03-29

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 30 Mar 2011 10:01:33 +0200

Hi, 

do not put each kind of security check as separated requirement item, only the important ones. The possibility to protect users from fake content is important for this service and should be added as separate requirement.

BR

Christian

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Ning Zong
Sent: Tuesday, March 29, 2011 10:48 AM
To: zhangyunfei; [email-masked]
Cc: Carl Williams
Subject: Re: [ppsp] Adding the security requirement for data intergrity check in the PPSPrequirement draft

Hi，all,

Thanks.

BR,

Ning Zong

________________________________

Hi all,

BR

Yunfei

________________________________

zhangyunfei

2011-03-29

________________________________

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 30 Mar 2011 10:23:19 +0200

Hi Lingli Deng, Yunfei and Ning Zong,

I like your proposal. Perhaps one minor think, what do you mean with

in case of distrustful tracker/peer distribution

Am I right, that you do not mean, that the distribution is distrustful, but the tracker or one or more peers? What about

in case of distrustful tracker/peers

BR

Christian

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext ???/denglingli
Sent: Wednesday, March 30, 2011 3:55 AM
To: 'Ning Zong'; 'zhangyunfei'; [email-masked]
Cc: 'Carl Williams'
Subject: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for data intergrity check in the PPSPrequirement draft

Hi Yunfei, Ning Zong and Christian

I agree with Christian’s initial proposal for the peer protocol security issues to 

address the integrity check requirement as follows: (with minor modification 

according to some later discussion)

Current text:

   Similar to the behaviour in the tracker-peer interaction, malicious

   peers may also create fake information on chunk availability and

   exchange it with other peers. Some techniques to check the data

   integrity (e.g., using checksum) may be useful for detecting the data.

   But this part is out of scope of PPSP.

Proposed new text:   

   Similar to the behaviour in the tracker-peer interaction, malicious

   peers may also create fake information on chunk availability and

   exchange it with other peers. 

   Malicious peers can also modify stream contents. Some techniques 

   are available and useful to check the data integrity (e.g., using checksum).

   The related information can be received from the tracker/peer via the 

tracker/peer protocol.   Additional mechanism will be needed to ensure the

authenticity of the checksum information in case of distrustful tracker/peer 

distribution. The selection of a certain mechanism for this purpose is out of 

scope for PPSP.

BR

Lingli Deng

发件人: [email-masked] [mailto:[email-masked]] 代表 Ning Zong
发送时间: 2011年3月29日 16:48
收件人: zhangyunfei; [email-masked]
抄送: Carl Williams
主题: Re: [ppsp] Adding the security requirement for data intergrity check in the PPSPrequirement draft

Hi，all,

Thanks.

BR,

Ning Zong

Hi all,

BR

Yunfei

zhangyunfei

2011-03-29

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 30 Mar 2011 12:08:42 +0200

As discussed in the IETF80/PPSP I would like to start the need to
include QoS related requirements to the requirement spec.

The quality for P2P Live Streaming could be very bad. Dependent from the
number of peers in the chains between content provider and displaying
peer, the network conditions (quality and load) and the performance of
the involved entities, especially end-to-end delay could be horrible.
End to end delay of 2 minutes will be not accepted e.g. for sport games
and setup or channel switching times of 2 minutes is horrible as well.
Especially if you take into account that this service will compete with
server/client based streaming solutions.

There are several solutions possible, e.g. addition of super peers,
network internal storage and the usage of QoS information for an
advanced peer selection. This could be for example, the max length of a
chunk between source and peer or some information about the performance
capacity of the last peer. This information would have to be transported
via Tracker/Peer Protocol. The tracker protocol must provide the
possibility for the request of alternative peer addresses, if the
quality is not sufficient for the user. 

Therefore I recommend the introduction of 2 basic QoS requirements.

QoS.REQ-1: 

Setup time to receive a new streaming channel or to switch between
channels should be reasonable small. This time mainly depends on the
End-to-End delay and the size of the receiving buffer. 

QoS.REQ-2: 

End to end delay (time between content generation, e.g. camera and
content consumption, e.g. user side monitor) will become critical in
case of live streaming. Especially In provisioning of sports events, end
to end delay of 1 minute and more are not acceptable. 

What do you think about?

Christian

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 31 Mar 2011 03:05:46 +0800

Hi Christian and all,
    My impression on the QoS related requirements is that we need propose the requirement that how the peer and tracker protocol should do regarding QoS issue. The solutions you proposed actually include some of such requirements.
    So my suggestion is:
Will it be more suitable to express the requirements in the following means:
 e.g.,The peer may include QoS request info in the tracker protocol, like the video quality and maximum delay requirements to help the tracker return suitable peerlist.(This is just an example, not the exact requirement item).
   
BR
Yunfei

zhangyunfei
2011-03-31

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-03-30 18:08:49
收件人： ext Martin Stiemerling; zhangyunfei; [email-masked]
抄送： 
主题： QoS for PPSP

As discussed in the IETF80/PPSP I would like to start the need to include QoS related requirements to the requirement spec.
 
The quality for P2P Live Streaming could be very bad. Dependent from the number of peers in the chains between content provider and displaying peer, the network conditions (quality and load) and the performance of the involved entities, especially end-to-end delay could be horrible. End to end delay of 2 minutes will be not accepted e.g. for sport games and setup or channel switching times of 2 minutes is horrible as well. Especially if you take into account that this service will compete with server/client based streaming solutions.
 
There are several solutions possible, e.g. addition of super peers, network internal storage and the usage of QoS information for an advanced peer selection. This could be for example, the max length of a chunk between source and peer or some information about the performance capacity of the last peer. This information would have to be transported via Tracker/Peer Protocol. The tracker protocol must provide the possibility for the request of alternative peer addresses, if the quality is not sufficient for the user. 

QoS.REQ-1: 
Setup time to receive a new streaming channel or to switch between channels should be reasonable small. This time mainly depends on the End-to-End delay and the size of the receiving buffer. 
  
QoS.REQ-2: 
End to end delay (time between content generation, e.g. camera and content consumption, e.g. user side monitor) will become critical in case of live streaming. Especially In provisioning of sports events, end to end delay of 1 minute and more are not acceptable. 
 
What do you think about?
Christian

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 31 Mar 2011 03:20:16 +0800

I agree with Christian on the principle of the requirment addition. What we need is a general requirement on fake content detection and prevention.

Yunfei

zhangyunfei
2011-03-31

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-03-30 16:01:43
收件人： ext Ning Zong; zhangyunfei; [email-masked]
抄送： Carl Williams
主题： RE: [ppsp] Adding the security requirement for data intergrity check in the PPSPrequire

Hi, 
 
BR
Christian

Hi，all,

BR,
Ni! ng Zong< o:p>

Hi all,
! 
 
BR
Yunfei

zhangyunfei
2011-03-29

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 31 Mar 2011 03:23:27 +0800

Hi Lingli,
    I think it would be more suitable to add some words in the requirement draft rather than in the PS draft because we are missing one requirement item in the former draft. In the PS draft,what we need is a general discription on the problem rather than the requirements.
    Thanks.

BR
Yunfei

zhangyunfei
2011-03-31

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-03-30 16:23:30
收件人： ext 邓灵莉/denglingli; Ning Zong; zhangyunfei; [email-masked]
抄送： Carl Williams
主题： RE: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri

 
BR
Christian

 
 
Current text:

Proposed new text:   

 
BR
Lingli Deng

Hi，all,

BR,
Ning Zong

Hi all,
 
BR
Yunfei

zhangyunfei
2011-03-29

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 31 Mar 2011 03:38:36 +0800

Hi all,
   I happen to see Q4S work in DISPATCH:http://www.ietf.org/proceedings/80/slides/dispatch-2.pdf.It's on application-level QoS abstraction. Maybe useful of discusion of QoS issue in PPSP. 

BR
Yunfei

zhangyunfei
2011-03-31

发件人： zhangyunfei
发送时间： 2011-03-31 03:06:12
收件人： Schmidt, Christian 1. (NSN - DE/; ext Martin Stiemerling; [email-masked]
抄送： 
主题： Re: [ppsp] QoS for PPSP

Hi Christian and all,
   
BR
Yunfei

zhangyunfei
2011-03-31

 

 
QoS.REQ-1: 
  
QoS.REQ-2: 
 
What do you think about?
Christian