Subject: [ppsp] Re: 答复: Re: RE: ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri

From: Ning Zong <[email-masked]>
Date: Thu, 31 Mar 2011 09:09:09 +0200

Hi, Lingli,

Thank you for the contribution.
I think the first sentence is fair. But the second sentence is not requirement to PPSP protocol, but requirement to chechsum distribution mechanism, which is not part of PPSP, I suppose?

BR,
Ning Zong

Hi, Ning Zong, Yunfei and Christian
 
What about adding the following item to the requirement draft?
 
PPSP.SEC.REQ-X: Integrity of the streaming content in PPSP MUST be supported to identify inauthentic media content (undesirable modified by other entities rather than its genuine source) and exclude it from the P2P streaming system. The corresponding checksum distribution and verification scheme SHOULD scale well in P2P streaming system and be robust against distrustful trackers/peers. 
 
BR
Lingli
 
发件人: Ning Zong [mailto:[email-masked]] 
发送时间: 2011年3月31日 5:22
收件人: zhangyunfei; Schmidt, Christian 1. (NSN - DE/; ext 邓灵莉/denglingli; [email-masked]
抄送: Carl Williams
主题: Re: Re: RE: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri
 
I will do it later.

Hi Lingli,
    I think it would be more suitable to add some words in the requirement draft rather than in the PS draft because we are missing one requirement item in the former draft. In the PS draft,what we need is a general discription on the problem rather than the requirements.
    Thanks.
 
BR
Yunfei

zhangyunfei
2011-03-31

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-03-30 16:23:30
收件人： ext 邓灵莉/denglingli; Ning Zong; zhangyunfei; [email-masked]
抄送： Carl Williams
主题： RE: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri
 
Hi Lingli Deng, Yunfei and Ning Zong,
I like your proposal. Perhaps one minor think, what do you mean with
in case of distrustful tracker/peer distribution
 
Am I right, that you do not mean, that the distribution is distrustful, but the tracker or one or more peers? What about
in case of distrustful tracker/peers
 
BR
Christian

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext ???/denglingli
Sent: Wednesday, March 30, 2011 3:55 AM
To: 'Ning Zong'; 'zhangyunfei'; [email-masked]
Cc: 'Carl Williams'
Subject: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for data intergrity check in the PPSPrequirement draft
 
Hi Yunfei, Ning Zong and Christian
 
I agree with Christian’s initial proposal for the peer protocol security issues to 
address the integrity check requirement as follows: (with minor modification 
according to some later discussion)
 
Current text:
 
   Similar to the behaviour in the tracker-peer interaction, malicious
   peers may also create fake information on chunk availability and
   exchange it with other peers. Some techniques to check the data
   integrity (e.g., using checksum) may be useful for detecting the data.
   But this part is out of scope of PPSP.
 
Proposed new text:   
 
   Similar to the behaviour in the tracker-peer interaction, malicious
   peers may also create fake information on chunk availability and
   exchange it with other peers. 
 
   Malicious peers can also modify stream contents. Some techniques 
   are available and useful to check the data integrity (e.g., using checksum).
   The related information can be received from the tracker/peer via the 
tracker/peer protocol.   Additional mechanism will be needed to ensure the
authenticity of the checksum information in case of distrustful tracker/peer 
distribution. The selection of a certain mechanism for this purpose is out of 
scope for PPSP.
 
BR
Lingli Deng
 
发件人: [email-masked] [mailto:[email-masked]] 代表 Ning Zong
发送时间: 2011年3月29日 16:48
收件人: zhangyunfei; [email-masked]
抄送: Carl Williams
主题: Re: [ppsp] Adding the security requirement for data intergrity check in the PPSPrequirement draft
 
Hi，all,
 
I agree this data integrity check is important. Just want to hear more opinion on whether to put each kind of secury check as separated requirement item?
Thanks.
 
BR,
Ning Zong

Hi all,
    As has added in the new version of problem statement on the security treat from the malicious peer to report fake information, shall we add the security requirement for data integrity check in the PPSP requirement draft?
    I notice that the current requirment draft has mentioned the requirement to detect the malicious peers, but regarding data integrity check, current draft doesn't include the requirement.
 
BR
Yunfei

zhangyunfei
2011-03-29

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 31 Mar 2011 09:31:14 +0200

Hi Lingli,

what do you mean with “exclude it from the P2P streaming system” and how do you want to achieve this? If for example source information are exchanged directly between peers, how do you want to enforce this?

And I have no problem with the second sentence. Dependent from the solution, this could be a requirement for tracker/peer protocol as well.

Br/Christian

From: ext Ning Zong [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 9:09 AM
To: 邓灵莉/denglingli; 'zhangyunfei'; Schmidt, Christian 1. (NSN - DE/Munich); [email-masked]
Cc: 'Carl Williams'
Subject: Re: 答复: Re: RE: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri

Hi, Lingli,

BR,

Ning Zong

________________________________

BR

Lingli

I will do it later.

________________________________

Hi Lingli,

    Thanks.

BR

Yunfei

________________________________

zhangyunfei

2011-03-31

________________________________

抄送： Carl Williams

BR

Christian

Current text:

Proposed new text:   

scope for PPSP.

BR

Lingli Deng

Hi，all,

Thanks.

BR,

Ning Zong

________________________________

Hi all,

BR

Yunfei

________________________________

zhangyunfei

2011-03-29

________________________________

________________________________

________________________________

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 31 Mar 2011 10:39:53 +0200

Hi Lingli,

what about the following proposal:

PPSP.SEC.REQ-X: Integrity of the streaming content in PPSP MUST be supported to provide a peer with the possibility to identify inauthentic media content (undesirable modified by other entities rather than its genuine source) and report this towards the tracker to exclude the related source from the P2P streaming system. The corresponding checksum distribution and verification scheme SHOULD scale well in P2P streaming system and be robust against distrustful trackers/peers. 

/Christian

From: ext 邓灵莉/denglingli [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 10:26 AM
To: Schmidt, Christian 1. (NSN - DE/Munich); 'ext Ning Zong'; 'zhangyunfei'; [email-masked]
Cc: 'Carl Williams'
Subject: 答复: Re: 答复: Re: RE: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri

Hi Christian and Ning Zong

To me,  it seems that tracker’s involvement would be necessary to achieve this exclusion.

If a deceived peer accuses another peer for providing inauthentic content provision, the tracker may exclude the latter from the correspondent peer list accordingly.

But would this mean we need also to protect honest uploading peers from false blames?

I have not come up with any solution yet.

About the second sentence, I have the same comment with Christian.

BR,

LIngli

发件人: Schmidt, Christian 1. (NSN - DE/Munich) [mailto:[email-masked]] 
发送时间: 2011年3月31日 15:31
收件人: ext Ning Zong; 邓灵莉/denglingli; zhangyunfei; [email-masked]
抄送: Carl Williams
主题: RE: Re: 答复: Re: RE: [ppsp] ***SPAM*** 8.537 (5) 答复: Adding the security requirement for dataintergri

Hi Lingli,

Br/Christian

Hi, Lingli,

BR,

Ning Zong

BR

Lingli

I will do it later.

Hi Lingli,

    Thanks.

BR

Yunfei

zhangyunfei

2011-03-31

抄送： Carl Williams

BR

Christian

Current text:

Proposed new text:   

scope for PPSP.

BR

Lingli Deng

Hi，all,

Thanks.

BR,

Ning Zong

Hi all,

BR

Yunfei

zhangyunfei

2011-03-29

__________ Information from ESET NOD32 Antivirus, version of virus signature database 5999 (20110330) __________

The message was checked by ESET NOD32 Antivirus.

http://www.eset.com

---

From: Riccardo Bernardini <[email-masked]>
Date: Thu, 31 Mar 2011 10:43:50 +0200

Quoting ???/denglingli <[email-masked]>:

> To me,  it seems that tracker?s involvement would be necessary to achieve
> this exclusion.
>
> If a deceived peer accuses another peer for providing inauthentic content
> provision, the tracker may exclude the latter from the correspondent peer
> list accordingly.
>
>
>

Yes, I think that peers must be protected against this kind of  
"defamatory attack." It would be too simple to mount.

> I have not come up with any solution yet.

Just off the top of my head (writing while thinking),  one could  
require that at least a minimum number of "denounces" must be  
received.  This would require a coordination  among several attackers.  
  If the tracker can have an estimate of how many peers the "accused"  
peer has served, it could use a relative threshold (e.g., at least 50%  
of the served peers must denounce the accused one).

Alternatively, one could ask each peer to sign every transmitted  
chunk.  This will allow the denouncer to use the signed chunk as  
"evidence".

Still writing while thinking, we should also consider the case where a  
peer propagate bad content in "good faith".  If the signature solution  
is employed, the peer could send the chunk together with a chain of  
past signatures. This would protect the peer from the accusation of  
distributing bad content since it would prove that the peer did not  
generate the content, but received it from someone else.  However, we  
must pay attention that the chain signature does not get too long.   
(If I remember correctly, there is a technique that allows to create  
signature chains that can be shortned).

> ???: Schmidt, Christian 1. (NSN - DE/Munich)
> [mailto:[email-masked]]
> ????: 2011?3?31? 15:31
> ???: ext Ning Zong; ???/denglingli; zhangyunfei; [email-masked]
> ??: Carl Williams
> ??: RE: Re: ??: Re: RE: [ppsp] ***SPAM*** 8.537 (5) ??: Adding the
> security requirement for dataintergri
>
>
>
> Hi Lingli,
>
>
>
> what do you mean with ?exclude it from the P2P streaming system? and how
> do you want to achieve this? If for example source information are exchanged
> directly between peers, how do you want to enforce this?
>
> And I have no problem with the second sentence. Dependent from the solution,
> this could be a requirement for tracker/peer protocol as well.
>
>
>
> Br/Christian
>
>
>
>
>
> To: ???/denglingli; 'zhangyunfei'; Schmidt, Christian 1. (NSN -
> DE/Munich); [email-masked]
> Cc: 'Carl Williams'
> Subject: Re: ??: Re: RE: [ppsp] ***SPAM*** 8.537 (5) ??: Adding the
> security requirement for dataintergri
>
>
>
> Hi, Lingli,
>
>
>
> I think the first sentence is fair. But the second sentence is not
> requirement to PPSP protocol, but requirement to chechsum distribution
> mechanism, which is not part of PPSP, I suppose?
>
>
>
> BR,
>
> Ning Zong
>
>
>
>   _____
>
> PPSP.SEC.REQ-X: Integrity of the streaming content in PPSP MUST be supported
> to identify inauthentic media content (undesirable modified by other
> entities rather than its genuine source) and exclude it from the P2P
> streaming system. The corresponding checksum distribution and verification
> scheme SHOULD scale well in P2P streaming system and be robust against
> distrustful trackers/peers.
>
>
>
> BR
>
> Lingli
>
>
>
> ???: Ning Zong [mailto:[email-masked]]
> ????: 2011?3?31? 5:22
> ???: zhangyunfei; Schmidt, Christian 1. (NSN - DE/; ext ???
> /denglingli; [email-masked]
> ??: Carl Williams
> ??: Re: Re: RE: [ppsp] ***SPAM*** 8.537 (5) ??: Adding the security
> requirement for dataintergri
>
>
>
> I will do it later.
>
>
>
>   _____
>
> Hi Lingli,
>
>     I think it would be more suitable to add some words in the requirement
> draft rather than in the PS draft because we are missing one requirement
> item in the former draft. In the PS draft,what we need is a general
> discription on the problem rather than the requirements.
>
>     Thanks.
>
>
>
> BR
>
> Yunfei
>
>
>
>   _____
>
> zhangyunfei
>
> 2011-03-31
>
>   _____
>
> ???? Schmidt, Christian 1. (NSN - DE/Munich)
>
> ????? 2011-03-30 16:23:30
>
> ???? ext ???/denglingli; Ning Zong; zhangyunfei; [email-masked]
>
> ??? Carl Williams
>
> ??? RE: [ppsp] ***SPAM*** 8.537 (5) ??: Adding the security requirement
> for dataintergri
>
>
>
> Am I right, that you do not mean, that the distribution is distrustful, but
> the tracker or one or more peers? What about
>
> Subject: [ppsp] ***SPAM*** 8.537 (5) ??: Adding the security requirement
> for data intergrity check in the PPSPrequirement draft
>
>
>
> I agree with Christian?s initial proposal for the peer protocol security
> issues to
>
> ???: [email-masked] [mailto:[email-masked]] ?? Ning Zong
> ????: 2011?3?29? 16:48
> ???: zhangyunfei; [email-masked]
> ??: Carl Williams
> ??: Re: [ppsp] Adding the security requirement for data intergrity check
> in the PPSPrequirement draft
>
>
>
> Hi?all,
>
>
>
> I agree this data integrity check is important. Just want to hear more
> opinion on whether to put each kind of secury check as separated requirement
> item?
>
> Thanks.
>
>
>
> BR,
>
> Ning Zong
>
>
>
>   _____
>
> Hi all,
>
>     As has added in the new version of problem statement on the security
> treat from the malicious peer to report fake information, shall we add the
> security requirement for data integrity check in the PPSP requirement draft?
>
>     I notice that the current requirment draft has mentioned the requirement
> to detect the malicious peers, but regarding data integrity check, current
> draft doesn't include the requirement.
>
>
>
> BR
>
> Yunfei
>
>
>
>   _____
>
> zhangyunfei
>
> 2011-03-29
>
>   _____
>
>   _____
>
>   _____
>
>
>

-- 
Riccardo Bernardini
DIEGM -- University of Udine
via delle Scienze 208
33100 Udine
Tel: +39-0432-55-8271
Fax: +39-0432-55-8251

----------------------------------------------------------------------
SEMEL (SErvizio di Messaging ELettronico) - CSIT -Universita' di Udine

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 31 Mar 2011 18:42:01 +0800

Hi Riccardo,
   Following your idea, I just go on to think this problem.Please see inline.

Yunfei

zhangyunfei
2011-03-31

发件人： Riccardo Bernardini
发送时间： 2011-03-31 16:44:04
收件人： [email-masked]
抄送： 
主题： Re: [ppsp] ***SPAM*** 7.814 (5) ??: Re: ??: Re: RE:***SPAM*** 8.537 (5) ??: Adding the security requirement

[Yunfei]
Alternatively,  one  could  ask  each  peer  to  sign  every  transmitted    
chunk.    This  will  allow  the  denouncer  to  use  the  signed  chunk  as    
"evidence".
[Yunfei]It would be complex to check the evidence and make the efficiency a problem, i.e., 
I have thought using P2P transfer for a ten times quicker download but find the checking costs me 
most of the time. In this sense simple majority is a good way to identify the "denounce"message is 
a fact or not.I prefer your fist proposal.

[Yunfei] Yes, I think this is a problem.But should we consider this case from the beginning of the design?Is
it a small probability event or a common thing for normal peers?

_______________________________________________
ppsp  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp