Subject: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txt starting today until August 15th

From: Martin Stiemerling <[email-masked]>
Date: Mon, 1 Aug 2011 13:26:08 +0000

Dear all,

We start a 2 weeks Working Group Last Call (WGLC) for draft-ietf-ppsp-problem-statement-02.txt, as agreed during the PPSP session at the IETF#81 meeting.

Please review the draft and send your comments to the PPSP list. Any type of review is appreciated, even it is saying only "I have read the draft and it is ok". 
However, a thorough review is required by a number of PPSP WG members (which is YOU!). 

The WGLC starts right now and will end August 14th, 6pm PDT.

The draft is accessible in text, pdf, or html from this URL
http://tools.ietf.org/html/draft-ietf-ppsp-problem-statement-02

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 3 Aug 2011 17:43:21 -0400

Hi,

I reviewed the PPSP problem statement and have the following comments:

Technical Comments:
===================

1) To be more balanced, the Intro (section 1, paragraph 2) should also
point out that P2P approach requires more resources and computational
power on the client (when compared to Client-Server architecture), as
well as a lot of clients to participate in the P2P network for the
network to be efficient.

2) In the Intro (Section 1, paragraph 3), it referred to CDN vendors
that are starting to use P2P technologies.  I then tried to find some
more information about this trend on the first reference (Akamai).  I
found the following article
http://gigaom.com/video/whatever-happened-to-red-swoosh/.  In this
article they concluded that Akamai was in fact NOT following the P2P
model (as they have discontinued their Red Swoosh P2P approach).  So my
question to the authors is whether they are sure that this is still a
valid trend (i.e. of CDN vendors starting to use P2P technologies)?  If
you are sure that this trend is valid maybe you can put some more
(better) references for this.

3) In Section 3.1, I did not understand the following key phrases:
- "ISPs are witnessing a big traffic tension on their backbone and
inter-networking ports".  
- "the variation in different P2P streaming systems mainly lies in how
the chunks are scheduled to transfer rather than how the chunks
availability information is exchanged"

Can you please re-write them to be more clearer and explicit?

4) In Section 3.2:
- The title is not clear (e.g. "interactionies" is not a valid English
word)
- The first paragraph, seems to imply that CCN approach will use P2P.  I
have been reading CCN papers for a while and I never reached this
conclusion.  Can you explain how you drew this conclusion?

5) I understand and agree on the general problem identified in Section
3.4.  However the terminology of "daemon" seems particular to Unix, and
makes a lot of SW design assumptions.  Also, the focus on wireless
terminals seems to overlap with the problem identified in Section 3.3.

6) In Sections 3.1, 3.2, and 3.4 there should be a short concluding
paragraph as in section 3.3.

7) In Section 4, the 2nd paragraph was too long and needs to be broken
up to multiple paragraphs to make it readable.  Otherwise, I found the
rest of the section to be clear and a good definition for PPSP!

Editorial Comments:
====================

8) Section 1 (and elsewhere)
   The first paragraph reference to "[Cisco]" does not have a hyper-link
in the HTML view.  Probably because a space is missing between the
reference and the previous word.  The same problem occurs for numerous
other references throughout the document.

9) Section 2
   - The word "exchange" is spelled incorrectly in the definition of
"Swarm"
   - In the last sentence in the definition of "tracker" the word
"logic" should be changed to "logical"
   - The definition of "VoD" is not very clear and should be re-worded.
(In contrast, the "Live Streaming" definition was much clearer.)

/Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Martin Stiemerling
Sent: Monday, August 01, 2011 9:26 AM
To: [email-masked]
Subject: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txt
starting today until August 15th

Dear all,

We start a 2 weeks Working Group Last Call (WGLC) for
draft-ietf-ppsp-problem-statement-02.txt, as agreed during the PPSP
session at the IETF#81 meeting.

Please review the draft and send your comments to the PPSP list. Any
type of review is appreciated, even it is saying only "I have read the
draft and it is ok". 
However, a thorough review is required by a number of PPSP WG members
(which is YOU!). 

  Martin

NEC Laboratories Europe - Network Research Division NEC Europe Limited |
Registered Office: NEC House, 1 Victoria Road, London W3 6BL |
Registered in England 2832014 

_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 4 Aug 2011 10:54:46 +0800

Hi Akbar,
   Thanks for your careful review. Please see inline for the reply.

BR
Yunfei

zhangyunfei
2011-08-04

发件人： Rahman, Akbar
发送时间： 2011-08-04 05:43:32
收件人： Martin Stiemerling; [email-masked]
抄送： 
主题： Re: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txtstarting today until August 15th

Hi,

Technical  Comments:
===================

[Yunfei] Okay. I'll add this in the paragraph.

[Yunfei]Okay. I just talked with some CDN vendors that verifies this trend. But need some 
time to find published evidence.

[Yunfei] Can you clarify your questions on the first sentence?
Regarding the second sentence, the basic idea is that different P2P streaming
systems compete on scheduling algorithms, which is independent of how the peers exchange chunk availability. 
In other words, different systems can have quite different scheuling algorithms with same peer protocol.

4)  In  Section  3.2:
-  The  title  is  not  clear  (e.g.  "interactionies"  is  not  a  valid  English
word)
-  The  first  paragraph,  seems  to  imply  that  CCN  approach  will  use  P2P.    I
have  been  reading  CCN  papers  for  a  while  and  I  never  reached  this
conclusion.    Can  you  explain  how  you  drew  this  conclusion?
[Yunfei] Oops. It should be "interactions". 
Actually the reference of using CCN is not to say that 
CCN approach will use P2P, rather the logic is as follows:
CCN/DONA->content centric network trend->p2p streaming accounts a lot in centent based networks.
There is no direct relationship betwwen CCN and P2P streaming.If this is not clear in the text, I can simply delete
"CCN" in the description.

[Yunfei]I'll merge the two parts and replace the ambiguous terminology.

[Yunfei] Okay.

Editorial  Comments:
====================

[Yunfei]I'll check the whole reference for the hyper-link issue.
9)  Section  2
     -  The  word  "exchange"  is  spelled  incorrectly  in  the  definition  of
"Swarm"
     -  In  the  last  sentence  in  the  definition  of  "tracker"  the  word
"logic"  should  be  changed  to  "logical"
     -  The  definition  of  "VoD"  is  not  very  clear  and  should  be  re-worded.
(In  contrast,  the  "Live  Streaming"  definition  was  much  clearer.)
[Yunfei]I'll update the text.

/Akbar

-----Original  Message-----

Dear  all,

   Martin

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 4 Aug 2011 01:51:10 -0400

Hi Yunfei,

Thanks for your quick responses.  Please see inline for my extra input on the open issues (i.e. points 3 and 4).  Otherwise, I am okay with all your responses on all the other points.  Finally, I would like to say the authors did a good job on the document, and the quality of the document was good from my point of view.

Sincerely,

Akbar

From: zhangyunfei [mailto:[email-masked]] 
Sent: Wednesday, August 03, 2011 10:55 PM
To: Rahman, Akbar; Martin Stiemerling; [email-masked]
Subject: Re: Re: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txtstarting today until August 15th

Hi Akbar,

BR

Yunfei

________________________________

zhangyunfei

2011-08-04

________________________________

发件人： Rahman, Akbar

抄送： 

Hi,

Technical  Comments:

===================

network  to  be  efficient.

inter-networking  ports".    

 

*** Akbar: On the first point, I do not understand what “inter-networking ports” mean.  This is not a common term.

  On the second point, your explanation is good.  Perhaps you can re-word the original wording with the explanation you gave above.

4)  In  Section  3.2:

word)

 

 **** Akbar: Okay.  Then I recommend you delete CCN from the description as otherwise it is too confusing

 

 

[Yunfei] Okay.

Editorial  Comments:

====================

9)  Section  2

"Swarm"

 

/Akbar

-----Original  Message-----

Martin  Stiemerling

To:  [email-masked]

Dear  all,

draft  and  it  is  ok".  

(which  is  YOU!).  

   Martin

 

ppsp  mailing  list

[email-masked]

ppsp  mailing  list

[email-masked]

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 4 Aug 2011 16:19:34 +0800

Hi Akbar,
  Your suggestions are quite good.I'll refect these revisions in the updated version. Thanks.

BR
Yunfei

zhangyunfei
2011-08-04

发件人： Rahman, Akbar
发送时间： 2011-08-04 13:51:40
收件人： zhangyunfei
抄送： Martin Stiemerling; [email-masked]
主题： RE: Re: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txtstarting today until August 15th

Hi Yunfei,

Sincerely,

Akbar

Hi Akbar,
 
BR
Yunfei

zhangyunfei
2011-08-04

发件人： Rahman, Akbar
 
Hi,

Technical  Comments:
===================

 

 

4)  In  Section  3.2:

 

Editorial  Comments:
====================

 
/Akbar

-----Original  Message-----
 
Dear  all,

 

   Martin

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 4 Aug 2011 13:51:03 +0200

My review comments for Problem Statement Draft:

In the draft, you mentioned certain peers, e.g. mobile terminals, not
able of willing to provide content to other peers. For this purpose, it
would be good to introduce another term "client". 

5.2. CDN supporting P2P streaming
"Also it can talk with peers with HTTP if it has complete copy of the
requested file."
What is the purpose of this restriction? What do you mean with file?
Chunk?
And what is the difference to the peer protocol in this case? Can you
download chunk information, if there is no complete copy in case of
usage of peer protocol?
Proposal (deleting the second part):
"Also it can talk with peers with HTTP."

5.3 PPSP Supporting cross-screen streaming in heterogeneous environment
"With PPSP Peers can identify the types of networks, ...."
Change to:
"With PPSP Peers can identify the types of access networks, ...."

5.4 Supporting P2P streaming in cellular mobile network.
"In a provincial network of China Mobile, P2P has accounted for more
than 30 percentage of the traffic, ranked second except HTTP."
What do you mean with ranked second except HTTP? I thought, HTTP is used
for p2p traffic as well?

6.1 Tracker Protocol

Existing Text:

   "Malicious peers may issue denial of service attack to the trackers
by
   sending large amount of requests with tracker protocol. Distributed
   trackers deployment may alleviate the problem.

   On the other hand, malicious peers may report fake information (e.g.,
   cheating trackers and other peers by claiming itself owning some un-
   existing data).

   So it may be optional to realize authentication to the peers before
   accepting the request for the tracker. But this may add up the
   tracker's workload.

   In the above discussion tracker is trustful. Things are worse when
   the malicious peer acts as part of the distributed trackers. The
   malicious acting tracker may reply the peers with fake peer-list.
   Peers may find they cannot find desired data with the fake
peer-list."

Proposal for new text:

   "Malicious peers may issue denial of service attack to the trackers
by
   sending large amount of requests with tracker protocol. Distributed
   trackers deployment may alleviate the problem. For protection against

   denial of service attacks, standard security methods can be used.

   Malicious peers may report fake information on behalf of other peers.
   This can be avoided with peer authentication.

   Malicious peers may report fake information about available content.
   For this purpose, malicious peers can be reported to the tracker.

   Malicious tracker, especially distributed version, can be very
harmful.
   The malicious acting tracker may reply instead of the regular tracker

   (man in the middle attack). To avoid this tracker authentication
could
   Be used. The malicious acting tracker may reply the peers with fake
   peer-list. Peers may find they cannot find desired data with the fake
   peer-list."

6.2. Peer Protocol

Existing Text:

   "Similar to the behaviour in the tracker-peer interaction, malicious
   peers may also create fake information on chunk availability and
   exchange it with other peers. Some techniques to check the data
   integrity (e.g., using checksum) may be useful for detecting the
data."

Proposal for new text:

   "Similar to the behaviour in the tracker-peer interaction, malicious
   peers may also create fake information on chunk availability and
   exchange it with other peers. Some techniques to check the data
   integrity (e.g., using checksum) may be useful for detecting the
attack."

Best Regards
Christian Schmidt

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Martin Stiemerling
Sent: Monday, August 01, 2011 3:26 PM
To: [email-masked]
Subject: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txt
starting today until August 15th

Dear all,

  Martin

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 5 Aug 2011 10:03:25 +0800

Hi Christian,
    Thanks for the review. Please see inline for the reply.

BR
Yunfei

zhangyunfei
2011-08-05

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2011-08-04 19:51:22
收件人： ext Martin Stiemerling; zhangyunfei; [email-masked]
抄送： 
主题： RE: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txt starting today until Augus

[Yunfei] I am okay for the introduction.

[Yunfei] Just as I mentioned in the PPSP session, this part is newly included. This addition is to 
show how existing CDNs even without PPSP support can work in a PPSP environment using HTTP. Here we mainly refer
to complete VoD files. And it can also be live stream chunk. 
Peers can download chunk information when there is no complete copy of the file in another peer using peer protocol,which
is common in PPSP senarios.

5.3  PPSP  Supporting  cross-screen  streaming  in  heterogeneous  environment
"With  PPSP  Peers  can  identify  the  types  of  networks,  ...."
Change  to:
"With  PPSP  Peers  can  identify  the  types  of  access  networks,  ...."
[Yunfei]Fine to change it.

[Yunfei] Actually in our practical experince, the P2P traffic are mainly carried by UDP and TCP. Few are using HTTP.We may
clarify this in the text.

6.1  Tracker  Protocol

Existing  Text:

Proposal  for  new  text:

[Yunfei] Good!
6.2.  Peer  Protocol

Existing  Text:

Proposal  for  new  text:

[Yunfei] Fine.
Best  Regards
Christian  Schmidt

-----Original  Message-----

Dear  all,

   Martin

---

From: "Xiao, Lin (NSN - CN/Beijing)" <[email-masked]>
Date: Fri, 5 Aug 2011 17:35:10 +0800

Hi，

Review from my side.

1) In Section 1, the last sentence: 
".... or updating /integrating existing cache/CDN/routers to support P2P
streaming delivery."
IMHO, We normally mention router as a layer 3 device, which forward IP packets according to IP protocol and routing algorism. So, here, do you mean some content router works beyond layer 3 or you do mean to update the network layer router?  

2) in Section 2, the definition of swarm:
"Swarm: A swarm refers to a group of clients (i.e., peers) who exchang
   data to distribute the same content (e.g. video/audio program,
   digital file, etc) at a given time."
Firstly, you use the term "clients" may not be accurate. As it also may be cache server, right? Why not use the term peer directly?
Moreover, spelling error on "exchange"

3) in Section 2, the definition of tracker:
"Tracker: A tracker refers to a directory server which maintains a
   list of peers storing chunks for a specific channel or streaming file,
   and answers queries from peers for peer lists. The tracker is a logic
   component which can be centralized or distributed."
Here, I think, the queries to tracker can also from a pure client. So, modified text: "...., and answers queries from peers or clients for peer lists....."

4) In Section 3.2,
" However, there are substantial obstacles for CDN
   nodes supporting proprietary P2P streaming protocols [HTPT]. ..."
[HTPT] appears here, but in Reference section, it's [HPTP]. 

5) In Section 3.2 
" Note again that we just focus on the standard data availability
   information interaction between tracker (maybe hosted by the source
   provider) and CDN nodes, among CDN nodes "
should be: "........ CDN nodes, and among CDN nodes"

6) In Section 4, the last paragraph 
" What's more, existing protocols should be investigated and evaluated
   for being reused or extended as the proposed protocols, e.g., HTTP.
   Considering that there can be a large number of peers, the protocol
   should consider some lightweight (possibly binary) encoding."
Do you suggest the binary encoding here?
The HTTP was given as an example of current protocol that PPSP can reused or extend from (which is text-based), but the last sentence said PPSP SHOULD consider binary encoding, which is confusing.

7) Section 5.2
"Also  it  can  talk  with  peers  with  HTTP  ....."
Do you mean the client/server way between the user 3 and CDN Node3? If So, you'd better use "end users" to take place of "peers", as in this scenario it's not the peer of CDN node anymore.
As peer protocol may also be based on HTTP protocol, difference should be clarified between the Http-based peer protocol and traditional HTTP protocol.
How about: "Also it can talk with end users with traditional HTTP ...."

Best Regards,
Xiao Lin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Martin Stiemerling
Sent: Monday, August 01, 2011 9:26 PM
To: [email-masked]
Subject: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txt starting today until August 15th

Dear all,

  Martin

---

From: "zhangyunfei" <[email-masked]>
Date: Sat, 6 Aug 2011 10:00:13 +0800

Hi Lin,
   Thanks for your review. Please see inline for the reply.

BR
Yunfei

zhangyunfei
2011-08-05

发件人： Xiao, Lin (NSN - CN/Beijing)
发送时间： 2011-08-05 17:36:19
收件人： ext Martin Stiemerling; [email-masked]
抄送： 
主题： Re: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txtstarting today until August 15th

Hi，

Review  from  my  side.

[Yunfei] Here we mean network layer content router. However this is a long-term evolution in IP network. To avoid the ambiguity and too much explaination on the defocus , I'll delete "routers" in the text. 

[Yunfei]Thanks for the corrections.

[Yunfei] It involves introducing a new conception:client, which is not a direct counterpart of tracker in PPSP domain currently. Do we need to add this, just like that in P2PSIP? I would like to hear more suggestions on this.

4)  In  Section  3.2,

[Yunfei] Oops.
5)  In  Section  3.2  

[Yunfei] In last IETF meeting, there are hot discussion on the encoding issue. For tracker protocol, there is rough consensus in taking HTTP. Regarding peer protocol Johan and Arno suggested to consider binary encoding, where HTTP may not be suitable. I would clarify the text in adding this in the text, e.g., How about this,  What's more, existing protocols should be investigated and evaluated for being reused or extended as the proposed protocols, e.g., HTTP for tracker protocol.  Considering that there can be a large number of peers,the peer protocol should consider some lightweight (possibly binary) encoding?

7)  Section  5.2
[Yunfei] Good suggestion.

Best  Regards,
Xiao  Lin

-----Original  Message-----
From:  [email-masked]  [mailto:[email-masked]]  On  Behalf  Of  ext  Martin  Stiemerling
Sent:  Monday,  August  01,  2011  9:26  PM
To:  [email-masked]
Subject:  [ppsp]  WGLC  for  draft-ietf-ppsp-problem-statement-02.txt  starting  today  until  August  15th

Dear  all,

   Martin

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 22 Aug 2011 12:24:27 +0000

Dear all,

The WGLC for draft-ietf-ppsp-problem-statement concluded successfully on 08/14, i.e., the draft is ready for the next steps, after the remaining edits are applied. 

There have been a number of reviews with comments and the draft got updated in the meantime. There is still some text missing for the security section which will be provided soon.

Thanks for all reviews.

  Martin

> We start a 2 weeks Working Group Last Call (WGLC) for draft-ietf-ppsp-
> problem-statement-02.txt, as agreed during the PPSP session at the IETF#81
> meeting.
> 
> Please review the draft and send your comments to the PPSP list. Any type of
> review is appreciated, even it is saying only "I have read the draft and it is ok".
> Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in
> England 2832014
> 
>

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 23 Aug 2011 10:42:06 +0800

[As an individual author of PPSP PS draft]

We are very grateful for the chair's orgnization and all the reviewers' careful review. We'll update the draft to solve all the remaining issues in a few days.

BR
Yunfei

zhangyunfei
2011-08-23

发件人： Martin Stiemerling
发送时间： 2011-08-22 20:25:07
收件人： Martin Stiemerling; [email-masked]
抄送： 
主题： Re: [ppsp] WGLC for draft-ietf-ppsp-problem-statement-02.txtstarting today until August 15th

Dear  all,

Thanks  for  all  reviews.

   Martin