Subject: [ppsp] Question about SVC/AVC support

From: Martin Stiemerling <[email-masked]>
Date: Thu, 10 Nov 2011 08:56:30 +0000

Hi,

I ran into SVC/AVC in the tracker draft and in draft-gu-ppsp-peer-protocol-03.txt. 

For the tracker, I'm not sure what the implications are, whereas for the peer protocol I can see implications. 

However, there has been no large scale discussion if the PPSP peer protocol should actually support SVC/AVC and if it should support it, what the implications are. 

When writing about this, is there also the need to support MDC?

Can somebody outline what the implications are if we support SVC/AVC codecs in the peer protocol?

Thank you,

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Rui Cruz <[email-masked]>
Date: Thu, 10 Nov 2011 12:20:29 +0000

Hi Martin,

Perhaps, I my apologies for repeating here what I answered in a previous message, that PPSP should support both "Structured Media"  (SVC/MDC/MVC/multi-bitrate) and unstructured media (AVC) or other formats, although the trend in the Internet has been for H.264 MPEG-4/AVC and its extensions SVC, MVC. In what respects MDC, it can be seen as an option, combined or not with SVC, but can perfectly be supported if the PPSP protocols are "codec agnostic" (not involved in the decoding process) but just "aware", as, in my opinion, they should be.  

A very important principle should be observed, in my opinion, related to the role the PPSP protocols play in the streaming process, as they should be open to support both "Structured Media"  (SVC/MDC/MVC/multi-bitrate) and unstructured media (AVC or other), but not being involved in the decoding/encoding processes of the "Structured Media". 
It is the Media Player application, not the protocols associated with the transport of the Media, the entity that should "know" (via a requester/re-assembler module) how and what to request (to a "peer") and decode the received "Structured Media" (from the "peer") in order to "present" it to the User. 

Both latest draft-gu-ppsp-tracker-protocol and draft-gu-ppsp-peer-protocol were designed with this principle in mind, and able to support (but not involved in the decoding) video streams transmitted at a suitable spacio-temporal resolution, adequate for the user's display device and networking conditions.
 
---------------------------
Best Regards,

Prof. Rui Santos Cruz
Chairman
IEEE Portugal Section
Av. Prof. Dr. Aníbal Cavaco Silva, IST-TagusPark, Office 1-5, 2744-016 Porto Salvo, Portugal
+351 214 233 200 (ext 5044), +351.939 060 939 (mobile)
[email-masked] 
[email-masked]
[email-masked]
www.ieee-pt.org
Advancing technology for humanity.

On 10/11/2011, at 08:56, Martin Stiemerling wrote:

> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: Martin Stiemerling <[email-masked]>
Date: Sun, 13 Nov 2011 03:49:07 +0100

Rui,

I should have written that this email was about the peer protocol, vs my 
earlier email which was about the tracker protocol.

I would like to know if you have any supported for structured codecs in 
your implementation, since you stress the fact to support in PPSP; and 
what the implications to the peer protocol are.

Is there any change required in the way how the "chunk maps" are treated 
or how the actual chunks are identified in the protocol, or how they are 
exchanged?

Thanks,

   Martin

On 11/10/2011 01:20 PM, Rui Cruz wrote:
> Hi Martin,
>
> Perhaps, I my apologies for repeating here what I answered in a previous
> message, that PPSP should support both "Structured Media"
> (SVC/MDC/MVC/multi-bitrate) and unstructured media (AVC) or other
> formats, although the trend in the Internet has been for H.264
> MPEG-4/AVC and its extensions SVC, MVC. In what respects MDC, it can be
> seen as an option, combined or not with SVC, but can perfectly be
> supported if the PPSP protocols are "codec agnostic" (not involved in
> the decoding process) but just "aware", as, in my opinion, they should be.
>
> A very important principle should be observed, in my opinion, related to
> the role the PPSP protocols play in the streaming process, as they
> should be open to support both "Structured Media"
> (SVC/MDC/MVC/multi-bitrate) and unstructured media (AVC or other), but
> *not being involved in the decoding/encoding processes of the
> "Structured Media"*.
> It is the Media Player application, not the protocols associated with
> the transport of the Media, the entity that should "know" (via a
> requester/re-assembler module) how and what to request (to a "peer") and
> decode the received "Structured Media" (from the "peer") in order to
> "present" it to the User.
>
> Both latest *draft-gu-ppsp-tracker-protocol* and
> *draft-gu-ppsp-peer-protocol *were designed with this principle in mind,
> and able to support (but not involved in the decoding) video streams
> transmitted at a suitable spacio-temporal resolution, adequate for the
> user's display device and networking conditions.
>
> *Prof. Rui Santos Cruz
> *Chairman
> *IEEE Portugal Section
> *Av. Prof. Dr. Aníbal Cavaco Silva, IST-TagusPark, Office 1-5, 2744-016
> Porto Salvo, Portugal
> [email-masked] <x-msg://127/[email-masked]>
> [email-masked] <x-msg://127/[email-masked]>
> [email-masked] <x-msg://127/[email-masked]>
> www.ieee-pt.org <http://www.ieee-pt.org/>
>> For the tracker, I'm not sure what the implications are, whereas for
>> the peer protocol I can see implications.
>>
>> However, there has been no large scale discussion if the PPSP peer
>> protocol should actually support SVC/AVC and if it should support it,
>> what the implications are.
>>
>> [email-masked] <mailto:[email-masked]>
>>
>> NEC Laboratories Europe - Network Research Division NEC Europe Limited
>> | Registered Office: NEC House, 1 Victoria Road, London W3 6BL |
>> Registered in England 2832014
>>
>>