Subject: [ppsp] draft-cruz-ppsp-http-peer-protocol: Clarification about the draft's status and further intention

From: Martin Stiemerling <[email-masked]>
Date: Thu, 1 Dec 2011 14:26:35 +0000

[writing as co-chair]

Hi all, 

The chairs have assumed that we have 2 drafts as candidates for the PPSP peer protocol selection, as stated during the meeting in the chair's slides (http://www.ietf.org/proceedings/82/slides/ppsp-0.pdf) and also in the original email " Selection of PPSP peer protocol draft"  (http://www.ietf.org/mail-archive/web/ppsp/current/msg01161.html).

However, it turned out during the recent discussions (http://www.ietf.org/mail-archive/web/ppsp/current/msg01211.html) that draft-gu-ppsp-peer-protocol-03 is **not** a merger of draft-gu-ppsp-peer-protocol-02 and draft-cruz-ppsp-http-peer-protocol-00; though also the updated author list of draft-gu-ppsp-peer-protocol-03 would also support this assumption of a merger of both protocols. 

Therefore, to clarify if the WG has also to consider draft-cruz-ppsp-http-peer-protocol-00 as a candidate: 

Should draft-cruz-ppsp-http-peer-protocol-00 also be considered as PPSP peer protocol proposal or not? 

A fast reply of the authors about the status of draft and their intention in addition to the above question who be nice!

Thank you

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: zhangyunfei <[email-masked]>
Date: Fri, 2 Dec 2011 01:31:51 +0800

[Speak individually]
According to Rui's remarks (http://www.ietf.org/mail-archive/web/ppsp/current/msg01211.html), I understand that the design team's intention is a merger draft, although there exist a typo(tracker protocol should be "peer protocol") in the draft announcement. Am I right?

Yunfei

zhangyunfei

From: Martin Stiemerling
Date: 2011-12-01 22:26
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [ppsp] draft-cruz-ppsp-http-peer-protocol: Clarification about the draft's status and further intention
[writing as co-chair]

Hi all, 

Thank you

  Martin

_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Rui Cruz <[email-masked]>
Date: Sat, 3 Dec 2011 19:44:04 +0000

Hi,

The authors of draft-cruz-ppsp-http-peer-protocol-00 intend to update the document by mid december.
This draft-cruz-ppsp-http-peer-protocol corresponds to web-based approach to the peer protocol.

> NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

Regards,

Rui Cruz
[email-masked]

IST/INESC-ID/INOV - Lisbon, Portugal
__________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Rui Cruz <[email-masked]>
Date: Sat, 3 Dec 2011 20:05:35 +0000

Hi Yunfei,

The  typo in the draft announcement to the mailing list, was not a typo but the unfortunate result of a  copy&paste, not edited, from the message announcing  the Tracker protocol, therefore, unintentionally included the last phrase referring a "merger" of drafts.

There was in fact no intention of a merger of drafts for the gu-ppsp-peer protocol.

The authors working in the draft-gu-ppsp-peer-protocol-03 were the only "merger" that happened.

Regards,

Rui Cruz
[email-masked]

---

From: Arno Bakker <[email-masked]>
Date: Mon, 5 Dec 2011 09:24:58 +0100

> approach to the peer protocol.

FYI, the draft-cruz-ppsp-http-peer-protocol expired last friday.

Regards,
     Arno Bakker

---

From: Rui Cruz <[email-masked]>
Date: Mon, 5 Dec 2011 10:46:02 +0000

We are aware of that, and I-Ds can be revived.

Thank you.

Rui

> FYI, the draft-cruz-ppsp-http-peer-protocol expired last friday.

---------------------------
Best Regards,

Prof. Rui Santos Cruz
Chairman
IEEE Portugal Section
Av. Prof. Dr. Aníbal Cavaco Silva, IST-TagusPark, Office 1-5, 2744-016 Porto Salvo, Portugal
+351 214 233 200 (ext 5044), +351.939 060 939 (mobile)
[email-masked] 
[email-masked]
[email-masked]
www.ieee-pt.org
Advancing technology for humanity.

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 7 Dec 2011 10:37:09 +0000

[writing as co-chair]
Hi Rui,

This means that draft-cruz-ppsp-http-peer-protocol should not be considered as another option, but only as a different encoding instance of the peer protocol in draft-gu-ppsp-peer-protocol?

  Martin

[email-masked]<mailto:[email-masked]>

From: Rui Cruz [mailto:[email-masked]] On Behalf Of Rui Cruz
Sent: Saturday, December 03, 2011 8:44 PM
To: Martin Stiemerling
Cc: Rui Cruz; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [ppsp] draft-cruz-ppsp-http-peer-protocol: Clarification about the draft's status and further intention

Hi,

[writing as co-chair]

Hi all,

Thank you

 Martin

[email-masked]<mailto:[email-masked]>

_______________________________________________
ppsp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ppsp

Regards,

Rui Cruz
[email-masked]<mailto:[email-masked]>

IST/INESC-ID/INOV - Lisbon, Portugal
__________________________________________
ppsp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Rui Cruz <[email-masked]>
Date: Wed, 7 Dec 2011 12:25:04 +0000

Hi Martin,

The update to draft-cruz-ppsp-http-peer-protocol should be considered a web-based option for the signaling.

Regards,

Rui Cruz
[email-masked]