Subject: [ppsp] I-D Action: draft-ietf-ppsp-base-tracker-protocol-00.txt

From: [email-masked]
Date: Thu, 14 Feb 2013 08:31:50 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Peer to Peer Streaming Protocol Working Group of the IETF.

	Title           : PPSP Tracker Protocol-Base Protocol (PPSP-TP/1.0)
	Author(s)       : Rui Santos Cruz
                          Mario Serafim Nunes
                          Gu Yingjie
                          Jinwei Xia
                          Joao P. Taveira
                          Deng Lingli
	Filename        : draft-ietf-ppsp-base-tracker-protocol-00.txt
	Pages           : 51
	Date            : 2013-02-14

Abstract:
   This document specifies the base Peer-to-Peer Streaming Protocol-
   Tracker Protocol (PPSP-TP/1.0), an application-layer control
   (signaling) protocol for the exchange of meta information between
   trackers and peers.  The specification outlines the architecture of
   the protocol and its functionality, and describes message flows,
   message processing instructions, message formats, formal syntax and
   semantics.  The PPSP Tracker Protocol enables cooperating peers to
   form content streaming overlay networks to support near real-time
   Structured Media content delivery (audio, video, associated timed
   text and metadata), such as adaptive multi-rate, layered (scalable)
   and multi-view (3D) videos, in live, time-shifted and on-demand
   modes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ppsp-base-tracker-protocol

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ppsp-base-tracker-protocol-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Arno Bakker <[email-masked]>
Date: Tue, 19 Feb 2013 11:59:42 +0100

Hi all

good that the tracker protocol is now in a WG document. Reading it again 
I really would like to have an option to specify that I want the tracker 
to return a random sample of the peer population of a swarm. Rui 
previously argued (mail dd. 13-11-2012) that it is an implementation 
issue, but I think users must be able to ask for specific semantics, 
just like they can select the number of peers to be returned, etc.

What do you think?

CU,
     Arno

---

From: João Pedro Taveira <[email-masked]>
Date: Tue, 19 Feb 2013 12:17:52 +0000

Hi Arno,

About the number of peers to be returned, one may specify optional PeerNUM.

About the option you mention about request a random sample of peer
population, I think this could be defined in one extended version of
tracker protocol. For instance, to the PeerNUM element, it could be
specified a "selector" attribute with the key of one of acceptable
selectors by tracker implementation, such as a "random" key.

Using CONNECT message sample
http://tools.ietf.org/html/draft-ietf-ppsp-base-tracker-protocol-00#section-4.1,
a connect message could be:

<?xml version="1.0" encoding="UTF-8"?>
<PPSPTrackerProtocol xmlns="TBD" schemaLocation="TBD" version="1.2">
  <Request>CONNECT</Request>
  <PeerID>656164657220</PeerID>
  <PeerNum abilityNAT="STUN" selector="random">15</PeerNum>
  <SwarmID action="JOIN" peerMode="SEED"
           transactionID="12345.1">1111</SwarmID>
  <SwarmID action="JOIN" peerMode="SEED"
           transactionID="12345.2">2222</SwarmID>
  <TransactionID>12345.0</TransactionID>
</PPSPTrackerProtocol>

Best Regards

On Tue, Feb 19, 2013 at 10:59 AM, Arno Bakker <[email-masked]> wrote:

> Hi all
>
> good that the tracker protocol is now in a WG document. Reading it again I
> really would like to have an option to specify that I want the tracker to
> return a random sample of the peer population of a swarm. Rui previously
> argued (mail dd. 13-11-2012) that it is an implementation issue, but I
> think users must be able to ask for specific semantics, just like they can
> select the number of peers to be returned, etc.
>
> What do you think?
>
> CU,
>     Arno
>
>
> ______________________________**_________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/ppsp<https://www.ietf.org/mailman/listinfo/ppsp>
>

---

From: Rui Cruz <[email-masked]>
Date: Tue, 19 Feb 2013 17:22:04 +0000

Hi Arno and All,

As a matter of fact, in page 28 (second paragraph: implementation note) such situation is described, i.e., the Tracker service responds with a random sample of the peer population in the peer list.

The text however, as it is written, is not clear, "apparently" restricting the "random" nature of the sample taken to a non-specific selection criteria in the PeerNum element. That situation can perfectly be cleared by rewriting that paragraph.

What I mean is: the tracker protocol semantics already conveys the "criteria" to be respected by the Tracker service in the corresponding responses regarding the peer list, and the "normal" behavior of the Tracker Service should be of taking a random sample of the peer population in a swarm (subject or not to more fine-grained criteria expressed in the PeerNum attributes or by Operators’ policy preferences, e.g., peer location). 
As such, the peer protocol requirement 13.2.3 was already considered, but not conveniently expressed in the text.

Of course, as in João Pedro Taveira's response, an extension to the base protocol semantics could also be considered in order to include additional attributes in the PeerNum element to "instruct" the Tracker service of a "selector algorithm" to be used in addition to the other criteria, and in alternative to the default "random" selector. But that is an option for extension of the base protocol. 

Regards,

Rui Cruz
[email-masked]

IST/INESC-ID/INOV - Lisbon, Portugal
__________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

On 19/02/2013, at 10:59, Arno Bakker <[email-masked]> wrote:

> Hi all
> 
> good that the tracker protocol is now in a WG document. Reading it again I really would like to have an option to specify that I want the tracker to return a random sample of the peer population of a swarm. Rui previously argued (mail dd. 13-11-2012) that it is an implementation issue, but I think users must be able to ask for specific semantics, just like they can select the number of peers to be returned, etc.
> 
> What do you think?
> 
> CU,
>    Arno
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: Arno Bakker <[email-masked]>
Date: Wed, 20 Feb 2013 08:10:45 +0100

On 19/02/2013 18:22, Rui Cruz wrote:
>
> What I mean is: the tracker protocol semantics already conveys the
> "criteria" to be respected by the Tracker service in the corresponding
> responses regarding the peer list, and the "normal" behavior of the
> Tracker Service should be of taking a random sample of the peer
> population in a swarm (subject or not to more fine-grained criteria
> expressed in the PeerNum attributes or by Operators’ policy preferences,
> e.g., peer location).
> As such, the peer protocol requirement 13.2.3 was already considered,
> but not conveniently expressed in the text.
>

Hi Rui

if you could update the text to make this clearer that would be great.

Regards,
      Arno