Subject: [ppsp] Fw: New Version Notification for draft-ietf-ppsp-problem-statement-13.txt

From: zhangyunfei <[email-masked]>
Date: Mon, 25 Feb 2013 10:39:40 +0800

Hi all,
   
    A new revision of PPSP problem statement and requirement draft has been uploaded. Any review and comments are welcome.

BR
Yunfei

zhangyunfei

From: internet-drafts
Date: 2013-02-23 03:44
To: zhangyunfei
CC: zongning
Subject: New Version Notification for draft-ietf-ppsp-problem-statement-13.txt

A new version of I-D, draft-ietf-ppsp-problem-statement-13.txt
has been successfully submitted by Yunfei Zhang and posted to the
IETF repository.

Filename:  draft-ietf-ppsp-problem-statement
Revision:  13
Title:  Problem Statement and Requirements of Peer-to-Peer Streaming Protocol (PPSP)
Creation date:  2013-02-20
Group:  ppsp
Number of pages: 26
URL:             http://www.ietf.org/internet-drafts/draft-ietf-ppsp-problem-statement-13.txt
Status:          http://datatracker.ietf.org/doc/draft-ietf-ppsp-problem-statement
Htmlized:        http://tools.ietf.org/html/draft-ietf-ppsp-problem-statement-13
Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-ppsp-problem-statement-13

Abstract:
   Peer-to-Peer(P2P for short) streaming systems show more and more
   popularity in current Internet with proprietary protocols. This
   document identifies problems of the proprietary protocols, proposes
   the development of Peer to Peer Streaming Protocol(PPSP) including
   the Tracker and Peer protocol, and discusses the scope, requirements
   and use cases of PPSP.

The Meta-Data check indicates the following error:
 *Document date* None
Creation Date field is empty or the creation date is not in a proper format 

I check the draft without finding the error. So I manually update the metadata with the right creation time. Thanks for the help.

The IETF Secretariat

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Feb 2013 16:14:43 +0100

Hi all,

There have been requirements added in the recent version that should be 
double-checked by the WG, before publishing the draft.

Yunfei and Stefano: Can you please run a short WGLC (e.g., until March 
5th) on the changes in version 13 to see if the WG has any issues with them?

Thanks,

   Martin

On 02/25/2013 03:39 AM, zhangyunfei wrote:
> Hi all,
>      A new revision of PPSP problem statement and requirement
> draft has been uploaded. Any review and comments are welcome.
> BR
> Yunfei
> ------------------------------------------------------------------------
> zhangyunfei
> *From:* internet-drafts <mailto:[email-masked]>
> *Date:* 2013-02-23 03:44
> *To:* zhangyunfei <mailto:[email-masked]>
> *CC:* zongning <mailto:[email-masked]>
> *Subject:* New Version Notification for
> draft-ietf-ppsp-problem-statement-13.txt
> Title:
>   Problem Statement and Requirements of Peer-to-Peer Streaming Protocol (PPSP)
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>

-- 
[email-masked]

NEC Laboratories Europe
NEC Europe Limited
Registered Office:
Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB
Registered in England 2832014

---

From: stefano previdi <[email-masked]>
Date: Tue, 26 Feb 2013 16:31:40 +0100

All,

the problem statement & requirements draft has been updated according to 
comments we received during IESG review.

A new set of requirement has been added in section 6.2. Operation & 
Management Requirements.

As Martin suggested, we're going to run a WG last call until March 5.

Please, have a look at the draft: 
 http://www.ietf.org/internet-drafts/draft-ietf-ppsp-problem-statement-13.txt

and come back to the list with any comment.

Thanks.
s.

---

From: Arno Bakker <[email-masked]>
Date: Wed, 27 Feb 2013 15:08:35 +0100

> and come back to the list with any comment.

Hi all

I have the following comments:

* PPSP.OAM.REQ-1: PPSP MUST be sufficiently configurable for 
installation and initial setup.

	I don't get the reference to "initial setup" there. I suggest
	to make the requirement "sufficiently configurable" (which is 	
	what we strived for with different chunk addressing, content
	protection methods) and state that the configuration should
	allow the proxy-based and end-client scenarios.

* PPSP.OAM.REQ-2: PPSP MUST implement a set of configuration 
parameters with default values.

	IMHO the descriptive text doesn't add anything and suggest it
	be removed.

* PPSP.OAM.REQ-3: PPSP MUST be capable of controlling traffic load to
existing networks.

	I suggest to rephrase this to "PPSP SHOULD allow steering by
	network-load management protocols." Current phrasing I find
	unclear and very restrictive with the MUST clause.

* PPSP.OAM.REQ-4: PPSP MUST support diagnostic operations.

	Typo: "correct operations" -> "correct operation"
	Typo: "*The* PPSP tracker should"
	Rephrase: "obtained chunks in due time" -> "whether it obtained
	chunks in time".

* PPSP.OAM.REQ-5: PPSP MUST facilitate achieving quality acceptable to
streaming application.

	I have problems with the last paragraph about scalable
	streaming. To me, it suggests scalable streaming should be
	supported. I suggest to rephrase to "PPSP implementations MAY
	use techniques such as scalable streaming to handle bandwidth
	shortages without disrupting playback."
	
	Typo: "to streaming application" -> "to *the* streaming ..."	
	
* PPSP.OAM.REQ-6: PPSP MUST support remote management using
centralized server, i.e. PPSP tracker. A basic set of management
information MUST be implemented by PPSP tracker.

	The wording suggests a centralized design where all management
	operations are done via the tracker. This image is not correct
	IMHO. A tracker service can play an important role in managing
	a swarm. E.g. it can be used to control publication of a swarm,
	or to monitor the health of the swarm. Hence it should have a
	standard management interface that supports such functionality.
	This interface should take into account that the tracker
	*service* may be implemented by multiple *servers*. However,
	PPSP should also support tracker-less designs and should define
	a management interface for (farms of) PPSP seeders.

	I suggest to rephrase the requirement so that the tracker
	service and PPSP seeders should have a remote management
	interface. Current descriptive text should be tweaked to
	explain the unique position of the tracker (sees both clients
	and PPSP seeders).

* PPSP.OAM.REQ-9: PPSP MUST support accounting management when content
provider wants to charge clients for certain content.

	I suggest to change the "MUST" to a "MAY" or "SHOULD allow
	accounting management".

CU,
     Arno