Subject: [ppsp] Next Step Work on Base Tracker Draft

From: Xiajinwei <[email-masked]>
Date: Wed, 11 Dec 2013 06:45:58 +0000

Hi all,

According to the last IETF meeting minutes, I have a few concerns about the Base Tracker draft.

1, Is HTTP confirmed to be used to convey PPSP-TP message? Or take raw TCP into account, or otherwise?

2, We plan to use a general syntax (like C, ASN.1) to define the PPSP-TP message structures while leaving the underlying encoding type into appendix, does the PPSP agree this approach?

3, Requesting peer may support XML encoding, binary encoding or both. In such case, how can the requesting peer negotiate the encoding type with an appropriate tracker? Our raw thought is to use the MPD to convey the appropriate tracker information to the peer during the bootstrap stage. Does the PPSP agree this approach?

IMHO these concerns needs to be confirmed by PPSP before we can push this draft forward in a correct direction.

Thank you all!

---

From: yunfei zhang <[email-masked]>
Date: Fri, 13 Dec 2013 12:25:43 +0800

Hi Jinwei and all,
     Speaking individually:
Point1， personally I think HTTP model is well suited for request/response
(without too frequent interaction), which is suitalbe for peer and tracker
communication.
Point2, I do think this is a good approach and has been achieved rough
consensus in the mailing list before last IETF.
Point3, one more issue is that do we enable peers supporting different
encodings to communicate, or just leave them in different swarm.

BR
Yunfei

2013/12/11 Xiajinwei <[email-masked]>

> 2, We plan to use a general syntax (like C, ASN.1) to define the PPSP-TP
> message structures while leaving the underlying encoding type into
> appendix, does the PPSP agree this approach?
>
>
>
> 3, Requesting peer may support XML encoding, binary encoding or both. In
> such case, how can the requesting peer negotiate the encoding type with an
> appropriate tracker? Our raw thought is to use the MPD to convey the
> appropriate tracker information to the peer during the bootstrap stage.
> Does the PPSP agree this approach?
>
>
>
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>
>

---

From: Xiajinwei <[email-masked]>
Date: Fri, 13 Dec 2013 05:40:33 +0000

Yunfei,

For the Point 3, I presume you are suggesting the negotiation is out of scope of tracker draft, so no need to highlight (maybe just mention) it in tracker draft.

We will do it based on your agreement.

Thank you!

BR
Jinwei

发件人: yunfei zhang [mailto:[email-masked]]
发送时间: 2013年12月13日 12:26
收件人: Xiajinwei
抄送: [email-masked]
主题: Re: [ppsp] Next Step Work on Base Tracker Draft

Hi Jinwei and all,
     Speaking individually:
Point1， personally I think HTTP model is well suited for request/response (without too frequent interaction), which is suitalbe for peer and tracker communication.
Point2, I do think this is a good approach and has been achieved rough consensus in the mailing list before last IETF.
Point3, one more issue is that do we enable peers supporting different encodings to communicate, or just leave them in different swarm.

BR
Yunfei

2013/12/11 Xiajinwei <[email-masked]<mailto:[email-masked]>>
Hi all,

Thank you all!

_______________________________________________
ppsp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 13 Dec 2013 06:13:57 +0000

Hi Yunfei,

Best regards,
Rachel

From: ppsp [mailto:[email-masked]] On Behalf Of yunfei zhang
Sent: Friday, December 13, 2013 12:26 PM
To: Xiajinwei
Cc: [email-masked]
Subject: Re: [ppsp] Next Step Work on Base Tracker Draft

Hi Jinwei and all,
     Speaking individually:
Point1， personally I think HTTP model is well suited for request/response (without too frequent interaction), which is suitalbe for peer and tracker communication.
Point2, I do think this is a good approach and has been achieved rough consensus in the mailing list before last IETF.
Point3, one more issue is that do we enable peers supporting different encodings to communicate, or just leave them in different swarm.
[Rachel]: I think peers should be allowed to support different encoding, so that the same peer could participant in different swarms supporting different encodings. For the case when both tracker and peer support  both encodings, we could mandate a default encoding (e.g., text based) to use. To me, the approach below proposed by Jinwei could solve the whole problems.

BR
Yunfei

Thank you all!

---

From: yunfei zhang <[email-masked]>
Date: Sat, 14 Dec 2013 14:28:08 +0800

Hi Jinwei,
   For my point3, it's a QUESTION instead of a suggestion. So maybe we need
to analyze the pros and cons for the two options,i.e., negotiation or not
 first before making the decision.

Br
Yunfei

2013/12/13 Xiajinwei <[email-masked]>

>  Yunfei,
>
>
>
> For the Point 3, I presume you are suggesting the negotiation is out of
> scope of tracker draft, so no need to highlight (maybe just mention) it in
> tracker draft.
>
>
>
> *发件人:* yunfei zhang [mailto:[email-masked]]
> *发送时间:* 2013年12月13日 12:26
> *收件人:* Xiajinwei
> *抄送:* [email-masked]
> *主题:* Re: [ppsp] Next Step Work on Base Tracker Draft
>
>
>
> Hi Jinwei and all,
>
>      Speaking individually:
>