Subject: [ppsp] A question for the peer protocol

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Sun, 26 Jan 2014 06:24:21 +0000

Hi, the authors of peer protocol,

The peer protocol supports can use different chunk addressing methods, e.g. 32-bit chunk ranges, 64-bit chunk ranges, 32-bit byte ranges, bins, etc. All the peer MUST support "32-bit chunk ranges" and "64-bit chunk ranges" for successful interactions. And all peers in one swarm MUST use the same chunk addressing method. But how do the peers know the chunk addressing method for that swarm? I couldn't find the answer in the draft.

Best regards,
Rachel

---

From: Arno Bakker <[email-masked]>
Date: Mon, 27 Jan 2014 09:04:12 +0100

On 26/01/2014 07:24, Huangyihong (Rachel) wrote:
> The peer protocol supports can use different chunk addressing
> methods, e.g. 32-bit chunk ranges, 64-bit chunk ranges, 32-bit byte
> ranges, bins, etc. All the peer MUST support "32-bit chunk ranges"
> and "64-bit chunk ranges" for successful interactions. And all peers
> in one swarm MUST use the same chunk addressing method. But how do
> the peers know the chunk addressing method for that swarm? I couldn't
> find the answer in the draft.
> 

Hi Rachel et al.

the chunk addressing method is part of the metadata of the swarm (Sec.
12.1.1) and communicated as a protocol option (Sec. 7.8).

Regards,
     Arno

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 27 Jan 2014 08:52:51 +0000

Hi Arno,

Thank you to point out. Is that metadata of the swarm allowed to include multiple chunk addressing methods? If not, what if the chunk addressing method configured in the swarm is not supported by some peers?  If yes, then how do the peers know which one will be selected as the streaming chunk addressing method? HANDSHAKE only provides the negotiation between two peers. I think there should be some clarifications in the draft. 

Best regards,
Rachel

> -----Original Message-----
> From: ppsp [mailto:[email-masked]] On Behalf Of Arno Bakker
> Sent: Monday, January 27, 2014 4:04 PM
> To: [email-masked]
> Subject: Re: [ppsp] A question for the peer protocol
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: Arno Bakker <[email-masked]>
Date: Tue, 28 Jan 2014 07:53:29 +0100

On 27/01/2014 09:52, Huangyihong (Rachel) wrote:
> Hi Arno,
> 
> Thank you to point out. Is that metadata of the swarm allowed to
> include multiple chunk addressing methods? If not, what if the chunk
> addressing method configured in the swarm is not supported by some
> peers?  If yes, then how do the peers know which one will be selected
> as the streaming chunk addressing method? HANDSHAKE only provides the
> negotiation between two peers. I think there should be some
> clarifications in the draft.
> 

Hi

as you write "And all peers in one swarm MUST use the same chunk
addressing method." If they don't support the one the content provider
selected, they are out of luck.

Regards,
    Arno

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 28 Jan 2014 08:12:17 +0000

Hi Arno,

Yes, that's a solution. I expect it to be clearly written in the draft. 

But I think mandating implementations MUST support "32-bit chunk ranges" and "64-bit chunk ranges" won't help much in this case. The swarm is possible to be configured with some other methods.

Best regards,
Rachel

> From: Arno Bakker [mailto:[email-masked]]
> Sent: Tuesday, January 28, 2014 2:53 PM
> To: Huangyihong (Rachel)
> Cc: [email-masked]