Subject: [ppsp] review of base tracker protocol

From: "Roni Even" <[email-masked]>
Date: Thu, 16 Oct 2014 18:58:10 +0300

Hi,

I reviewed the document and have some comments and nits. 

1.       Nit: In section 1 "The PPSP architecture requires PPSP peers able
to communicate" should be "The PPSP architecture requires that PPSP peers
are able to communicate"

2.       In section 1.1 "CHUNK ID" is it identifier for SEGMENT CHUNK or for
a CHUNK. Also you need to expand MPD.  I also have a question if the address
scheme is described in the MPD?

3.       In section 1.1 "TRACKER" it says that it also answers PEER LIST
queries. It does not mention the other requests, is this the only one that
it respond to?

4.       In 2.1 3rd paragraph you mention the service Portal, it is not
mentioned in section 1.1 but the connection tracker is.

5.       In section 2.3 delete "over it" at the end of the section.

6.       A general question on transport (relates also for 2.3, 2.3.1,. ),
do you mandate using TLS for security reasons, or is also TCP allowed and
when? In section 7.1 second paragraph says that a channel oriented security
mechanism should (change to SHOULD) be used. Why SHOULD and not MUST in
which cases you can use non secure communication between peers and tracker?

7.       In section 2.3.2 "FIND" - "This Request message is an "action
signal" used by peers to request to the tracker"  change "to request from
the tracker"

8.       In section 4 for  why is PPSP_TP_EXTENDED have the comment before
"//"  typedef enum ppsp_tp_versions {

                   PPSP_TP_BASE       = 0x10, // or "1.0"
                // PPSP_TP_EXTENDED   = 0x11, // or "1.1"
      } ppsp_tp_version_t;
 
9.       In the ppsp_tp_peer_addr there is an enum for connection, how is it
used, is it for information only in which case why is it in each message?
10.   In section 6.1.3 the security is in 7.1 and not 6.1 
 
Thanks
Roni Even

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 17 Oct 2014 08:13:05 +0000

Hi Roni,

I can answer some of the questions. Please see inline. Authors, please correct me if I'm wrong.
BTW, just let you know that we also have an extended tracker protocol draft. If you're interested in it, please read it and give some comments.
Thanks.

BR,
Rachel

From: ppsp [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Thursday, October 16, 2014 11:58 PM
To: [email-masked]
Subject: [ppsp] review of base tracker protocol

Hi,

1.       Nit: In section 1 "The PPSP architecture requires PPSP peers able to communicate" should be "The PPSP architecture requires that PPSP peers  are able to communicate"
[Rachel]: Okay.

2.       In section 1.1 "CHUNK ID" is it identifier for SEGMENT CHUNK or for a CHUNK. Also you need to expand MPD.  I also have a question if the address scheme is described in the MPD?
[Rachel]:  I think it is for a CHUNK. And I don't think we have to bring the term "SEGMENT CHUNK" to tracker protocol. And yes, chunk addressing scheme could be described in MPD. Actually, section 1.1 has defined MEDIA PRESENTATION DESCRIPTION (MPD).

3.       In section 1.1 "TRACKER" it says that it also answers PEER LIST queries. It does not mention the other requests, is this the only one that it respond to?
[Rachel]: I agree it's not accurate.  Need fix. Maybe just delete "PEER LIST".

4.       In 2.1 3rd paragraph you mention the service Portal, it is not mentioned in section 1.1 but the connection tracker is.

[Rachel]: Okay.

6.       A general question on transport (relates also for 2.3, 2.3.1,... ),  do you mandate using TLS for security reasons, or is also TCP allowed and when? In section 7.1 second paragraph says that a channel oriented security mechanism should (change to SHOULD) be used. Why SHOULD and not MUST in which cases you can use non secure communication between peers and tracker?

7.       In section 2.3.2 "FIND" - "This Request message is an "action signal" used by peers to request to the tracker"  change "to request from the tracker"
[Rachel]: Okay.

8.       In section 4 for  why is PPSP_TP_EXTENDED have the comment before "//"  typedef enum ppsp_tp_versions {

      } ppsp_tp_version_t;
[Rachel]: Need fix. It should be extended in extended tracker protocol draft.

9.       In the ppsp_tp_peer_addr there is an enum for connection, how is it used, is it for information only in which case why is it in each message?

[Rachel]: It's just information for this specific interface. Peer will tell tracker its interface connection information, and the peer list sent from tracker also includes this information for each peer address.

[Rachel]: Okay.

Thanks

Roni Even