Subject: Re: [ppsp] New comments for extend tracker protocol

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 13 Oct 2014 01:12:41 +0000

Hi Fei,

Thanks again for your careful review and comments. Please see inline.

BR,
Rachel

> -----Original Message-----
> From: ppsp [mailto:[email-masked]] On Behalf Of Fei Song
> Sent: Monday, October 13, 2014 8:05 AM
> To: [email-masked]
> Subject: [ppsp] New comments for extend tracker protocol
> 
> Hi Rachel:
> 
> 1. 4.3. Usage of Extended Request Messages Section 4.3 gives a clear usage of
> the extended request messages. The statement is good. Since this part is
> trying to demonstrate the benefits of using DISCONNECT and other extended
> messages, more description will be helpful here.

[Rachel]: Yes, you're right. Will do it.

> 2. Section 3.2, the first sentence: "A peer may have the requirement to start
> streaming the content from some specific point of the content timeline." Point
> or Points?

[Rachel]: it's "point". I'll use "one" instead of "some" to avoid ambiguity. What do you think?

> 3. In both base draft and extended draft, we can see the "Per-Peer-ID
> Transaction State Machine" figure. Section 2.4 of PPSP base tracker protocol
> indicates that the START state is transient. I don't know whether it is suitable
> to mark "Transient" just next to the "PEER REGISTERD state" block.

[Rachel]: Marking "PEER REGISTRERED" state with "Transient" is because we don't have to wait for any messages in this state. When a tracker receives the CONNECT message from a new peer, it will move the peer's state from START to PEER REGISTERED. After analyzing and authenticating the CONNECT message, the tracker moves the states to either "TRACKING" or "TERMINATE". So this state is quite short, depending on the time that the tracker deals with the new CONNECT message.

> 
> 
> Best Regards!
> 
> Fei Song
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Fei Song" <[email-masked]>
Date: Mon, 13 Oct 2014 09:32:37 +0800

Hi Rachel:

For the second point, I think it is great to use "one" : )

--------------
Fei Song

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 13 Oct 2014 01:36:35 +0000

Okay, will fix it^^.

BR,
Rachel

> From: Fei Song [mailto:[email-masked]]
> Sent: Monday, October 13, 2014 9:33 AM
> To: Huangyihong (Rachel); [email-masked]
> Cc: hkzhang
> Subject: Re: RE: [ppsp] New comments for extend tracker protocol
> 
> Hi Rachel:
> 
> >> 1. 4.3. Usage of Extended Request Messages Section 4.3 gives a clear
> >> usage of the extended request messages. The statement is good. Since
> >> this part is trying to demonstrate the benefits of using DISCONNECT
> >> and other extended messages, more description will be helpful here.
> >
> >> 2. Section 3.2, the first sentence: "A peer may have the requirement
> >> to start streaming the content from some specific point of the
> >> content timeline." Point or Points?
> >
> >> Transaction State Machine" figure. Section 2.4 of PPSP base tracker
> >> protocol indicates that the START state is transient. I don't know
> >> whether it is suitable to mark "Transient" just next to the "PEER REGISTERD
> state" block.
> >
> >[Rachel]: Marking "PEER REGISTRERED" state with "Transient" is because we
> don't have to wait for any messages in this state. When a tracker receives the
> CONNECT message from a new peer, it will move the peer's state from START
> to PEER REGISTERED. After analyzing and authenticating the CONNECT
> message, the tracker moves the states to either "TRACKING" or "TERMINATE".
> So this state is quite short, depending on the time that the tracker deals with
> the new CONNECT message.
> >
> >>
> >>
> >> Best Regards!
> >>
> >> Fei Song