Subject: [ppsp] Comment on base tracker protocol binary encoding

From: Arno Bakker <[email-masked]>
Date: Mon, 27 Oct 2014 09:30:24 +0100

Hi all

when I look at the binary encoding in Section 3 the following questions
come up:
1. Why wasn't an existing encoding standard chosen?
2. The draft does not specify the endianness for the integer data?
3. Is there a need to support Unicode/internationalization? If so, this
should be added.

CU,
    Arno

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 27 Oct 2014 09:42:07 +0000

Hi Arno,

Thanks for the comments. Please see inline.

BR,
Rachel

> -----Original Message-----
> From: ppsp [mailto:[email-masked]] On Behalf Of Arno Bakker
> Sent: Monday, October 27, 2014 4:30 PM
> To: ppsp
> Subject: [ppsp] Comment on base tracker protocol binary encoding
> 
> Hi all
> 
> when I look at the binary encoding in Section 3 the following questions come up:

[Rachel]: Which encoding standard are you suggesting? 

> 2. The draft does not specify the endianness for the integer data?

[Rachel]: have fixed in the new version. " For a binary encoding, all integer fields are carried in network byte order, i.e., most significant octet first. "

> 3. Is there a need to support Unicode/internationalization? If so, this should be
> added.

[Rachel]: I'm not sure if it's necessary. I'd like to see others' opinions on this.

> 
> CU,
>     Arno
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: Arno Bakker <[email-masked]>
Date: Mon, 27 Oct 2014 13:08:15 +0100

> [Rachel]: Which encoding standard are you suggesting? 

XDR [RFC4506] is one of the classics.

CU,
    Arno

---

From: "Prof. Rui Santos Cruz Eng." <[email-masked]>
Date: Mon, 27 Oct 2014 12:17:04 +0000

The idea for the new specification of the protocol, was to avoid suggestions of encoding, leaving that to implementation.
Thee main reasons for delaying the approval process of previous versions of the draft was for having included suggestions of encoding (text or binary). 

Regards,

Dr. Rui Santos Cruz, Ph.D.
[email-masked]

IST/INESC-ID/INOV - Lisbon, Portugal
__________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

> On 27 Oct 2014, at 12:08, Arno Bakker <[email-masked]> wrote:
>

---

From: Arno Bakker <[email-masked]>
Date: Mon, 27 Oct 2014 16:51:05 +0100

On 27/10/2014 13:17, Prof. Rui Santos Cruz Eng. wrote:
> The idea for the new specification of the protocol, was to avoid
> suggestions of encoding, leaving that to implementation.
> Thee main reasons for delaying the approval process of previous versions
> of the draft was for having included suggestions of encoding (text or
> binary). 
> 

Hi

I did not follow the whole discussion, but the draft should be such that
interoperable implementations can be made. Weren't the encodings
supposed to go into appendices?

CU,
    Arno