Subject: [ppsp] Reivew of the base tracker protocol

From: "yunfei" <[email-masked]>
Date: Fri, 24 Oct 2014 10:14:15 +0800

Hi,
   (Speaking individually) I have reviewed the latest three versions of the base tracker protocol and have the following comments. Wish it helpful for today's online discussion.
 
General: I do like the idea in the latest two versions that the new section (section 3 and the corresponding update in section 4) has been added to address to accomodate different encodings in unified data type.
 
Comments:
1) Section 4.1:
typedef struct {  
                     CONCRETE_PROTO_SPEC_DEPENDENT    address;  
                     // string, addr_in4,  
                     // addr_in6, addr_storage  
                     CONCRETE_PROTO_SPEC_DEPENDENT    port;  
                     // string (IANA service port),  
                     // or uint16 (service port) 

Is the definition of the type of address and port missing? I didn't find them before.
 
2) In the end of section 5.1 and 5.2, there is an IMPLEMENTATION NOTE saying: If no PeerNum attributes are present in the request the tracker MAY return a random sample from the peer population. 
It's suggested to set a DEFAULT value for the return number if no explict request of number.

BR
Yunfei

typedef struct {

CONCRETE_PROTO_SPEC_DEPENDENT address;

// string, addr_in4,

// addr_in6, addr_storage

CONCRETE_PROTO_SPEC_DEPENDENT port;

// string (IANA service port),

// or uint16 (service port)

CONCRETE_PROTO_SPEC_DEPENDENT address;

// string, addr_in4,

// addr_in6, addr_storage

CONCRETE_PROTO_SPEC_DEPENDENT port;

// string (IANA service port),

// or uint16 (service port)

CONCRETE_PROTO_SPEC_DEPENDENT address;

// string, addr_in4,

// addr_in6, addr_storage

CONCRETE_PROTO_SPEC_DEPENDENT port;

// string (IANA service port),

// or uint16 (service port)

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 24 Oct 2014 03:06:18 +0000

Hi Yunfei,

Please see inline.

BR,
Rachel

From: ppsp [mailto:[email-masked]] On Behalf Of yunfei
Sent: Friday, October 24, 2014 10:14 AM
To: draft-ietf-ppsp-base-tracker-pro; ppsp
Subject: [ppsp] Reivew of the base tracker protocol

Hi,

Comments:

1) Section 4.1:

typedef struct {

                     // string, addr_in4,

 [Rachel]: Yes. Comparing to previous xml format, the address type is missing.

 [Rachel]: Agree. The tracker should set a DEFAULT value. And I think this should also apply in the case of peer_count= 0.

BR

Yunfei
typedef struct {

// string, addr_in4,

// string, addr_in4,

// string, addr_in4,