Subject: [ppsp] 答复: Comment on base tracker protocol binary encoding

From: Xiajinwei <[email-masked]>
Date: Fri, 7 Nov 2014 09:52:57 +0000

Hi Arno,

We can move the specific encoding into appendices, if so, the content in appendix is just informative, not normative. But in my mind, the actual implementation may not use the codes.

BR
Jinwei

> -----邮件原件-----
> 发件人: ppsp [mailto:[email-masked]] 代表 Arno Bakker
> 发送时间: 2014年10月27日 23:51
> 收件人: Prof. Rui Santos Cruz Eng.
> 抄送: ppsp
> 主题: Re: [ppsp] Comment on base tracker protocol binary encoding
> 
> On 27/10/2014 13:17, Prof. Rui Santos Cruz Eng. wrote:
> > The idea for the new specification of the protocol, was to avoid
> > suggestions of encoding, leaving that to implementation.
> > Thee main reasons for delaying the approval process of previous
> > versions of the draft was for having included suggestions of encoding
> > (text or binary).
> >
> 
> Hi
> 
> I did not follow the whole discussion, but the draft should be such that
> interoperable implementations can be made. Weren't the encodings supposed
> to go into appendices?
> 
> CU,
>     Arno
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: Arno Bakker <[email-masked]>
Date: Fri, 7 Nov 2014 15:40:27 +0100

On 07/11/2014 10:52, Xiajinwei wrote:
> Hi Arno,
> 
> We can move the specific encoding into appendices, if so, the content
> in appendix is just informative, not normative. But in my mind, the
> actual implementation may not use the codes.
> 

Hi

IMHO, for people to build interoperable implementations at least one
encoding needs to be mandatory to implement.

CU,
    Arno

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 12 Nov 2014 16:27:02 -1000

[writing as an individual, not as your Area Director]

Sorry for getting so late to this email, but:

> suggestions of encoding, leaving that to implementation.

No encoding, means no protocol, means no standard.

Get started on finding consensus on a protocol encoding right now. 
Otherwise, we can just abandon the tracker protocol draft.

   Martin