Subject: [ppsp] Review of draft-huang-ppsp-extended-tracker-protocol-07

From: "Roni Even" <[email-masked]>
Date: Thu, 4 Dec 2014 17:15:08 +0200

Hi,

I reviewed the draft and in general it looks OK, some comments

1.       In section 5.3 in the first case it says that the peer will now if
the tracker supports the extension based on the error response why cannot
the peer know it based on the ppsp_tp_versions value

2.       In section 5.4 why not say that if a tracker support version 01 it
MUST support the same chunk addressing method as the peers. This will be in
line with section 4 of peer protocol that says "All peers in a swarm MUST
use the same chunk addressing method."

Thanks

Roni Even

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 9 Dec 2014 02:24:01 +0000

Hi Roni,

Thank you for the review. See my replies inline.

BR,
Rachel

发件人: ppsp [mailto:[email-masked]] 代表 Roni Even
发送时间: 2014年12月4日 23:15
收件人: [email-masked]
主题: [ppsp] Review of draft-huang-ppsp-extended-tracker-protocol-07

Hi,

1.       In section 5.3 in the first case it says that the peer will now if the tracker supports the extension based on the error response why cannot the peer know it based on the ppsp_tp_versions value
[Rachel]: Because there’s no negotiation in the whole tracker protocol design. So the first message sent from the peer is the CONNECT message. Only when the tracker responds,  the peer know if the tracker supports the extension.

2.       In section 5.4 why not say that if a tracker support version 01 it MUST support the same chunk addressing method as the peers. This will be in line with section 4 of peer protocol that says “All peers in a swarm MUST use the same chunk addressing method.“

[Rachel]: But a tracker could serve multiple swarms. What if different swarms chooses different chunk addressing methods? Actually the principle in the extended tracker protocol is consistent with the peer protocol. See section 5.4 : “Multiple chunk addressing methods could be used in this document to present content information. But only one of them MUST be used for
one swarm when a peer communicating with a tracker.”

Thanks
Roni Even