Subject: Re: [ppsp] I-D Action: draft-ietf-ppsp-base-tracker-protocol-07.txt

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Sun, 4 Jan 2015 03:03:22 +0000

Hi Haibin,

Thanks for the careful review. We'll fix them in the next version which will be submitted in next few days.

BR,
Rachel

> -----Original Message-----
> From: ppsp [mailto:[email-masked]] On Behalf Of Songhaibin (A)
> Sent: Wednesday, December 31, 2014 4:13 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [ppsp] I-D Action: draft-ietf-ppsp-base-tracker-protocol-07.txt
> 
> Thanks to the authors for the update. And here are some proposed changes to
> the json text after a glance at the draft.
> 
> 
> 1.  "struct" should be changed to object. For example, change:
> 
>  struct {
>               s1  e1;
>               s2  e2;
>               ...
>               sn  en;
>       } type_name;
> 
> to
> 
> object {
>               s1  e1;
>               s2  e2;
>               ...
>               sn  en;
>  } type_name;
> 
> 2.	Do not use "enum" type, and change to others instead, due to there's no
> enum type in JSON language.
> 3.	the version of "ppsp_tp_version_t" should be registered in IANA?
> 
> 4. You might change:
> Object {
>               ppsp_tp_stat_type_t  type;
>               union {
>                      Object {
>                              ppsp_tp_string_t  swarm_id;
>                              ppsp_tp_integer_t  uploaded_bytes;
>                              ppsp_tp_integer_t  downloaded_bytes;
>                              ppsp_tp_integer_t  available_bandwidth;
>                          } stream_stats;
>               } stat_data;
> 	      } ppsp_tp_stat_t;
> 
> to:
> 
>          Object {
>                   ppsp_tp_string_t  swarm_id;
>                   ppsp_tp_integer_t  uploaded_bytes;
>                   ppsp_tp_integer_t  downloaded_bytes;
>                   ppsp_tp_integer_t  available_bandwidth;
>                 } stream_stats;
> 
>          Object {
>                   ppsp_tp_stat_type_t  type;
>                   stream_stats str_stats_value;
>               } stat_data;
> 
> 
> 5.	suggest to change media type "application/ppsp+json" to
> "application/ppsptracker+json"
> 6.	The examples in Section 6 seems inconsistent with the data structures in
> Section 4. They should be fixed.
> 
> Best Regards!
> -Haibin
> 
> 
> > -----Original Message-----
> > From: ppsp [mailto:[email-masked]] On Behalf Of
> > [email-masked]
> > Sent: Friday, December 12, 2014 9:33 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: [ppsp] I-D Action:
> > draft-ietf-ppsp-base-tracker-protocol-07.txt
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> >  This draft is a work item of the Peer to Peer Streaming Protocol
> > Working Group of the IETF.
> >
> >         Title           : PPSP Tracker Protocol-Base Protocol
> (PPSP-TP/1.0)
> >         Authors         : Rui Santos Cruz
> >                           Mario Serafim Nunes
> >                           Gu Yingjie
> >                           Jinwei Xia
> >                           Rachel Huang
> >                           Joao P. Taveira
> >                           Deng Lingli
> > 	Filename        : draft-ietf-ppsp-base-tracker-protocol-07.txt
> > 	Pages           : 56
> > 	Date            : 2014-12-11
> >
> > Abstract:
> >    This document specifies the base Peer-to-Peer Streaming Protocol-
> >    Tracker Protocol (PPSP-TP/1.0), an application-layer control
> >    (signaling) protocol for the exchange of meta information between
> >    trackers and peers.  The specification outlines the architecture of
> >    the protocol and its functionality, and describes message flows,
> >    message processing instructions, message formats, formal syntax and
> >    semantics.  The PPSP Tracker Protocol enables cooperating peers to
> >    form content streaming overlay networks to support near real-time
> >    Structured Media content delivery (audio, video, associated timed
> >    text and metadata), such as adaptive multi-rate, layered (scalable)
> >    and multi-view (3D) videos, in live, time-shifted and on-demand
> >    modes.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-ppsp-base-tracker-protocol
> > /
> >
> > There's also a htmlized version available at:
> > http://tools.ietf.org/html/draft-ietf-ppsp-base-tracker-protocol-07
> >
> > A diff from the previous version is available at:
> > http://www.ietf.org/rfcdiff?url2=draft-ietf-ppsp-base-tracker-protocol
> > -07
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > ppsp mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ppsp
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Roni Even" <[email-masked]>
Date: Sun, 4 Jan 2015 17:49:24 +0200

Hi,
I reviewed this version and have no comments
Regards
Roni

> From: ppsp [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: 12 December, 2014 3:33 AM
> Subject: [ppsp] I-D Action: draft-ietf-ppsp-base-tracker-protocol-07.txt
> 
> 
>  This draft is a work item of the Peer to Peer Streaming Protocol Working
> Group of the IETF.
> 
(PPSP-TP/1.0)
> https://datatracker.ietf.org/doc/draft-ietf-ppsp-base-tracker-protocol/
> 
> http://www.ietf.org/rfcdiff?url2=draft-ietf-ppsp-base-tracker-protocol-07
> 
> 
submission
> until the htmlized version and diff are available at tools.ietf.org.
>