Subject: RE: some comments on draft-ietf-psamp-framework-09.txt

From: <[email-masked]>
Date: Mon, 29 Nov 2004 12:02:33 -0500

> Do we have to say that a hash approximates uniform random sampling?  It does, most of the time, but it's tough to beat uniform random > sampling and with insider information one could defeat a hash.  

I think approximation is a reasonable term, since an approximation can be close or not. The security and robustness issues are discussed more fully in the sampling techniques draft. But to give a flavor of what is needed to avoid the problem you mention, I propose adding a sentence to the framework draft"

"Privacy of hash selection range and hash function parameters (although not the hash function itself) obstruct subversion of the selector by packets that are crafted either to avoid selection or to be selected"

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: Derek Chiou <[email-masked]>
Date: Tue, 30 Nov 2004 00:38:14 -0500

Hi Nick,

Your additional sentence looks good.

Thanks.

Derek