Subject: RE: [ippm] comments on draft-morton-ippm-composition-00.txt

From: "STEPHAN Emile RD-CORE-LAN" <[email-masked]>
Date: Tue, 9 Aug 2005 17:43:22 +0200

Hi Al,

How do we arrange the way the contribution to the composition draft ?
As a first step, to prepare the version 01 of the draft I propose to send you my definitions of composition metrics. 

Regarding passive metrics, I will propose a definition of a passive one way delay metric based on the Type-P-Spatial-One-way-Delay-Stream defined in draft-stephan-ippm-multimetrics-01.txt.

Regards
Emile

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Maurizio Molina
> Envoyé : mardi 9 août 2005 16:53
> À : [email-masked]
> Objet : [ippm] comments on draft-morton-ippm-composition-00.txt
> 
> Hi Al,
> some comments on your draft:
> 
> - sec 3.1:
> ...This means that the complete path metric may be composed from:
> 
>     +  the same metric for each sub-path
> 
>     +  multiple metrics for each sub-path (possibly one that is the same
> 
>       as the complete path metric)
> 
>     +  a single sub-path metrics that is different from the complete
> 
>       path metric
> 
> =>Comment: I understand the first example, not the other two. Shouldn't
> we stick, for simplicity, to the first case?
> 
> - sec. 3.2:
> For each metric, the applicable circumstances are defined, in terms of
> whether the composition:
> Requires the same test packets to traverse all sub-paths, or may use
> similar packets sent and collected separately in each sub-path.
> 
> => Comment: I think the sentence brings some confusion, mixing
> de-composition and composition. The draft should focus on composition
> only, and should say it explicitly. Also, by mentioning test packets you
> seem to limit to active measurements, whereas in other parts of the
> draft you leave the door open to passive measurement as well.
> 
> - Sec. 4:
> One-way Delay Composition Metrics and Statistics
> 
> => Comment: Shouldn't it read "Composition of One-way Delay Metrics and
> Statistics"?
> 
> - Sec. 4.1.8
> "...Therefore, the sub-path measurements may differ   from the performance
> experienced by packets on the complete path. Measurements employing
> sufficient sub-path address pairs mightproduce bounds on the extent of
> this error."
> 
> => Comment: Not sure what you mean by "sufficient sub-path address
> pairs". I think this is however a delicate point and Lei's concerns, if
> I understood well, were also about this. Could you clarify?
> 
> 
> Thanks,
> Maurizio
> 
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ippm

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: Al Morton <[email-masked]>
Date: Tue, 16 Aug 2005 15:47:52 -0400

Hi Emile,

At 11:43 AM 8/9/2005, STEPHAN Emile RD-CORE-LAN wrote:
>As a first step, to prepare the version 01 of the draft I propose to send 
>you my definitions of composition metrics.

Let's try that.  If you can follow the outline
I used for the example that is already in the draft,
that would be good.

>Regarding passive metrics, I will propose a definition of a passive one 
>way delay metric based on the Type-P-Spatial-One-way-Delay-Stream defined 
>in draft-stephan-ippm-multimetrics-01.txt.
OK.

Al