Subject: RE: [ippm] comments on draft-morton-ippm-composition-00.txt

From: Al Morton <[email-masked]>
Date: Sun, 21 Aug 2005 11:02:42 -0400

Hi Roman,

Thanks for your comments, see initial responses below:

At 06:32 PM 8/17/2005, [email-masked] wrote:
>Al
>
>My few thoughts:
>
>(1) regarding the delay variation metric
>would we follow the ITU proposal or 2 point IPPM definition .. what would
>be our preference?
>My initial take on the ITU  delay variation proposal is negative. It is
>different from MEF and from what we already use
>as well as it is not very practical - my view..
>can we have a discussion on it?

We've had some good discussions comparing these metrics on ippm-list
(my guess is that the 2001 archive has most of the exchange).
It's worthwhile pointing out that when one of the selected packets in
the pair (as in RFC3393) is always the packet with the minimum delay,
the IPPM and ITU definitions are equivalent.  I don't know if the same
flexibility exists in the MEF definition.  In any case, we have the
freedom to consider both in this effort, and I suggest we do just that.

Personally, I think we may have more success with compositions of the
ITU-T delay histogram.  The traditional version of IPPM's
adjacent packet pair metric depends on packet spacing, and
that may make compositions more challenging, somewhat like reordering.

>(2) I can draft  the availability and packet loss metric section , is this
>OK with you. I am not sure how far you are on it

I have some material on Loss already, so start with availability.
(I'll send you a template to make things easier.)
What IPPM (or ITU) metric will you start with to compose availability?

>(3) We need some generic definition of the composite metric itself - my
>view:

Thanks, I'll look at working these ideas into the draft.  Clearly we need
a new section containing definitions. I also like some of the
definitions composed by Andreas Åkre Solberg.  This topic really seems
to be of wide interest...

Al

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: "Robert Holley \(rholley\)" <[email-masked]>
Date: Wed, 24 Aug 2005 13:45:06 -0400

Al,
Roman,

I've been (rather passively) monitoring the list's discussions on this subject.

However, I didn't see any responses on the availability metric mentioned below.

Have I missed it, or am I just jumping ahead?

Regards
Bob 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Al Morton
> Sent: Sunday, August 21, 2005 11:03 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [ippm] comments on draft-morton-ippm-composition-00.txt
> 
> Hi Roman,
> 
> _______________________________________________
> ippm mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/ippm
>