Subject: RE: Measurement Process -> Metering Process

From: "Thomas Dietz" <[email-masked]>
Date: Wed, 21 Dec 2005 16:48:30 +0100

Hi Juergen and Benoit,

I support Juergens view. Its consistent with IPFIX and thus easier to
understand for those who already implemented IPFIX (which I guess will be
the majority).

Thomas

-- 
Thomas Dietz                       E-mail: [email-masked]
Network Laboratories               Phone:  +49 6221 90511-28
NEC Europe Ltd.                    Fax:    +49 6221 90511-55
Kurfuersten-Anlage 36
69115 Heidelberg, Germany          http://www.netlab.nec.de

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juergen Quittek
> Sent: Wednesday, December 21, 2005 12:24 PM
> To: Benoit Claise
> Cc: psamp
> Subject: Re: Measurement Process -> Metering Process
> 
> --On 21.12.2005 11:37 Uhr +0100 Benoit Claise wrote:
> 
> > Juergen Quittek wrote:
> >
> > Hi Benoit,
> >
> > Thanks for elaborating this change.
> > Please find a comment in line.
> >
> > --On 19.12.2005 17:28 Uhr +0100 Benoit Claise wrote:
> >
> >
> > Dear all,
> >
> > I applied the editorial changes.
> >
> > 1. I deleted the definition of "Reporting Process"
> > 2. I removed/replaced all remaining occurrence of 
> "Reporting Process"
> >     btw, as a consequence, I updated the definitions of 
> "packet report", "report interpretation", "report stream"
> > 3. I deleted the definition of "Measurement Process"
> > 4. I modified all remaining occurrence of "Measurement 
> Process" by "Selection Process"
> >    btw, as a consequence, I modified the definitions of 
> "Exporting Process"
> >    I also modified the different requirements from 
> [PSAMP-FMWK] that I was quoting in section 6.
> >    As a consequence, [PSAMP-FMWK] will have to be updated 
> accordingly.
> >
> > Then, the figure becomes.
> >
> >
> >                +---------+      +---------+
> >      Observed  |Selection|      |Exporting|
> >      Packet--->|Process  |----->|Process  |--->Collector
> >      Stream    +---------+      +---------+
> >               \--Metering-/
> >                \-Process-/
> >
> >      Figure B: PSAMP Processes
> >
> >
> > Shouldn't it be just
> >
> >               +---------+      +---------+
> >     Observed  |Metering |      |Exporting|
> >     Packet--->|Process  |----->|Process  |--->Collector
> >     Stream    +---------+      +---------+
> >
> > ?
> 
> I would use this figure for showing consistency with IPFIX.
> We can explain in the text that the metering process contains
> a selection process (as it does in IPFIX).
> 
> Thanks,
> 
>     Juergen
> 
> > Personally, this is what I would prefer. It makes more sense.
> > However, I was perfectly clear on the conclusions from the 
> meeting in Vancouver (this is reason why I started this thread)
> > From the meeting minutes at 
> http://www3.ietf.org/proceedings/05nov/minutes/psamp.txt
> >
> > Open Issue (not numbered): Terminology Metering Process (IPFIX) vs.
> > Measurement Process(PSAMP)
> > Terminology problem: When psamp started it wasn't clear 
> that ipfix would be
> > chosen for export, the architecture is similar but still 
> different. What IPFIX
> > calls "metering" is defined as "measurement" in PSAMP terminology.
> > Juergen: Let's use term "metering" for both. Shall we also 
> drop terms
> > "selection process" and "reporting process"?
> > Tanja: Keep selection process as part of metering process 
> (is in line with
> > IPFIX, because metering process can contain sampling/filtering). But
> > selection process should be kept.
> > Nick: I agree.
> > Juergen: The changes need to be applied also to the 
> framework draft and the
> > packet selection draft that are currently in AD review.
> >
> >
> > Juergen, I would be perfectly happy to edit the diagram as 
> you draw it.
> >
> > Regards, Benoit.
> >
> >
> >
> >
> >
> >
> > The same steps from 1 to 4 will have to be executed for 
> [PSAMP-FMWK] and [PSAMP-TECH]. Alternatively, you might copy 
> the new definitions from the next [PSAMP-PROTO] version.
> >
> > Regards, Benoit.
> >
> >
> >  Dear all,
> >
> > Do I understand correctly from the meeting minutes (below) 
> that we get rid of the Reporting Process.
> >
> >
> >
> > Open Issue (not numbered): Terminology Metering Process (IPFIX) vs.
> >   Measurement Process(PSAMP)
> > Terminology problem: When psamp started it wasn't clear 
> that ipfix would be
> > chosen for export, the architecture is similar but still 
> different. What IPFIX
> > calls "metering" is defined as "measurement" in PSAMP terminology.
> > Juergen: Let's use term "metering" for both.  Shall we also 
> drop terms
> >   "selection process" and "reporting process"?
> > Tanja: Keep selection process as part of metering process 
> (is in line with
> >   IPFIX, because metering process can contain 
> sampling/filtering).  But
> >   selection process should be kept.
> > Nick: I agree.
> > Juergen: The changes need to be applied also to the 
> framework draft and the
> >   packet selection draft that are currently in AD review.
> >
> >
> > Without objections, I will be removing the concept of 
> Reporting Process in [PSAMP-PROTO].
> > Anyway, we don't need it in the protocol.
> >
> > Regards, Benoit.
> >
> >
> >
> >
> > Tanja, Nick, and al.
> >
> > Regarding the "Measurement Process -> Metering Process" 
> issue discussed during the IETF meeting, I understand that:
> > - the Measurement Process definition disappears
> > - we replace all instances of Measurement Process by 
> (IPFIX) Metering Process
> > - we keep the Selection Process
> >
> > I was not too clear about the following point:
> > - do we keep the Reporting Process?
> >    There is actually no information about it (no such thing 
> such as Reporting Process ID)
> >    This is just a concept, right?
> >
> > Regards, Benoit.
> >
> >
> > --
> > to unsubscribe send a message to [email-masked] with
> > the word 'unsubscribe' in a single line as the message text body.
> > archive: <http://ops.ietf.org/lists/psamp/>
> >
> >
> >
> >
> >
> >
> >
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/psamp/>
>

---

From: Benoit Claise <[email-masked]>
Date: Wed, 21 Dec 2005 16:52:14 +0100

Hi Thomas,

Very good. Below is the new proposal.

Regards, Benoit.

    The figure B indicates the sequence of the processes (selection and
    exporting) within the PSAMP Device.
         
                          +----------+      +-----------+
         Observed  | Metering |         | Exporting |
         Packet--->| Process  |----->| Process   |--->Collector  
         Stream     +----------+       +-----------+ 

    The Selection Process, which takes an Observed Packet Stream as its
    input, and produces Packet Reports as its output, is an integral
    part of the Metering Process, which by its definition, produces Flow
    Records as its output.

---

From: Tanja Zseby <[email-masked]>
Date: Thu, 22 Dec 2005 13:19:49 +0100

Hi Benoit,

I also support this. If the metering process contains the selection 
process this is also fully in line with IPFIX.

Regards
Tanja

-- 
Dipl.-Ing. Tanja Zseby			    	      	
Fraunhofer Institute FOKUS			Email: [email-masked]	
Kaiserin-Augusta-Allee 31			Phone: +49-30-3463-7153
D-10589 Berlin, Germany				Fax:   +49-30-3463-8153
-------------------------------------------------------------------------------------- 
"Living on earth is expensive but it includes a free trip around the sun." (Anonymous)
--------------------------------------------------------------------------------------