Subject: Re: Measurement Process -> Metering Process

From: Benoit Claise <[email-masked]>
Date: Thu, 08 Dec 2005 12:52:22 +0100

Dear all,

Do I understand correctly from the meeting minutes (below) that we get 
rid of the Reporting Process.

    Open Issue (not numbered): Terminology Metering Process (IPFIX) vs. 
      Measurement Process(PSAMP)
    Terminology problem: When psamp started it wasn't clear that ipfix would be 
    chosen for export, the architecture is similar but still different. What IPFIX 
    calls "metering" is defined as "measurement" in PSAMP terminology. 
    Juergen: Let's use term "metering" for both.  Shall we also drop terms 
      "selection process" and "reporting process"?
    Tanja: Keep selection process as part of metering process (is in line with 
      IPFIX, because metering process can contain sampling/filtering).  But 
      selection process should be kept. 
    Nick: I agree.
    Juergen: The changes need to be applied also to the framework draft and the
      packet selection draft that are currently in AD review.

Without objections, I will be removing the concept of Reporting Process 
in [PSAMP-PROTO].
Anyway, we don't need it in the protocol.

Regards, Benoit.

> Tanja, Nick, and al.
>
> Regarding the "Measurement Process -> Metering Process" issue 
> discussed during the IETF meeting, I understand that:
> - the Measurement Process definition disappears
> - we replace all instances of Measurement Process by (IPFIX) Metering 
> Process
> - we keep the Selection Process
>
> I was not too clear about the following point:
> - do we keep the Reporting Process?
>    There is actually no information about it (no such thing such as 
> Reporting Process ID)
>    This is just a concept, right?
>
> Regards, Benoit.
>  
>
> -- 
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/psamp/>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 19 Dec 2005 17:28:11 +0100

Dear all,

I applied the editorial changes.

1. I deleted the definition of "Reporting Process"
2. I removed/replaced all remaining occurrence of "Reporting Process"
    btw, as a consequence, I updated the definitions of "packet report", 
"report interpretation", "report stream"
3. I deleted the definition of "Measurement Process"
4. I modified all remaining occurrence of "Measurement Process" by 
"Selection Process"
   btw, as a consequence, I modified the definitions of "Exporting Process"
   I also modified the different requirements from [PSAMP-FMWK] that I 
was quoting in section 6.
   As a consequence, [PSAMP-FMWK] will have to be updated accordingly.

Then, the figure becomes.

               +---------+      +---------+ 
     Observed  |Selection|      |Exporting| 
     Packet--->|Process  |----->|Process  |--->Collector   
     Stream    +---------+      +---------+  
              \--Metering-/
               \-Process-/ 

     Figure B: PSAMP Processes

The same steps from 1 to 4 will have to be executed for [PSAMP-FMWK] and 
[PSAMP-TECH]. Alternatively, you might copy the new definitions from the 
next [PSAMP-PROTO] version.

Regards, Benoit.

> Without objections, I will be removing the concept of Reporting 
> Process in [PSAMP-PROTO].

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 21 Dec 2005 09:57:45 +0100

Hi Benoit,

Thanks for elaborating this change.
Please find a comment in line.

--On 19.12.2005 17:28 Uhr +0100 Benoit Claise wrote:

>     btw, as a consequence, I updated the definitions of "packet report", "report interpretation", "report stream"
> 4. I modified all remaining occurrence of "Measurement Process" by "Selection Process"
>    I also modified the different requirements from [PSAMP-FMWK] that I was quoting in section 6.

Shouldn't it be just

               +---------+      +---------+
     Observed  |Metering |      |Exporting|
     Packet--->|Process  |----->|Process  |--->Collector
     Stream    +---------+      +---------+

?

    Juergen

> The same steps from 1 to 4 will have to be executed for [PSAMP-FMWK] and [PSAMP-TECH]. Alternatively, you might copy the new definitions from the next [PSAMP-PROTO] version.
>
> Regards, Benoit.
>
>
>  Dear all,
>
> Do I understand correctly from the meeting minutes (below) that we get rid of the Reporting Process.
>
>
>
> Without objections, I will be removing the concept of Reporting Process in [PSAMP-PROTO].
> Regarding the "Measurement Process -> Metering Process" issue discussed during the IETF meeting, I understand that:
> - we replace all instances of Measurement Process by (IPFIX) Metering Process
>    There is actually no information about it (no such thing such as Reporting Process ID)

---

From: Benoit Claise <[email-masked]>
Date: Wed, 21 Dec 2005 11:37:38 +0100

Juergen Quittek wrote:
>>     btw, as a consequence, I updated the definitions of "packet 
>> report", "report interpretation", "report stream"
Personally, this is what I would prefer. It makes more sense.
However, I was perfectly clear on the conclusions from the meeting in 
Vancouver (this is reason why I started this thread)
 From the meeting minutes at 
http://www3.ietf.org/proceedings/05nov/minutes/psamp.txt

    Open Issue (not numbered): Terminology Metering Process (IPFIX) vs.
    Measurement Process(PSAMP)
    Terminology problem: When psamp started it wasn't clear that ipfix
    would be
    chosen for export, the architecture is similar but still different.
    What IPFIX
    calls "metering" is defined as "measurement" in PSAMP terminology.
    Juergen: Let's use term "metering" for both. Shall we also drop terms
    "selection process" and "reporting process"?
    Tanja: Keep selection process as part of metering process (is in
    line with
    IPFIX, because metering process can contain sampling/filtering). But
    selection process should be kept.
    Nick: I agree.
    Juergen: The changes need to be applied also to the framework draft
    and the
    packet selection draft that are currently in AD review.

Juergen, I would be perfectly happy to edit the diagram as you draw it.

Regards, Benoit.

>
>> The same steps from 1 to 4 will have to be executed for [PSAMP-FMWK] 
>> and [PSAMP-TECH]. Alternatively, you might copy the new definitions 
>> from the next [PSAMP-PROTO] version.
>>
>> Regards, Benoit.
>>
>>
>>  Dear all,
>>

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 21 Dec 2005 12:23:36 +0100

> Then, the figure becomes.

I would use this figure for showing consistency with IPFIX.
We can explain in the text that the metering process contains
a selection process (as it does in IPFIX).

Thanks,

    Juergen

> However, I was perfectly clear on the conclusions from the meeting in Vancouver (this is reason why I started this thread)
> From the meeting minutes at http://www3.ietf.org/proceedings/05nov/minutes/psamp.txt
>