Subject: Open Issue 5: PSAMP transport protocol

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Dec 2005 14:50:09 +0100

Dear all,

The PSAMP open issue 5 is the following:
Transport protocol: SCTP and/or UDP and/or TCP. Nothing is mentioned at 
this stage. [PSAMP-FMWK] and PSAMP charter specifically mention UDP.

Currently, we don't mention anything regarding the transport protocol 
selection in [PSAMP-PROTO].
However, I think that we don't need to specify anything as we have this 
sentence in the draft:
    "The entire IPFIX protocol specifications [IPFIX-PROTO] MUST be 
implemented for the PSAMP export."
This allows the same transport  protocol choices as specified in 
[IPFIX-PROTO].

Please let me know if you disagree.

Regards, Benoit.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: "Thomas Dietz" <[email-masked]>
Date: Fri, 23 Dec 2005 13:44:35 +0100

Benoit,

I think, with the mentioned sentence we cover everything because we have
IPFIX as basis...

Regards,

Thomas

-- 
Thomas Dietz                       E-mail: [email-masked]
Network Laboratories               Phone:  +49 6221 90511-28
NEC Europe Ltd.                    Fax:    +49 6221 90511-55
Kurfuersten-Anlage 36
69115 Heidelberg, Germany          http://www.netlab.nec.de

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Benoit Claise
> Sent: Tuesday, December 20, 2005 2:50 PM
> To: psamp
> Subject: Open Issue 5: PSAMP transport protocol 
> 
> Dear all,
>

---

From: <[email-masked]>
Date: Fri, 23 Dec 2005 13:14:39 -0500

Benoit,

> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Benoit Claise
> Sent: Tuesday, December 20, 2005 8:50 AM
> To: psamp

Requiring implementation of the entire IPFIX protocol is stronger than
requiring the same transport protocol choices. 

According to [PSAMP-FMWK], not all of IPFIX need be implemented, see
Section 8.1: 
	"On the other 
      hand, not all features of the IPFIX protocol will need to be 
      implemented by some PSAMP devices. For example, a device that 
      offers only content-independent sampling and basic PSAMP 
      reporting has no need to support IPFIX capabilities based on 
      packet fields."

Nick