Subject: Open Issue 6: Associations ID -> Selection Path

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Dec 2005 15:35:40 +0100

Dear all,

The PSAMP open issue 6 is the following:

    Even if the notion of Associations ID is mentioned in [PSAMP-TECH],
    maybe a term such as SelectionPath or PathID would be more appropriate.

The background of this issue is the following.
[PSAMP-TECH] specifies the Associations ID like this:

    ASSOCIATIONS 
     
    Values: <STREAM ID, IPFIX Metering process ID, IPFIX Exporting 
    process ID, IDs of other associated processes> 
    With STREAM ID: Observation point ID AND List of SELECTOR_IDs 

However, we concluded during the last IETF meeting that we don't need 
the IPFIX Metering and Exporting Process ID.
So we're left with:

    Values: <Observation point ID, List of SELECTOR_IDs>

Since we don't associate anymore the observation point with processes, it was proposed to change the name:
from "Associations ID" to "Selection Path" or "Path ID".

Personally, I prefer the Selection Path term, along with the selectionPath I.E.
For the simple reason that we speak of selection methods all over in the PSAMP drafts.

Feedback?

Regards, Benoit.

---

From: Tanja Zseby <[email-masked]>
Date: Thu, 22 Dec 2005 13:04:55 +0100

Hi Benoit,

I also prefer Selection Path.

Kind regards,
Tanja

Benoit Claise wrote:

>    ASSOCIATIONS        Values: <STREAM ID, IPFIX Metering process ID, 
> IPFIX Exporting    process ID, IDs of other associated processes>    

-- 
Dipl.-Ing. Tanja Zseby			    	      	
Fraunhofer Institute FOKUS			Email: [email-masked]	
Kaiserin-Augusta-Allee 31			Phone: +49-30-3463-7153
D-10589 Berlin, Germany				Fax:   +49-30-3463-8153
-------------------------------------------------------------------------------------- 
"Living on earth is expensive but it includes a free trip around the sun." (Anonymous)
--------------------------------------------------------------------------------------

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 23 Dec 2005 00:09:40 +0100

Ok, I made the modifications for the new draft that I will be posting soon.

Regards, Benoit.
>> Since we don't associate anymore the observation point with 
>> processes, it was proposed to change the name: