Subject: PSAMP IANA considerations section

From: Benoit Claise <[email-masked]>
Date: Wed, 21 Dec 2005 11:14:56 +0100

Dear all,

Here is a proposal for the IANA considerations section.

1. 9. IANA Considerations

The PSAMP Protocol, as set out in this document, has two sets of 
assigned numbers.  Considerations for assigning them are discussed in 
this section, using the example policies as set out in the "Guidelines 
for IANA Considerations" document IANA-RFC [RFC2434].

     9.1 IPFIX Related Considerations

As the PSAMP protocol uses the IPFIX protocol, refer to the IANA 
considerations section in [IPFIX-PROTO] for the assignments of numbers 
used in the protocol and for the numbers used in the information model.

      9.2 PSAMP Related Considerations

Each new selection method MUST be assigned a unique value for the 
selectorAlgorithm Information Element.  Its configuration parameter(s), 
along with the way to report it/them with an Options Template, MUST be 
clearly specified.

Each new selection method MUST be assigned a unique value for the 
selectorAlgorithm Information Element.  New assignments for the PSAMP 
selection method will be administered by IANA, on a First Come First 
Served basis [RFC 2434], subject to Expert Review [RFC 2434], i.e. 
review by one of a group of experts designated by an IETF Operations and 
Management Area Director.  The group of experts must double check the 
Information Elements definitions with already defined Information 
Elements for completeness, accuracy and redundancy.  Those experts will 
initially be drawn from the Working Group Chairs and document editors of 
the IPFIX and PSAMP Working Groups.

Now, two questions:
1. I'm not too sure whether we should mandate a new IETF RFC for the new 
selection method description?
2. I'm not too sure whether we should mandate new IANA-registered 
information elements for the new selection method?
    In other words, can we have proprietary selection method in the 
selectorAlgorithm Information Element?

Regards, Benoit.

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 23 Dec 2005 13:15:58 +0100

--On 21.12.2005 11:14 Uhr +0100 Benoit Claise wrote:

> The PSAMP Protocol, as set out in this document, has two sets of assigned numbers.  Considerations for assigning them are discussed in this section, using the example policies as set out in the "Guidelines for IANA Considerations" document IANA-RFC
> [RFC2434].
>
> As the PSAMP protocol uses the IPFIX protocol, refer to the IANA considerations section in [IPFIX-PROTO] for the assignments of numbers used in the protocol and for the numbers used in the information model.
>
> Each new selection method MUST be assigned a unique value for the selectorAlgorithm Information Element.  Its configuration parameter(s), along with the way to report it/them with an Options Template, MUST be clearly specified.
>
> Each new selection method MUST be assigned a unique value for the selectorAlgorithm Information Element.  New assignments for the PSAMP selection method will be administered by IANA, on a First Come First Served basis [RFC 2434], subject to Expert
> Review [RFC 2434], i.e. review by one of a group of experts designated by an IETF Operations and Management Area Director.  The group of experts must double check the Information Elements definitions with already defined Information Elements for
> completeness, accuracy and redundancy.  Those experts will initially be drawn from the Working Group Chairs and document editors of the IPFIX and PSAMP Working Groups.
>
> Now, two questions:
> 1. I'm not too sure whether we should mandate a new IETF RFC for the new selection method description?

This would be a tough requirement.  However, it would make sure that the
new methods is well documented.

> 2. I'm not too sure whether we should mandate new IANA-registered information elements for the new selection method?

Since we do not have vendor IDs in here, this is the only way of achieving
interoperability.

>     In other words, can we have proprietary selection method in the selectorAlgorithm Information Element?

Can't we assign an interval, say [1024 - ...] and declare selection methods
with identifiers in that interval as 'experimental' or even 'implementation specific'?

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>