Subject: [quicwg/base-drafts] Some questions about Packet Number Encoding And Decoding (#3002)

From: Ainiroad <[email-masked]>
Date: Mon, 02 Sep 2019 19:10:18 -0700

Thank you guys a lot! I have some questions about Packet Number Encoding And Decoding

In transport draft Section `17.1. Packet Number Encoding and Decoding`
>For example, if an endpoint has received an acknowledgment for packet 0xabe8bc, sending a packet with a number of 0xac5c02 requires a packet number encoding with 16 bits or more; whereas the 24-bit packet number encoding is needed to send a packet with a number of 0xace8fe.

1. What's the purpose of Packet Number Encoding? to be safe or save some bits space or something else?

> A peer receiving the packet will then correctly decode the packet number, unless the packet is delayed in transit such that it arrives after many higher-numbered packets have been received. An endpoint SHOULD use a large enough packet number encoding to allow the packet number to be recovered even if the packet arrives after packets that are sent afterwards.

2. How can an endpoint know to use a large enough packet number encoding? For example, as example 1 said, an endpoint can send 16 bits to send a number of 0xac5c02 if peer has received an acknowledgment for packet 0xabe8bc, which means it will send 0x5c02. So in the early time when it want to send 0x5c02 exactly(not 0xac5c02), How should it encode packet number to avoid conflict with 0xac5c02 if the packet is delay so much.

3. If an endpoint is not encoded packet number well, the peer will recover it as a wrong packet number, what happens next?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3002

---

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Sep 2019 19:14:49 -0700

@Ainiroad I'd like to request that you take these questions to our [mailing list](mailto:[email-masked]).  This issue list really isn't the best place for this sort of query.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3002#issuecomment-527277703

---

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Sep 2019 19:14:52 -0700

Closed #3002.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3002#event-2602059259

---

From: Ainiroad <[email-masked]>
Date: Mon, 02 Sep 2019 19:16:42 -0700

Sorry for that!
Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3002#issuecomment-527278036

---

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Sep 2019 19:29:09 -0700

No worries.  As [our contributing doc](https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md) says, we use this to track issues, not as a general discussion forum.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3002#issuecomment-527280177