Subject: Re: [quicwg/base-drafts] Skip a packet number when sending one PTO packet (#2952)

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Sep 2019 15:26:07 -0700

This is a clever idea, but I don't think that we want to write it down in the spec. It's allowed by the spec, so people can surely do it, but we are talking about immediate ACK signaling in other ways too, and I don't think we want to encourage this behavior.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-530144296

---

From: chumd <[email-masked]>
Date: Thu, 12 Sep 2019 04:38:59 -0700

Thats brialliant idialistic for futured company soon.......

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-530786096

---

From: Marten Seemann <[email-masked]>
Date: Thu, 12 Sep 2019 04:46:07 -0700

@chumd
> Thats brialliant idialistic for futured company soon.......

Yeah, it's incredible how much money they will make by skipping packet numbers. If I had just known about this before...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-530788310

---

From: chumd <[email-masked]>
Date: Thu, 12 Sep 2019 07:40:27 -0700

think think thinking..........fzcash.io/community .
  Dollar...they're??going travel meeting community to personally deploying the  big even/......   coinbase/lokally wallet etc check backgroundLy/TransaCtion
Er20 looked it.....after making youre reporting blog/hub.com....../  goodnight still working tomrrow @ dawn..ethe  requesting passward  to proving transaction /wasnt

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-530857413

---

From: chumd <[email-masked]>
Date: Thu, 12 Sep 2019 07:47:45 -0700

Like what i said  for the biggest  even i deploying personally for zcash foundation/community.
Need to paying laptop thats reason personally employed @company..no support
No earning no dollar/comments 40%...thats TRUE 100%

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-530860816

---

From: ianswett <[email-masked]>
Date: Fri, 13 Sep 2019 08:19:46 -0700

I'm going to run an experiment comparing 1 PTO packet, 2 PTO packets, and 1 with skipping a packet number and report back the results.  If the results are good enough with 1PTO + gap, we can consider whether this is an optimization worth mentioning.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-531279851

---

From: ianswett <[email-masked]>
Date: Fri, 13 Sep 2019 08:19:47 -0700

Closed #2952.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#event-2632699273

---

From: MikkelFJ <[email-masked]>
Date: Fri, 13 Sep 2019 08:59:03 -0700

Can also test this both sides at the same time? I'm still concerned this might run away in ACK floods.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#issuecomment-531294213