Subject: [quicwg/base-drafts] Original/Initial Connection ID (#3011)

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Sep 2019 17:29:37 -0700

The connection ID that the client chooses for the Destination Connection ID hold special status.  It is used for source address validation for servers that send Retry or Version Negotiation, it determines the packet protection keys for Initial packets, and it is used to validate the Retry.

If we go with #2878 (which isn't yet decided, but seems plausible) then we have an opportunity to revisit this naming.  The name "original" was chosen to distinguish this connection ID from the one that was in other Initial packets, as the value wasn't the same for all Initial packets and the packet protection keys were also consistent.  Using "initial" might be feasible if the packet protection keys are all based on this one value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3011

---

From: MikkelFJ <[email-masked]>
Date: Mon, 09 Sep 2019 21:42:34 -0700

See also https://github.com/quicwg/base-drafts/issues/2926

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3011#issuecomment-529766760