Subject: [quicwg/base-drafts] Changelog for transport-23 (#3019)

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Sep 2019 18:39:45 -0700

Someone already did TLS for me.

I put the major wire-format change first.  ekr likes the idea of marking such things as &quot;special&quot;, but I don&#39;t subscribe to that theory.  This is all important.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3019

-- Commit Summary --

  * Changelog for transport-23

-- File Changes --

    M draft-ietf-quic-transport.md (32)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3019.patch
https://github.com/quicwg/base-drafts/pull/3019.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Sep 2019 19:25:32 -0700

janaiyengar commented on this pull request.

> +- A maximum ACK delay of 0 is used for handshake packet number spaces (#2646,
+  #2638)
+- Improved rules for use of congestion control state on new paths (#2685, #2918)
+- PATH_RESPONSE frames are not sent again if lost (#2724, #2729)
+- Removed recommendation to coordinate spin for multiple connections that share
+  a path (#2763, #2882)
+- Allow smaller stateless resets and recommend a smaller minimum on packets
+  that might trigger a stateless reset (#2770, #2869, #2927)
+- Provide guidance around the interface to QUIC as used by application protocols
+  (#2805, #2857)
+- Frames other than STREAM can cause STREAM_LIMIT_ERROR (#2825, #2826)
+- Tighter rules about processing of rejected 0-RTT packets (#2829, #2840, #2841)
+- Explanation of the effect of Retry on 0-RTT packets (#2842, #2852)
+- Cryptographic handshake needs to provide server transport parameter encryption
+  (#2920, #2921)
+

If #2916 is merged,
- Moved guidance around ACK generation from recovery draft to here (#2916).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019#pullrequestreview-286525951

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Sep 2019 19:25:39 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019#pullrequestreview-286525980

---

From: Marten Seemann <[email-masked]>
Date: Tue, 10 Sep 2019 19:53:43 -0700

marten-seemann requested changes on this pull request.

Not a comprehensive review. If I remember correctly, some other items were part of draft-22 as well.

> @@ -5935,6 +5935,38 @@ DecodePacketNumber(largest_pn, truncated_pn, pn_nbits):
 
 Issue and pull request numbers are listed with a leading octothorp.
 
+## Since draft-ietf-quic-transport-22
+
+- NEW_CONNECTION_ID includes a request to retire old connection IDs (#2645,

That was already part of draft-22.

> @@ -5935,6 +5935,38 @@ DecodePacketNumber(largest_pn, truncated_pn, pn_nbits):
 
 Issue and pull request numbers are listed with a leading octothorp.
 
+## Since draft-ietf-quic-transport-22
+
+- NEW_CONNECTION_ID includes a request to retire old connection IDs (#2645,
+  #2769)
+- Rules for preventing correlation by connection ID tightened (#2084, #2929)
+- Clarified use of CONNECTION_CLOSE in Handshake packets (#2151, #2541, #2688)
+- Discourage regressions of largest acknowledged in ACK (#2205, #2752)
+- Improved robusness of validation process for ECN counts (#2534, #2752)
+- Introduce concept of handshake confirmation (#2267, #2673)

This as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019#pullrequestreview-286530924

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Sep 2019 20:03:12 -0700

@martinthomson pushed 1 commit.

c880853f1a9ec3dc05a4912fc17058296c1e0e9b  Remove issues that were closed between 2019-06-09 and 2019-07-09 from -23 changelog

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019/files/515185d51882f5d635471215b54959724ca1015e..c880853f1a9ec3dc05a4912fc17058296c1e0e9b

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Sep 2019 20:03:46 -0700

Thanks @marten-seemann, I mistyped the date when I searched and didn't check for duplicates on that set.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019#issuecomment-530199738

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 11 Sep 2019 14:51:34 -0700

+  #2638)

#2916 is now merged.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019#discussion_r323475980

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Sep 2019 18:09:03 -0700

e9aa25a0bdebb42dbf392ad551a72aa0eb7531f8  Add #2916 too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019/files/c880853f1a9ec3dc05a4912fc17058296c1e0e9b..e9aa25a0bdebb42dbf392ad551a72aa0eb7531f8

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Sep 2019 18:11:09 -0700

Merged #3019 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3019#event-2627566080