Subject: Re: [quicwg/base-drafts] Keys need to be available to QUIC earlier (#2992)

From: David Schinazi <[email-masked]>
Date: Tue, 10 Sep 2019 15:26:24 -0700

DavidSchinazi approved this pull request.

> @@ -495,6 +496,12 @@ client could interleave ACK frames that are protected with Handshake keys with
 0-RTT data and the server needs to process those acknowledgments in order to
 detect lost Handshake packets.
 
+QUIC also needs access to keys that might not ordinarily be available to a TLS
+implementation.  For instance, a client might need to acknowledge Handshake
+packets before it is ready to sent CRYPTO frames at that encryption level.  TLS

typo: ready to *send*

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2992#pullrequestreview-286468862

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Sep 2019 15:30:35 -0700

@martinthomson pushed 1 commit.

e6c5d74fd41b62eab9e8333c89d89b01f5e1fb39  typo

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2992/files/3d5e2692e439f2f488b92bad55f885827d702367..e6c5d74fd41b62eab9e8333c89d89b01f5e1fb39

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 10 Sep 2019 16:14:33 -0700

kazuho commented on this pull request.

LGTM modulo the nitpick below.

>                                                     Get Handshake
                      <------------- Initial
+Handshake Received
+Install tx Handshake keys

s/Install tx Handshake keys/Install Handshake keys/?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2992#pullrequestreview-286483236

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Sep 2019 16:30:54 -0700

a668d506e6168a1aa831c0a2cf1f4c1ff9365f87  Both read and write for Handshake keys

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2992/files/e6c5d74fd41b62eab9e8333c89d89b01f5e1fb39..a668d506e6168a1aa831c0a2cf1f4c1ff9365f87

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 10 Sep 2019 17:34:05 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2992#pullrequestreview-286503008

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Sep 2019 17:47:43 -0700

Merged #2992 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2992#event-2624079987