Subject: [quicwg/base-drafts] Https:/github-release-draft..yml (#3024)

From: chumd <[email-masked]>
Date: Thu, 12 Sep 2019 03:04:07 -0700

Linked by contributor...
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3024

-- Commit Summary --

  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * move definition of active_connection_id_limit to where it belongs
  * grease transport parameters
  * Merge pull request #2872 from marten-seemann/move-active-conn-id-limit-def
  * Merge pull request #2769 from nibanks/pr/replace-cid
  * Merge pull request #2729 from erickinnear/dont_retransmit_path_response
  * Merge pull request #2794 from quicwg/ianswett-ack-ack
  * Merge pull request #2370 from huitema/stronger-migration-handshake
  * Change log for -21
  * Reflow
  * Ian&#39;s tweaks to text
  * Fix recovery references
  * Grammatical error
  * Merge pull request #2875 from quicwg/changelog-21
  * Merge branch &#39;master&#39; into master
  * Merge pull request #2749 from martinduke/master
  * Fix changelogs for -22
  * Merge branch &#39;master&#39; into accept-and-reject-0-rtt
  * Editorial fix for #2479
  * Update draft-ietf-quic-invariants.md
  * Update draft-ietf-quic-invariants.md
  * Update draft-ietf-quic-invariants.md
  * Update draft-ietf-quic-invariants.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-invariants.md
  * add IANA considerations
  * Articulate error code principles
  * Remove spin coordination requirement
  * fixed typo
  * Byte lengths are next
  * Merge pull request #2877 from quicwg/ianswett-2479
  * Get test vectors in place for -23
  * Merge pull request #2883 from martinduke/patch-1
  * Move some text up
  * Firm up language around stream termination
  * Giving Lucas credit for a suggestion
  * qpack: fix reference to blocked-streams section
  * Remove connection error response to a packets from a different source address when an endpoint has sent disable_migration, clarify an endpoints options when prohibited packets are received, rename disable_migration to disable_active_migration, and remove INVALID_MIGRATION error code.
  * Rewrap long line
  * Move wasteful packet stuff to -transport
  * Tweak language more
  * Merge Crypto timeout and PTO (#2806)
  * Fix typo
  * Updates from review feedback
  * Don&#39;t state QUIC error codes.
  * Fix lack of exponential backoff in pseudocode (#2902)
  * Fix HPACK xref
  * Add one to sample offset for header protection
  * Merge pull request #2904 from quicwg/sample-offset
  * Reaction to attack
  * Merge pull request #2901 from tandf/patch-1
  * Remove sentence that&#39;s no longer necessary
  * Typo in change log
  * PTO should always send an ack-eliciting packet
  * Clarify resetting congestion control
  * Merge pull request #2917 from quicwg/close2685
  * Fix language around CC on migration
  * Up to two full-sized datagrams, not packets (#2915)
  * Add rationale for why ack-eliciting
  * reorder reading better for
  * Merge pull request #2912 from quicwg/ianswett-pto-ack-eliciting
  * Confidentiality for server transport parameters
  * Reword per Ian&#39;s suggestion
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * David&#39;s comments
  * Update draft-ietf-quic-transport.md
  * Minor clarification. Fixes #2084
  * Fix typo in transport draft: eliciting
  * Merge pull request #2930 from dtikhonov/201907241710-fix-typo-eliciting
  * Rewrap, clarify affiliation to mean cooperation
  * Update the PreferredAddress structure to accomodate a 20 byte CID.
  * Merge pull request #2943 from rpaulo/preferred-address-cid
  * Fix nit in protocol overview in TLS draft
  * Remove extra curly brace from HTTP draft
  * Remove mention of &quot;protocol version selection&quot; from TLS draft
  * Merge pull request #2949 from nharper/nit2
  * Merge pull request #2948 from nharper/nit1
  * Merge pull request #2950 from nharper/nit3
  * Replace HTTP_MALFORMED_FRAME error code (#2662)
  * Early-Data isn&#39;t per-stream, it&#39;s connection handshake state
  * Tighten HEADERS and DATA frame order requirements. (#2867)
  * Add normative reference to RFC7540 8.1.2.5. (#2868)
  * ECN verification text
  * faulty, not all
  * ECN verification text
  * faulty, not all
  * ... and I thought this was going to be easy
  * gah... git
  * fix ref
  * clarify out of order acking
  * Make Recovery Pseudocode Formatting Consistent (#2946)
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Apply suggestions from code review
  * Merge pull request #2887 from quicwg/vectors-23
  * More feedback
  * Remove extra line
  * comments and more
  * Apply suggestions from code review
  * reflow
  * comments
  * use largest acked, not packet number
  * the best words
  * lint
  * Merge pull request #2896 from quicwg/issue2890
  * Merge pull request #2888 from quicwg/firm-stop-sending
  * CRYPTO frames can not be sent in 0-RTT
  * Merge pull request #2960 from tandf/patch-1
  * more words
  * Merge pull request #2954 from quicwg/jri/ack-el
  * Repair rules for NEW_TOKEN
  * fix example for reserved transport parameter code points
  * Update Stream Commitment Attack example
  * s/STREAM DATA frames/STREAM frames/
  * 1,000,001 streams to be precise
  * likely too many uses of likely
  * Editorial clean-up
  * Merge pull request #2965 from tandf/patch-1
  * Modify pseudo-code to enforce that zero must be encoded as zero.
  * blocked
  * MUST emit Header Acknowledgement
  * Change &quot;when&quot; to &quot;after&quot; to allow for delayed acknowledgements that might reduce overheads.
  * post-base index is not relative index
  * Update draft-ietf-quic-transport.md
  * ECN counts in the ACK frame should be in the same pn_space of the ACK frame (#2964)
  * Merge pull request #2921 from quicwg/encrypt-tps
  * Merge pull request #2852 from marten-seemann/should-send-0rtt-after-retry
  * Merge pull request #2841 from marten-seemann/accept-and-reject-0-rtt
  * Merge pull request #2857 from quicwg/define-terms
  * Merge pull request #2918 from quicwg/more2685
  * Merge pull request #2893 from erickinnear/ek/disable_active_migration
  * Merge branch &#39;master&#39; into grease-transport-parameters
  * Merge pull request #2873 from marten-seemann/grease-transport-parameters
  * Merge pull request #2880 from quicwg/error-handling-principles
  * Merge pull request #2882 from quicwg/dont-coordinate-spin
  * Dedupe
  * Talk more about multiple tokens
  * Reword
  * Not migration, just address change
  * Add missing word back
  * State network byte order here, too
  * Merge pull request #2976 from quicwg/transport/pa_yes_really_nbo
  * Merge pull request #2961 from quicwg/retransmit-new-token
  * Update remaining test vectors for Initial packets.
  * Merge pull request #2981 from rpaulo/update-remaining-vectors
  * Remove short title for TLS
  * Merge pull request #2983 from quicwg/no-tls-short-title
  * Update QPACK stream creation error
  * Reorder &quot;Variables of Interest&quot;
  * Merge pull request #2927 from quicwg/ianswett-smaller-stateless-resets
  * Merge pull request #2752 from quicwg/jri/ecn
  * Merge pull request #2929 from ekr/issue2084_correlated_cids
  * Missing quote
  * Only servers send NEW_TOKEN
  * No point in coalescing Retry or VN
  * Simplify ChaCha20 interface
  * DCID in short headers
  * Keys need to be available to QUIC earlier
  * Require 8164 validation for non-https origins (#2973)
  * Forbid duplicate setting identifiers. (#2979)
  * Ian&#39;s suggestion
  * Remove PRIORITY (#2922)
  * Send complete SETTINGS (#2972)
  * Add headings to Security Considerations (#2975)
  * Default values in IANA (#2974)
  * Merge pull request #2988 from quicwg/client-new-token
  * Merge pull request #2991 from quicwg/unclarity-short
  * Merge pull request #2989 from quicwg/coalesce-retry-vn
  * apply Mike&#39;s suggestion
  * HTTP Upgrade in H3 is silliness (#2898)
  * Error codes can&#39;t cause errors
  * Fix Recovery Pseudocode (#2907)
  * Ian&#39;s suggested wording
  * Simplify more
  * Attempt to make the stateless reset text better
  * More editorial changes
  * Reserved frame types and the other reserved frame types (#2997)
  * Cache git repo between Circle runs
  * Cache draft references too
  * Only gc if called for
  * Taking Ian&#39;s rewording
  * Add master to fallback path for new branches
  * (38+2)/8 != 6
  * Add CRYPTO_BUFFER_EXCEEDED to the error code table
  * Use contains() (#3015)
  * No --
  * Merge pull request #2962 from quicwg/multi-token
  * Merge pull request #2990 from quicwg/chacha-simple
  * Error codes can&#39;t cause errors (#2998)
  * QPACK [editorial] Update text to include both criteria of &quot;blocking entry&quot;. (#2937)
  * Merge pull request #3012 from maskit/error_code_table
  * Merge pull request #3007 from quicwg/cleanup-sr
  * rename HTTP_UNEXPECTED_FRAME to HTTP_FRAME_UNEXPECTED and fold HTTP_W… (#3003)
  * QPACK [editorial] Update text on instructions and representations. (#2941)
  * Security Considerations text for a memory limit (#3004)
  * typo
  * typo fix
  * Merge pull request #3009 from quicwg/circle_caching
  * Merge pull request #2802 from marten-seemann/misleading-alpn-version
  * Update QPACK Changelog (#3016)
  * HTTP-23 changelog
  * Recovery Changelog
  * Update draft-ietf-quic-recovery.md
  * Update draft-ietf-quic-recovery.md
  * Both read and write for Handshake keys
  * Merge pull request #2992 from quicwg/keys-available-earlier
  * Changelog for transport-23
  * Move Generating Acknowledgements to Transport
  * Move, don&#39;t just remove the text
  * Remove the &quot;Crypto Handshake Data&quot; section
  * Stop referencing QUIC Transport
  * Remove obsolete text
  * Stop referencing host-delay in Recovery
  * Fix CircleCI (hopefully)
  * Update draft-ietf-quic-recovery.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Addresses comments and some text rework
  * re-adding (with some rework) text that was dropped inadvertently
  * rebase cleanup
  * Remove issues that were closed between 2019-06-09 and 2019-07-09 from -23 changelog
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Update draft-ietf-quic-transport.md
  * Reflow a line
  * Update draft-ietf-quic-recovery.md
  * moving text around a bit and mt&#39;s comment
  * Merge pull request #2916 from quicwg/ianswett-generating-acknowledgements
  * Add #2916 too
  * Add #2916 to listing
  * Merge branch &#39;ianswett-recovery-changelog&#39;
  * Merge branch &#39;changelog-tt-23&#39;
  * Merge pull request #3017 from quicwg/http/changelog_23
  * fix length of Initial payload for the client
  * fix protected Initial header for the server
  * Merge pull request #3021 from marten-seemann/fix-test-vectors

-- File Changes --

    M .circleci/config.yml (29)
    M CONTRIBUTING.md (2)
    M README.md (8)
    M draft-ietf-quic-http.md (1848)
    M draft-ietf-quic-invariants.md (48)
    M draft-ietf-quic-qpack.md (699)
    M draft-ietf-quic-recovery.md (776)
    D draft-ietf-quic-spin-exp.md (314)
    M draft-ietf-quic-tls.md (501)
    M draft-ietf-quic-transport.md (1608)
    M initial-protection.js (16)
    M tag.sh (1)
    A workflow.png (0)
    A workflow.xml (1)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3024.patch
https://github.com/quicwg/base-drafts/pull/3024.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3024

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Sep 2019 07:58:17 -0700

No.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3024#issuecomment-530865758

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Sep 2019 07:58:19 -0700

Closed #3024.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3024#event-2629507834

---

From: chumd <[email-masked]>
Date: Thu, 12 Sep 2019 19:11:35 -0700

Chinlog

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3024#issuecomment-531072493