Subject: Re: [quicwg/base-drafts] Confused about Fixed Bit in Version Negotiation Packet (#2995)

From: Martin Thomson <[email-masked]>
Date: Fri, 13 Sep 2019 00:44:34 -0700

>  If Client must ignore the value(including Fixed Bit), why server should set Fixed Bit?

Because this might allow us - in future - to depend on that behaviour.  We might assign semantics to a non-zero value.  A client that doesn't understand that bit will continue to consume the packet and ignore the semantic difference.  If servers set the value any way they please, then we can't.  (It's a SHOULD, so we won't be able to rely on it exclusively, but we might still be able to do something with it.  That said, I consider it a write-off, but this is a general protocol design hygiene matter.)

My proposal for this issue is to do nothing.  This is a little complex, but I don't think that the required behaviour is unclear in any way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2995#issuecomment-531135802

---

From: Ainiroad <[email-masked]>
Date: Sun, 15 Sep 2019 19:35:24 -0700

Thanks

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2995#issuecomment-531625100

---

From: Ainiroad <[email-masked]>
Date: Sun, 15 Sep 2019 19:35:25 -0700

Closed #2995.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2995#event-2635055923