Subject: [quicwg/base-drafts] require peers to check if RETIRE_CONNECTION_ID sequence number is valid (#3036)

From: Marten Seemann <[email-masked]>
Date: Mon, 16 Sep 2019 04:24:34 -0700

When it comes to error checks for protocol violations, our principle is that easy to implement error checks are REQUIRED. Only error checks that might require a lot of state to perform are optional.

The check that the sequence number retired in a RETIRE_CONNECTION_ID frame is smaller than the highest issued connection ID is a single trivial uint64 comparison. Furthermore, every implementation needs to track the highest issued sequence number anyway, since connection IDs are issued in order.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3036

-- Commit Summary --

  * require peers to check if RETIRE_CONNECTION_ID sequence number is valid

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3036.patch
https://github.com/quicwg/base-drafts/pull/3036.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3036

---

From: ianswett <[email-masked]>
Date: Mon, 16 Sep 2019 10:08:45 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3036#pullrequestreview-288773060

---

From: ianswett <[email-masked]>
Date: Mon, 16 Sep 2019 10:09:39 -0700

This is small and I support it, but I think it needs to be marked design and run through the process because it changes normative language.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3036#issuecomment-531869424

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 16 Sep 2019 17:33:36 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3036#pullrequestreview-288967287