Subject: [quicwg/base-drafts] Clients send datagrams with 1200 byte payloads (#3051)

From: ianswett <[email-masked]>
Date: Thu, 19 Sep 2019 14:30:59 -0700

I was a bit unsure if the text meant 1200 or 1192 byte payloads. I think this is clearer.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3051

-- Commit Summary --

  * Clients send datagrams with 1200 byte payloads

-- File Changes --

    M draft-ietf-quic-transport.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3051.patch
https://github.com/quicwg/base-drafts/pull/3051.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051

---

From: fayang <[email-masked]>
Date: Thu, 19 Sep 2019 15:05:13 -0700

yangfanud approved this pull request.

This is much clearer, thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#pullrequestreview-290868188

---

From: MikkelFJ <[email-masked]>
Date: Thu, 19 Sep 2019 15:09:38 -0700

Not directly related to the change which is editorial, but why is it that 1200 only applies to Initial? Isn't it possible to coalesce Initial with random other packets and thereby work around this limit?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#issuecomment-533327645

---

From: ianswett <[email-masked]>
Date: Thu, 19 Sep 2019 15:48:39 -0700

@mikkelfj I agree that the wording currently implies if a client bundles a 0-RTT packet with an Initial in a datagram, then it's ok for it to be less than 1200 bytes, which I don't believe is what we want?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#issuecomment-533336970

---

From: David Schinazi <[email-masked]>
Date: Thu, 19 Sep 2019 17:13:27 -0700

DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#pullrequestreview-290903005

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 19 Sep 2019 17:19:52 -0700

@mikkelfj @ianswett I agree with the concern, and have opened #3053 (before reading your comments here). I think this PR can be kept an editorial issue while #3053 needs to be a design issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#issuecomment-533355297

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 19 Sep 2019 18:55:03 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#pullrequestreview-290922078

---

From: Marten Seemann <[email-masked]>
Date: Thu, 19 Sep 2019 19:06:31 -0700

marten-seemann requested changes on this pull request.

> @@ -1592,10 +1592,10 @@ magnitude of any amplification attack that can be mounted using spoofed source
 addresses.  In determining this limit, servers only count the size of
 successfully processed packets.
 
-Clients MUST ensure that UDP datagrams containing only Initial packets are sized
-to at least 1200 bytes, adding padding to packets in the datagram as necessary.
-Sending padded datagrams ensures that the server is not overly constrained by
-the amplification restriction.
+Clients MUST ensure that UDP datagrams containing only Initial packets have
+payloads of at least 1200 bytes, adding padding to packets in the datagram as

I think this is less clear than it was before. There's a UDP payload and a QUIC payload, and it's not clear that you're referring to the UDP payload size here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#pullrequestreview-290924150

---

From: ianswett <[email-masked]>
Date: Fri, 20 Sep 2019 05:48:42 -0700

@ianswett pushed 1 commit.

3801ebda3af7418505f1aed87138ae72a3178829  More UDP

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051/files/f77bd1e5395bbac2bd1fe2ab575f1beac4c8bf32..3801ebda3af7418505f1aed87138ae72a3178829

---

From: ianswett <[email-masked]>
Date: Fri, 20 Sep 2019 05:49:10 -0700

ianswett commented on this pull request.

I see your point, I added another UDP to remove the ambiguity.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#discussion_r326611670

---

From: Martin Thomson <[email-masked]>
Date: Fri, 20 Sep 2019 22:03:39 -0700

@martinthomson pushed 1 commit.

6cfcbe26385f17072ccd330aea619f65bf3bdcb4  Closes #3053 too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051/files/3801ebda3af7418505f1aed87138ae72a3178829..6cfcbe26385f17072ccd330aea619f65bf3bdcb4

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Sep 2019 16:21:51 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#pullrequestreview-292105048

---

From: Nick Banks <[email-masked]>
Date: Mon, 23 Sep 2019 16:27:32 -0700

nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3051#pullrequestreview-292106585