Subject: [quicwg/base-drafts] Suggest sending empty CRYPTO frames in Initial/Handshake packets (#3033)

From: Alessandro Ghedini <[email-masked]>
Date: Sat, 14 Sep 2019 12:19:10 -0700

As per @tatsuhiro-t, since PING frames are not allowed in
Initial/Handshake packets, one can use an empty CRYPTO frame when
sending a probe when there is no other ack-eliciting frame to send.

It seems to me like this is something that is fairly easy to miss, so
worth expanding the existing suggestion I think.

The alternative would be to allow PING frames in Initial/Handshake, but
I figured we are maybe too late in the process for that kind of design
change.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3033

-- Commit Summary --

  * Suggest sending empty CRYPTO frames in Initial/Handshake packets

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3033.patch
https://github.com/quicwg/base-drafts/pull/3033.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033

---

From: Marten Seemann <[email-masked]>
Date: Sat, 14 Sep 2019 22:39:26 -0700

I'd prefer to just allow PING in all packet types. Sending empty CRYPTO frames seems kind of hacky to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033#issuecomment-531536478

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Sat, 14 Sep 2019 23:52:41 -0700

If don't know the reasoning why PING has been prohibited in Initial or Handshake, but if there is no hard rule to exclude it from handshake packets, I think that just allowing PING in Initial/Handshake is simpler.
I just chose empty CRYPTO so that it works with draft-23 compliant implementations; literally there is no ACK eliciting frame other than that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033#issuecomment-531540032

---

From: Marten Seemann <[email-masked]>
Date: Sun, 15 Sep 2019 00:39:19 -0700

I brought this up a long time ago in #2307. Apparently, this issue was closed by #2355. I'm wondering why.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033#issuecomment-531542643

---

From: Alessandro Ghedini <[email-masked]>
Date: Sun, 15 Sep 2019 04:10:28 -0700

Ok, thanks.

I made https://github.com/quicwg/base-drafts/issues/3034 to discuss allowing PING in Initial/Handshake packets again and made a PR (https://github.com/quicwg/base-drafts/pull/3035). The WG can then decide if we want the editorial-only change in this PR, or the design one in the other PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033#issuecomment-531556390

---

From: ianswett <[email-masked]>
Date: Mon, 16 Sep 2019 07:25:03 -0700

I agree with @marten-seemann the intent was to allow this in #2355, thanks for sending out a different PR to allow them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033#issuecomment-531801123

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 16 Sep 2019 17:30:39 -0700

I don't recall us wanting to disallow PING frames in Initial/Handshake packets. #3035 looks good to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3033#issuecomment-532009003