Subject: [quicwg/base-drafts] Mysterious 1 vs 2 packet distinction in recovery pseudocode (#3070)

From: Benjamin Saunders <[email-masked]>
Date: Wed, 25 Sep 2019 17:11:31 -0700

[The pseudocode](https://quicwg.org/base-drafts/draft-ietf-quic-recovery.html#rfc.appendix.A.9) only potentially sends 2 packets if the endpoint is a server or if 1-RTT keys are had. It's unclear why this distinction is made, as opposed to sending "one or two" packets in every case. The text says:
>  Sending two packets on PTO expiration increases resilience to packet drops, thus reducing the probability of consecutive PTO events.

which seems to apply universally.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3070

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Sep 2019 17:20:53 -0700

I think that we probably need to start saying "send a probe" rather than "send one or two packets".  And to define a probe as being one or two packets that can exceed the congestion limit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3070#issuecomment-535275358