Subject: [quicwg/base-drafts] Unclear how short header packets should be matched to connections (#3006)

From: Constantine Shablya <[email-masked]>
Date: Wed, 04 Sep 2019 16:21:26 -0700

Section 5.2 of current draft (22) doesn't explain how one should match short headers to connections.  Does one first check if one has a connection associated with the address/port tuple and then use Connection ID?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3006

---

From: MikkelFJ <[email-masked]>
Date: Wed, 04 Sep 2019 16:31:10 -0700

You cannot assume that the src port is always stable because of NAT rebinding. Perhaps not even the IP address. So you should look up the CID first. On the other hand, some CID's are zero length. In this case you can assume the address is stable, so you would use the tuple for connection lookup.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3006#issuecomment-528131415

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Sep 2019 16:36:33 -0700

Closed #3006.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3006#event-2608806140

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Sep 2019 16:36:33 -0700

@mikkelfj has it about right, though I would point out two things: you choose how long the connection ID is based on your understanding of requirements.  Zero-length is basically only for when you have a unique address for the connection at your end.

The other is that this is not the best place to ask questions.  Try our [mailing list](mailto:[email-masked]).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3006#issuecomment-528132545

---

From: Constantine Shablya <[email-masked]>
Date: Wed, 04 Sep 2019 16:41:51 -0700

Thanks for clarifying. Though I did not create the issue just as a plain question but rather to express that I believe the order of actions of matching a short header to connection isn't very clear as described in the current draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3006#issuecomment-528133680

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Sep 2019 16:51:31 -0700

> Hosts try to associate a packet with an existing connection. If the packet has a Destination Connection ID corresponding to an existing connection, QUIC processes that packet accordingly.

I'll concede that this should probably say "processes that packet for the identified connection" or something along those lines, but I don't see how this is ambiguous otherwise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3006#issuecomment-528136882