Subject: [quicwg/base-drafts] http: syntax fixes for quic Alt-Svc parameter (#3059)

From: Peter Wu <[email-masked]>
Date: Mon, 23 Sep 2019 15:32:34 -0700

Following https://tools.ietf.org/html/rfc7838#section-3, the Alt-Svc
parameter value can be unquoted. Do not further restrict that grammar
and use the correct ABNF syntax to express repetition.

Fix the Reserved frame type link.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3059

-- Commit Summary --

  * http: syntax fixes for quic Alt-Svc parameter

-- File Changes --

    M draft-ietf-quic-http.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3059.patch
https://github.com/quicwg/base-drafts/pull/3059.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 23 Sep 2019 16:07:24 -0700

There is some baggage with this parameter - https://github.com/quicwg/base-drafts/issues/1093

People were a bit grumpy with changing their parser 18 months ago, I think they might be even grumpier now that we have even more client implementations in the wild.

What is the benefit of this change? I think we need an issue for due process and discussion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059#issuecomment-534319043

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 23 Sep 2019 16:28:00 -0700

Oh joy. This caused me to go look at our parser in Chrome, and realized we're still doing the old (pre 1097) quic=<hex>;quic=<hex> format. So Chrome has work to do no matter how we resolve this. 

That being said, I'd really rather not have two different ways to do this, so +1 to @LPardue 's comment on the motivation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059#issuecomment-534323939

---

From: Peter Wu <[email-masked]>
Date: Mon, 23 Sep 2019 16:39:17 -0700

I can remove the additional unquoted token change and keep this PR purely as editorial fix. Before the PR, the current text does not have correct ABNF grammar.

I added the unquoted token variant since it is permitted (but not required) by the grammar at https://tools.ietf.org/html/rfc7838#section-3
>    parameter     = token "=" ( token / quoted-string )

Since HTTP/3 over QUIC is not the only user of this Alt-Svc header, I can imagine that generic parsers are written such that they already understand the unquoted token value. Thus, adding support for this should not be an additional burden?

I have no strong opinion here. The additional CPU cost of handling both unquoted and quoted forms should be neglible. Disallowing the unquoted form is a restriction of the RFC 7838 grammar.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059#issuecomment-534326183

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 23 Sep 2019 17:04:28 -0700

Let's create a new issue. 

You're correct that non-HTTP/3 implementations might need to handle this - hence the original issue which related back to structured headers (an attempt at defining some best practice in this regard -https://github.com/httpwg/http-extensions/issues/281).

Part of the problem is not CPU cost of DQUOTEs but expressing "a list of versions" and making sure that implementations know how to do that. Alt-Svc defines the parameter syntax but not how to handle repetition of parameters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059#issuecomment-534331561

---

From: Peter Wu <[email-masked]>
Date: Mon, 23 Sep 2019 17:30:36 -0700

@Lekensteyn pushed 1 commit.

fafd8726104bf1b6a4083b990b3525b92e0b7ecf  http: syntax fixes for quic Alt-Svc parameter

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059/files/efd2db09c4cf1c943d006ab1c42148142fdd798b..fafd8726104bf1b6a4083b990b3525b92e0b7ecf

---

From: Peter Wu <[email-masked]>
Date: Mon, 23 Sep 2019 17:31:57 -0700

I removed the single quote change, this should be a purely editorial fix now. I'll create a new issue for the unquoted parameter value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3059#issuecomment-534337242