Subject: [quicwg/base-drafts] rename HTTP_UNEXPECTED_FRAME to HTTP_FRAME_UNEXPECTED and fold HTTP_W… (#3003)

From: Lucas Pardue <[email-masked]>
Date: Tue, 03 Sep 2019 10:40:16 -0700

…RONG_STREAM into it

Renaming the error to align with a suggestion from @MikeBishop made somewhere. This is a less drastic version of #2996.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3003

-- Commit Summary --

  * rename HTTP_UNEXPECTED_FRAME to HTTP_FRAME_UNEXPECTED and fold HTTP_WRONG_STREAM into it

-- File Changes --

    M draft-ietf-quic-http.md (81)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3003.patch
https://github.com/quicwg/base-drafts/pull/3003.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003

---

From: ianswett <[email-masked]>
Date: Tue, 03 Sep 2019 15:23:31 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003#pullrequestreview-283292551

---

From: Mike Bishop <[email-masked]>
Date: Wed, 04 Sep 2019 10:42:24 -0700

MikeBishop approved this pull request.

Yes, I like this better than #2996.

> @@ -1414,8 +1414,8 @@ HTTP_STREAM_CREATION_ERROR (0x103):
 HTTP_CLOSED_CRITICAL_STREAM (0x104):
 : A stream required by the connection was closed or reset.
 
-HTTP_UNEXPECTED_FRAME (0x105):
-: A frame was received which was not permitted in the current state.
+HTTP_FRAME_UNEXPECTED (0x105):
+: A frame was received which was not permitted in the current state or stream.

```suggestion
: A frame was received which was not permitted in the current state or on the current stream.
```
We've usually used "on" rather than "in" for a stream. (Though this reminds me of a great story about the choice of prepositions my former manager told once....)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003#pullrequestreview-283783209

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 04 Sep 2019 11:37:14 -0700

@LPardue pushed 1 commit.

cea422edb3bd8e51b2f72b2ddf7aba9bf1c15984  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003/files/cbb61346d1cc708772c518910ade0da0d95b3c98..cea422edb3bd8e51b2f72b2ddf7aba9bf1c15984

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 04 Sep 2019 17:37:22 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003#pullrequestreview-283967611

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Sep 2019 15:17:46 -0700

@MikeBishop pushed 1 commit.

72838cc0ee5275f2acd3f37109cafca6ea08c80a  Rewrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003/files/cea422edb3bd8e51b2f72b2ddf7aba9bf1c15984..72838cc0ee5275f2acd3f37109cafca6ea08c80a

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Sep 2019 15:19:53 -0700

Merged #3003 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003#event-2623867846

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Sep 2019 15:21:16 -0700

Note:  I got some questions about the renumbering of the error codes; I went ahead and took it because we've had a massive renumbering since the last published draft anyway.  If we'd published the draft with the old numbering, I would have just left the hole.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3003#issuecomment-530143065