Subject: [quicwg/base-drafts] Remove Requirement of an Acknowledgement per Round Trip (#3030)

From: Nick Banks <[email-masked]>
Date: Fri, 13 Sep 2019 09:31:07 -0700

The spec gives no reason (that I can see) as to why an ACK frame must be sent at least once per round trip (assuming there are ack-eliciting packets to acknowledge), effectively overwriting the ACK delay logic when the RTT is very small. If the RTT is smaller than the platform's timer granularity, this isn't really even possible.

I propose to remove this requirement. If the WG instead feels that we should keep this requirement, then there should be a reasoning for it; and probably an update to the PTO calculation as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3030

---

From: ianswett <[email-masked]>
Date: Fri, 13 Sep 2019 09:35:57 -0700

As I commented on the PR that this came up in, given we have an explicit max_ack_delay that's now communicated, removing the 1 ACK per RTT requirement seems wide.

TCP has no such recommendation and I'm unaware of any indications or proposals that it should have such a property.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3030#issuecomment-531306962

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 16 Sep 2019 16:52:21 -0700

@nibanks's point that the RTT can be smaller than the platform's granularity is a good one. I agree that this text ought to be removed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3030#issuecomment-532001186

---

From: ianswett <[email-masked]>
Date: Fri, 20 Sep 2019 08:52:20 -0700

This is changing text in a SHOULD statement, so I believe it should be marked as design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3030#issuecomment-533610757