Subject: Re: [quicwg/base-drafts] QPACK decoder stream buffer grows without bounds (#2999)

From: Mike Bishop <[email-masked]>
Date: Tue, 03 Sep 2019 12:34:39 -0700

Hypothetically, this limit would create a way to force the peer to kill the connection by starving the decoder stream of flow control credit and then cancelling lots of streams.  However, the consumer of (and therefore the entity which could fail to read) the decoder stream is the encoder, and the encoder can trivially cause the connection to close by emitting an invalid instruction anyway.  That seems fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2999#issuecomment-527606375

---

From: afrind <[email-masked]>
Date: Tue, 10 Sep 2019 15:22:32 -0700

Closed #2999 via #3004.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2999#event-2623872322