Subject: Re: [quicwg/base-drafts] Simplify more (b0f00ed)

From: MikkelFJ <[email-masked]>
Date: Thu, 05 Sep 2019 21:40:40 -0700

Don't you mean the opposite?

implementation could take a byte sequence in place of a 32-bit integer, in

What happened to the suggest change?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/b0f00edf9f8ba7139a6b7a2c36edd44112de5482#commitcomment-34973994

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Sep 2019 23:56:19 -0700

I think that this is right.  The starting assumption is that the input is a byte sequence (the first sentence).

The second sentence says that if the ChaCha20 implementation expects a 32-bit integer instead, the bytes are read as a little-endian number.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/b0f00edf9f8ba7139a6b7a2c36edd44112de5482#commitcomment-34975082

---

From: MikkelFJ <[email-masked]>
Date: Fri, 06 Sep 2019 00:28:06 -0700

I see

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/b0f00edf9f8ba7139a6b7a2c36edd44112de5482#commitcomment-34975415