Subject: [quicwg/base-drafts] ack-eliciting not ACK-eliciting (#3069)

From: ianswett <[email-masked]>
Date: Wed, 25 Sep 2019 08:14:07 -0700

Fixes #3068
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3069

-- Commit Summary --

  * ack-eliciting not ACK-eliciting

-- File Changes --

    M draft-ietf-quic-transport.md (32)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3069.patch
https://github.com/quicwg/base-drafts/pull/3069.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 25 Sep 2019 11:59:07 -0700

We use ACK for ACK frame and 'acknowledgment' instead of 'ack'. I think this should be ACK-eliciting. I suppose if ack-eliciting were defined as a term that might make it ok to use... can you bring the term over from the recovery doc into the transport one?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#issuecomment-535164281

---

From: ianswett <[email-masked]>
Date: Wed, 25 Sep 2019 12:39:24 -0700

@ianswett pushed 1 commit.

1d0274ff01eafb4dc088a09976f949fe2899150c  Define Ack-eliciting packet

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/22239c60048e3c8266ed52fa7fa26e827dfb4c27..1d0274ff01eafb4dc088a09976f949fe2899150c

---

From: ianswett <[email-masked]>
Date: Wed, 25 Sep 2019 12:41:15 -0700

dae6c31a90f737b6fa7b2fb67d5d481972c7a765  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/1d0274ff01eafb4dc088a09976f949fe2899150c..dae6c31a90f737b6fa7b2fb67d5d481972c7a765

---

From: ianswett <[email-masked]>
Date: Wed, 25 Sep 2019 12:42:33 -0700

7e738c6605dd9e5c5325b418955d8f167ff523af  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/dae6c31a90f737b6fa7b2fb67d5d481972c7a765..7e738c6605dd9e5c5325b418955d8f167ff523af

---

From: ianswett <[email-masked]>
Date: Wed, 25 Sep 2019 12:43:03 -0700

Definition of ack-eliciting added.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#issuecomment-535180765

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Sep 2019 14:46:02 -0700

martinthomson approved this pull request.

With a tweak.

> @@ -190,6 +190,11 @@ QUIC packet:
 : A complete processable unit of QUIC that can be encapsulated in a UDP
   datagram.  Multiple QUIC packets can be encapsulated in a single UDP datagram.
 
+Ack-eliciting Packet:
+
+: A QUIC packet that contain frames other than ACK and PADDING elicits an ACK

```suggestion
: A QUIC packet that contains frames other than ACK and PADDING. These cause a recipient
   to send an acknowledgment within the maximum ack delay.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#pullrequestreview-293382727

---

From: ianswett <[email-masked]>
Date: Wed, 25 Sep 2019 17:13:26 -0700

1aa9dc12ca874228614963de312b634c1e12c358  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/7e738c6605dd9e5c5325b418955d8f167ff523af..1aa9dc12ca874228614963de312b634c1e12c358

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Sep 2019 18:14:09 -0700

@martinthomson pushed 1 commit.

a6f95c9f45e3db163668d23d3f93c6b938590b68  dont repeat

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/1aa9dc12ca874228614963de312b634c1e12c358..a6f95c9f45e3db163668d23d3f93c6b938590b68

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Sep 2019 18:17:54 -0700

ccd8b3fa264d1709d269f0d2190299b2b2309eb5  wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/a6f95c9f45e3db163668d23d3f93c6b938590b68..ccd8b3fa264d1709d269f0d2190299b2b2309eb5

---

From: Cameron Bytheway <[email-masked]>
Date: Thu, 26 Sep 2019 16:44:06 -0700

camshaft commented on this pull request.

>  containing frames other than ACK and/or PADDING).  An endpoint MUST NOT send a
-packet containing only an ACK frame in response to a non-ACK-eliciting packet
+packet containing only an ACK frame in response to a non-acl-eliciting packet

s/acl/ack

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#pullrequestreview-294057051

---

From: ianswett <[email-masked]>
Date: Thu, 26 Sep 2019 16:58:06 -0700

030e4b5584d2768c3dacc88bc286633437de1c46  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/ccd8b3fa264d1709d269f0d2190299b2b2309eb5..030e4b5584d2768c3dacc88bc286633437de1c46