Subject: [quicwg/base-drafts] Clearer description of detecting spurious retransmission (#3058)

From: ianswett <[email-masked]>
Date: Mon, 23 Sep 2019 09:24:40 -0700

There are multiple mentions of spurious retransmission in the recovery draft, but no text on what detecting this may require from an implementation.  Maybe there should be?

"Spuriously declaring packets as lost leads to unnecessary retransmissions and may result in degraded performance due to the actions of the congestion controller upon detecting loss. Implementations that detect spurious retransmissions and increase the reordering threshold in packets or time MAY choose to start with smaller initial reordering thresholds to minimize recovery latency."

>From comments on #3057 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3058

---

From: Benjamin Saunders <[email-masked]>
Date: Mon, 23 Sep 2019 10:34:05 -0700

Some discussion of implementation strategies here would absolutely be helpful; it doesn't obviously fall out of Quinn's current architecture.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3058#issuecomment-534203423