Subject: [quicwg/base-drafts] The QUIC bit in stateless resets (#3008)

From: Martin Thomson <[email-masked]>
Date: Fri, 06 Sep 2019 03:04:03 -0700

Do we need discussion on the fixed QUIC header bit in the triggering packet and outgoing reset packet?

_Originally posted by @mikkelfj in https://github.com/quicwg/base-drafts/pull/3007#issuecomment-528706518_

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3008

---

From: Marten Seemann <[email-masked]>
Date: Fri, 06 Sep 2019 03:10:40 -0700

Maybe I'm misunderstanding the question, but isn't the spec is completely clear on that? A stateless reset has the first bit unset and the second bit set.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3008#issuecomment-528797201

---

From: ianswett <[email-masked]>
Date: Fri, 06 Sep 2019 04:31:02 -0700

Agreed, I think this is already clear and I don't see any need to change it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3008#issuecomment-528818731

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Sep 2019 17:58:18 -0700

Thanks both.  I just wanted to check and didn't feel like I had the brain cells to answer that.  I don't like relying on the image only, but the text says "two fixed bits", and stateless reset - unlike Version Negotiation - is version-specific.  So I'm closing with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3008#issuecomment-529265440

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Sep 2019 17:58:19 -0700

Closed #3008.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3008#event-2617120455