Subject: Re: [quicwg/base-drafts] Separate HTTP/3 stream errors from connection errors. (#2911)

From: Lucas Pardue <[email-masked]>
Date: Thu, 26 Sep 2019 08:27:50 -0700

@DaanDeMeyer after the big error shuffle that landed in draft-23, how do feel about this issue now?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2911#issuecomment-535557873

---

From: Daan De Meyer <[email-masked]>
Date: Thu, 26 Sep 2019 09:34:37 -0700

I took a quick look at the changes and I my main argument that stream level errors do not make sense as connection level errors still applies. Instead of using stream level errors as connection level errors, I would use a general connection level error and use the reason phrase to add more detail on why an endpoint chose to treat a stream level error as a connection level error (I also think that the cases where it makes sense to do this are rather limited).

On the other hand, this is a pretty insignificant issue so I understand if there's no major motivation to change this when we're this late in the standardization process.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2911#issuecomment-535584983

---

From: ianswett <[email-masked]>
Date: Thu, 26 Sep 2019 12:08:47 -0700

I think it makes sense to make them separate lists, but it is relatively insignificant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2911#issuecomment-535644767

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 26 Sep 2019 12:17:55 -0700

We have at least one implementer that has stated the use of a reason phrase is problematic for them.

I think what we have today is fairly consistent with how HTTP/2 works. 

I'd review a PR that addresses this issue in some way but I'm not motivated to write one myself.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2911#issuecomment-535648028