Subject: [quicwg/base-drafts] kMaxDatagramSize should use the maximum packet size of the connection (#3041)

From: Jana Iyengar <[email-masked]>
Date: Mon, 16 Sep 2019 18:09:04 -0700

kMaxDatagramSize is currently set to the minimum packet size of 1200 bytes. It should be set instead to the max packet size used by the connection, which is discussed in Section 14.1 of the transport draft.

(Issue raised by Timo Völker on the mailing list.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3041

---

From: ianswett <[email-masked]>
Date: Tue, 17 Sep 2019 04:02:24 -0700

My reading is that this value is the actual max packet size used in the connection, it's just not clear from the explanation.  kInitialWindow and kMinimumWindow are also per-connection fields defined directly below.

There is one potential detail, which is if the MTU increases after the handshake, do the min CWND and Reno behavior change accordingly?  I think it's simpler to reason about them not changing, but I can see both arguments and in the end I don't think it'll matter that much.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3041#issuecomment-532171887

---

From: Nick Banks <[email-masked]>
Date: Tue, 17 Sep 2019 06:26:30 -0700

WinQuic uses the currently calculated path MTU instead a constant kMaxDatagramSize.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3041#issuecomment-532219806