Subject: [quicwg/base-drafts] Retransmitting an ACK frame warning (#3049)

From: ianswett <[email-masked]>
Date: Tue, 17 Sep 2019 18:56:26 -0700

It can result in an inflated RTT, as well as being a waste of bytes.

Fixes #2748
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3049

-- Commit Summary --

  * Retransmitting an ACK frame warning

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3049.patch
https://github.com/quicwg/base-drafts/pull/3049.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3049

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Sep 2019 19:20:52 -0700

janaiyengar commented on this pull request.

> @@ -3183,7 +3183,8 @@ containing that information is acknowledged.
 
 * The most recent set of acknowledgments are sent in ACK frames.  An ACK frame
   SHOULD contain all unacknowledged acknowledgments, as described in
-  {{sending-ack-frames}}.
+  {{sending-ack-frames}}.  Retransmitting an ACK frame can result in an

This para is not great. That second sentence totally doesn't belong here. Suggested rewrite:

"ACK frames carry the most recent set of acknowledgements and the current Ack Delay estimate. Retransmitting an old ACK frame with stale Ack Delay can cause the peer to generate an inflated RTT sample."

Then in 13.2.1 (sending-ack-frames), add this as the first paragraph:
"ACK frames SHOULD acknowledge both ack-eliciting and non-ack-eliciting packets that have been received but not yet acknowledged."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3049#pullrequestreview-289638816

---

From: ianswett <[email-masked]>
Date: Tue, 17 Sep 2019 19:31:45 -0700

@ianswett pushed 1 commit.

1d7abab6b77b9ea678143b12c0d308d89362cfa0  Jana's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3049/files/721d42f89c0f739dc8514363856328c9adcecc35..1d7abab6b77b9ea678143b12c0d308d89362cfa0

---

From: ianswett <[email-masked]>
Date: Tue, 17 Sep 2019 19:33:35 -0700

ianswett commented on this pull request.

There is already text that says "When only non-ACK-eliciting packets need to be acknowledged, an endpoint MAY wait until an ACK-eliciting packet has been received to bundle an ACK frame with outgoing frames."  I'm not sure that's sufficient, but your suggestion adds a SHOULD, which makes this change no longer editorial.  The ACK generation text needs a full rewrite, and I'd rather tackle that suggestion as part of that PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3049#discussion_r325459906