Subject: [quicwg/base-drafts] Codes for frame encoding errors (#3027)

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Sep 2019 21:21:17 -0700

In the context of deciding what code to use for badly formatted frames:

> I'd use a FRAME_ENCODING_ERROR error here. However, for other invalid frame errors we use PROTOCOL_VIOLATION. Not sure if that's something we want to address at some point.

_Originally posted by @marten-seemann in https://github.com/quicwg/base-drafts/pull/2977_

I tend to agree with this.  Let's go through and try to apply some sort of consistency.  Maybe even try to be principled about it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027

---

From: Marten Seemann <[email-masked]>
Date: Thu, 12 Sep 2019 22:05:39 -0700

How does this principle sound: If you can detect an error while parsing the frame, and without consulting any connection state, it should be a FRAME_ENCODING_ERROR. For everything that happens after frame parsing, we use the more concrete error types (or PROTOCOL_VIOLATION).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027#issuecomment-531099377

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 12 Sep 2019 22:21:42 -0700

+1. To rephrase, as the name suggests, FRAME_ENCODING_ERROR indicates a syntactic (i.e., encoding) error. But nothing else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027#issuecomment-531102092

---

From: ianswett <[email-masked]>
Date: Fri, 13 Sep 2019 06:37:57 -0700

I'd like to see a PR, but that seems like a good principle.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027#issuecomment-531240209

---

From: Marten Seemann <[email-masked]>
Date: Mon, 16 Sep 2019 04:36:22 -0700

@ianswett I prepared a PR, just waiting for #2977 to get merged to apply the principle there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027#issuecomment-531740310

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Sep 2019 23:14:17 -0700

Can we call this editorial?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027#issuecomment-534870487

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Sep 2019 00:06:16 -0700

It changes functional requirements about what error codes to send, so not really.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3027#issuecomment-534885048