Subject: [RAM] Re: PI v locator rewriting

From: RJ Atkinson <[email-masked]>
Date: Sun, 7 Jan 2007 18:42:50 -0500

Earlier, Tony Li said:
> NAT permits most excellent aggregation as long as you're willing to  
> deal
> with PA addresses. What really becomes cumbersome tho, is when  
> multihoming
> is involved. Then, hosts interacting with the hosts behind the NAT  
> aren't
> aware of the multiple locators allocated to their correspondent and
> havoc ensues.
>
> So, I'd rather say that NAT does rewrite locators, but in an  
> uncoordinated
> way that defeats most of the benefits of multihoming. As such, it's  
> pretty
> much useless as a long-term architectural strategy.

Tony,

Maybe I've misunderstood, but the first paragraph above appears
to say that existing/deployed NAT systems are not sufficient BECAUSE
they do not *currently* include a way for correspondents to discover
all valid Locators associated with a destination node.

If that's a correct understanding, ought not the second paragraph
be saying instead that:

	"In order for NAT to provide multi-homing benefits,
	we need to enhance it with a mechanism to permit
	correspondent nodes to discover the full set of valid Locators
	for nodes behind the NAT (or whatever one calls it) that are
	communicating with the correspondent nodes."

So I don't see this as an *architectural* (using JNC's definition)
issue so much as an specification/implementation gap.

What am I missing here ?

Ran

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Tony Li <[email-masked]>
Date: Sun, 7 Jan 2007 20:42:08 -0800

On Jan 7, 2007, at 3:42 PM, RJ Atkinson wrote:

> Earlier, Tony Li said:
>> NAT permits most excellent aggregation as long as you're willing  
>> to deal
>> way that defeats most of the benefits of multihoming. As such,  
>> it's pretty

Yes, you could do that, but then it wouldn't be NAT, would it now?

Tony

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 08 Jan 2007 17:20:08 +0100

On 2007-01-08 05:42, Tony Li wrote:
>>> NAT permits most excellent aggregation as long as you're willing to deal

As a matter of fact, if you follow Ran's line of thought,
and decide to solve the problem in the host, you get shim6.

     Brian

---

From: Eliot Lear <[email-masked]>
Date: Mon, 08 Jan 2007 17:22:19 +0100

> and decide to solve the problem in the host, you get shim6.

Right.  Or something that looks an awful lot like HIP.

Eliot