Subject: Re: [RAM] candidate properties of some new name types

From: RJ Atkinson <[email-masked]>
Date: Thu, 18 Jan 2007 18:55:15 -0500

Earlier, Heiner Hummel wrote:
> IMHO: the identifier should name some kind of stack, and the locator
> as well . But here each part is conceived to be just another IP  
> address.
> Right ?
> The locator is not a combination of AS# + some router's IP address.
> Right?

I am definitely NOT thinking that "each part is just another IP  
address".
My thought is conceptually to deprecate the concept of "address" and
instead have distinct locators and identifiers (with different
namespaces for each -- so reducing the semantic overloading).

The approach where "each part is an IP address" increases,
rather than decreases, the semantic overloading.  That is also
roughly the engineering decision that SHIM6 made.

So far, I'm not getting into the details of what might constitute
the internal format of a locator.  One can imagine a range of very
different engineering choices there.  For now, O'Dell's term
"Routing Goop" certainly is good enough for the locator (keeping
the details vague enough to keep our options open).

Ran

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Peter Sherbin <[email-masked]>
Date: Fri, 19 Jan 2007 13:58:43 -0800 (PST)

> O'Dell's term "Routing Goop"

His drafts (8+8, GSE) have expired. Could anyone point to or share these documents?

Thank you,

Peter

> the details vague enough to keep our options open).

____________________________________________________________________________________
Don't get soaked.  Take a quick peak at the forecast
with the Yahoo! Search weather shortcut.
http://tools.search.yahoo.com/shortcuts/#loc_weather

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 19 Jan 2007 23:16:33 +0100

> His drafts (8+8, GSE) have expired.

And then some.  :-)

Those should really be published as historic RFCs or something...

> Could anyone point to or share these documents?

Have a look at draft-iab-raws-report-00.txt, it contains many good  
pointers, including one to the GSE draft.

---

From: David Meyer <[email-masked]>
Date: Fri, 19 Jan 2007 14:28:02 -0800

> His drafts (8+8, GSE) have expired. Could anyone point to or share these documents?

	Check out http://www.watersprings.org/pub/id/draft-ietf-ipngwg-gseaddr-00.txt

	--dmm

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 22 Jan 2007 09:14:53 +0100

> 	Check out http://www.watersprings.org/pub/id/draft-ietf-ipngwg-gseaddr-00.txt

And bookmark http://tools.ietf.org/id/, which can find a lot
of stuff for you.

    Brian