Subject: Re: [RAM] Traffic Engineering

From: David Meyer <[email-masked]>
Date: Wed, 3 Jan 2007 07:38:54 -0800

On Sat, Dec 30, 2006 at 04:14:23AM +0000, Chris L. Morrow wrote:
> 
> would it be possible to not have html email on this list? :) it's just
> ugly and unnecessary.

	I would appreciate that as well. While I can get mutt to
	display html --

	 .muttrc:  auto_view text/html application/x-X-sun-attachment 
	 .mailcap: text/html; lynx -dump -force_html %s; \
                   needsterminal; copiousoutput; 

	its still not pretty.

	--dmm

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: David Meyer <[email-masked]>
Date: Wed, 3 Jan 2007 07:51:25 -0800

Chris/all,

> I think what's been said loudly and often by larger network operators and
> content providers is that SHIM6 isn't solving the problem(s) they see,
> it's not even attempting to address those problems. So, they require
> something else to do multihoming, they also realize that that 'something
> else' may require radical changes, and will have to scale to very large
> numbers over the next 10-15 years.

	I think this is key. Namely, that shim6 is solving a
	different problem than what the backbone operators are
	seeing. Now, one can argue to what degree there is a
	different problem, and to what degree shim6 whould solve
	such a problem, but all of that is defocusing. So, here's
	proposal:  

	 How about we just stipulate that shim6 (et al) doesn't
	 address (nor solve) the problem set the backbone
	 operators are dealing with, and move on. 
	 
	Why? Well, first, the IETF *is* developing SHIM6/HIP/...,
	and from all the evidence I can see, that will continue
	(no value judgement, just so that is clear). Second, what
	I'm hoping this activitiy leads to is a scalable routing
	(and addressing) system for the Internet (big I). 

	Note that such a system will might need to interact with
	whatever the hosts are doing in this domain (e.g., hip,
	shim6, maybe even things like softwires), hopefully in
	some aggregated way (if at all), and it would be
	reasonable to understand those interactions (if any) as
	part of any future architecture/design.  

	--dmm

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 04 Jan 2007 17:06:25 +0100

On 2006-12-30 13:46, Marshall Eubanks wrote:
...
> 
> I too may be missing something, but isn't the idea behind SHIM6 is that 
> the host
> is multi-homed ? It has locators in two or more domains, so it can 
> select paths.
> So, in principle, a botnet operator could know what paths were possible.

This is nothing to do with shim6. Any IPv6 host can have multiple
addresses, and many do. Any IPv4 host can have multiple addresses,
for that matter (my laptop appears to have three at the moment). I'm
not sure what the new threat is...

    Brian

---

From: Roland Dobbins <[email-masked]>
Date: Thu, 4 Jan 2007 08:13:08 -0800

> not sure what the new threat is...

It has everything to do with SHIM6, because the vast majority of  
hosts in the world do not currently have multiple IP addresses which  
are in active use, and it is undesirable (for the many reasons  
previously outlined on these threads) to try and make multiple IP  
addresses with dynamic host selection of the initial path for egress  
traffic mandatory for multihomed sites.

-----------------------------------------------------------------------
Roland Dobbins <[email-masked]> // 408.527.6376 voice

		          Technology is legislation.

                     -- Karl Schroeder

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 05 Jan 2007 14:54:21 +0100

On 2007-01-04 17:13, Roland Dobbins wrote:
> It has everything to do with SHIM6, because the vast majority of hosts 
> in the world do not currently have multiple IP addresses which are in 
> active use, and it is undesirable (for the many reasons previously 
> outlined on these threads) to try and make multiple IP addresses with 
> dynamic host selection of the initial path for egress traffic mandatory 
> for multihomed sites.

So you've asserted. But the context of my question was botnet capture.
Why does shim6 increase the threat caused by botnet capture?

However, I'd rather we stopped discussing shim6 here. It isn't the basic
topic, and it will sink or swim on its own merits.

    Brian