Subject: Re: [RAM] Re: server referrals

From: Brian E Carpenter <[email-masked]>
Date: Thu, 01 Feb 2007 10:25:25 +0100

On 2007-01-31 16:32, RJ Atkinson wrote:
> Earlier Thomas Narten wrote:
>> IMO, this assertion needs to be shown to be true.
>> I suspect its very much not.
> 
> Well, if one is looking to prove assertions, let us please start
> with proving the unsubstantiated assertion that server referrals
> necessarily are broken by moving to an ID/Locator split.

Actually it might be exactly the opposite: referrals are widely
broken today by NATs and VPNs (which both cause addresses to
have a limited context of validity) whereas I assume that any loc/id
split will at least have the virtue of providing global ids.

To put it another way, we should make this a requirement: ids
must be able to serve as 3rd party references.

   Brian

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: David R Oran <[email-masked]>
Date: Sun, 4 Feb 2007 15:31:29 -0500

> must be able to serve as 3rd party references.
I agree with this to the extent that such references have an assumed  
temporal scope - i.e. they can be assumed to be valid at the time of  
referral but not for an indefinite period thereafter. In this respect  
they differ from identifiers assumed to be temporally immutable like  
public keys or UUIDs.