Subject: [RAM] Fwd: I-D ACTION:draft-bagnulo-pshim6-00.txt

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 28 Feb 2007 12:45:50 +0100

Hi,

i have included in this draft some level of detail on how to do proxies 
in shim6, in order to support unmodified hosts, allow some middle boxes 
to perform egress path selection and provide PI identifiers, so that we 
can have an idea of how this would look like in the shim approach

Comments are welcome

Regards, marcelo

Inicio mensaje reenviado:

> De: [email-masked]
> Fecha: 27 de febrero de 2007 21:50:02 GMT+01:00
> Para: [email-masked]
> Cc: Asunto: I-D ACTION:draft-bagnulo-pshim6-00.txt
> Responder a: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Proxy Shim6 (P-Shim6)
> 	Author(s)	: M. Bagnulo
> 	Filename	: draft-bagnulo-pshim6-00.txt
> 	Pages		: 22
> 	Date		: 2007-2-27
> 	
>    This draft discusses extensions to the shim6 architecture to support
>    shim6 proxies that would allow the provision of the following
>    capabilities:
>    o  Provide Upper Layer Identifier portability.
>    o  Provide Traffic Engineering policy enforcement.
>    o  Off-load of the shim6 context management from the actual peers of
>       the communication.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-bagnulo-pshim6-00.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-bagnulo-pshim6-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-bagnulo-pshim6-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 28 Feb 2007 04:25:39 -0800

I haven't had time to follow these discussions closely, but
anyone interested in the proposals being discussed here might
also be interested in IP with Virtual Link eXtension (IPvLX):

http://www.ietf.org/internet-drafts/draft-templin-ipvlx-06.txt

Not making any claims of originality, but the proposal has
been around for several years and is about joining sites
that can use provider-independent addressing across a global
Internet routing core that uses provider-aggregated addressing.
PI-to-PA mappings are not conveyed in routing protocols; they
are kept in the global DNS instead.

In its current manifestation, the proposal assumes IPv6 sites
with an IPv4 Internet routing core, but there is no reason it
couldn't be extended to support any IPv*/IPv* combination. I
would be interested to hear what people think about this.

Fred
[email-masked]