Subject: Re: [RAM] The DNS? Which DNS? (Was: Incremental Deployment of LISP

From: Brian E Carpenter <[email-masked]>
Date: Mon, 02 Apr 2007 10:39:18 +0200

On 2007-03-30 18:12, David Meyer wrote:
> On Fri, Mar 30, 2007 at 08:36:21AM -0700, Templin, Fred L wrote:
>> I think the subject of this message hits the mark, and
>> maybe there is some confusion about what needs to go
>> in the global DNS. Only FQDNs with locators for egress
>> tunnel routers need to go in the global DNS, and that
>> is not a lot more than what we are asking the global
>> DNS to carry today.
>>
>> FQDNs for the services themselves are not resolved in
>> the global DNS; they are resolved in site-specific name
>> services instead.
> 
> 	I've said this once already, however, it might be
> 	instructive to look at the other existing instance where
> 	this has been tried, i.e., carrier/infrastructure
> 	ENUM. There are some lessons, both technical and
> 	non-technical to be learned there. See e.g.
> 	http://voipandenum.blogspot.com/2006/03/dallas-treaty-on-infrastructure-enum.html

It would seem a little strange to me to actively advocate
walled-garden namespaces as part of the way to make the
Internet scale up transparently. I don't want example.com
to resolve to some local SP or corporate notion of who should
be providing the services branded as 'example'.

    Brian

     Brian

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: David Meyer <[email-masked]>
Date: Mon, 2 Apr 2007 07:46:13 -0700

> be providing the services branded as 'example'.

	To be a little more clear, the "example" was intended to
	illustrate the pitfalls of trying to create special
	purpose "disconnected" parts of the DNS (i.e., it doesn't
	work, because the new "apexes" will be a source of
	revenue/control for someone, ...). 

	That said, I agree with what you have said about
	consistency of response(s) from the DNS.

	--dmm