Subject: Fw: Fraction of transit ASes going down? [Re: [RAM] TIDR using the IDENTIFIERS attribute]

From: [email-masked]
Date: Thu, 26 Apr 2007 13:20:23 +0200

Marshall and Pierre,

Thank you for your mails. Please see below.

Pierre Francois <[email-masked]> wrote on 25/04/2007 16:27:55:
> Marshall Eubanks wrote:
> > I do not know, but if I had to guess I would guess this is the effect 
> > of route aggregation, which will tend
> > to "bury" leaf asn's.
> If the question is destined to me :
> 
> I would "cluster" the histogramm you provide :
> group 1 : Number of ASN supporting 1 ASN
> group 2 : Number of ASN supporting 2 ASN
> group 3 : Number of ASN supporting 3 ASN
> group 4 : Number of ASN supporting ]3,10] ASN,
> group 5 : Number of ASN supporting ]10, 100] ASN,
> group 6 : Number of ASN supporting > 100  ASN,
> 
> Then look at how these values evolve since 2001. I have no clue on which 

> clustering would reveal interesting trends, but this could
> be worth the investigation. (would have been good to have it just a bit 
> earlier than 2001 ;-)  )

The proposal made by Pierre is also fine to me. Another
interesting table would be the number and percentage of
transit AS-es having just 2 upstream transit providers,
or 3, or 4, etc.

> > Histogram of the number of AS Supported Out of  24857
> >
> > Number ASN Supporting      1 ASN =  21989  or 88.462 %
> >

The results of your data is very important because it
confirms again the small fraction of transit AS-es in the
Internet: we have around 2868 transit AS-es (24857-21989).

I think this supports the use of a "locator prefix" per
transit AS as a method to reduce the RIB as I proposed
in the TIDR draft.

In its simplest form, where each transit AS announces only
one /32 "locator prefix" to receive tunneled traffic for its
leaf customers, we would have a RIB containing 2868 prefixes.
This "locator prefix" could be thought of as the "IP address"
of the autonomous system, and it is where the multipoint
TIDR tunnel ends.

Don't forget that a transit AS is a customer of itself
in the sense that it will use the same "locator prefix"
to receive tunneled traffic for the prefixes that it is
currently originating ("identifier prefixes").

Moving further, if each transit AS announces for example
100 /32 "locator prefixes" so that each of these corresponds
to a specific entry point from the interdomain
infrastructure (i.e. interfaces not facing leaf customers)
we will have a RIB containing 286800 prefixes, which is
a little bigger than current RIB. But for regional
transit AS-es is quite common to have just a small number
(2, 3, 4, ...) of upstream providers.

The evolution of the fraction of transit AS-es could also
support my proposal as follows: if this fraction keeps
decreasing over time the benefit of holding in the RIB
only the "locator prefixes" will be more clearly seen
(don't let leaf AS-es to influence on the RIB because
they are not within the INTER-domain infrastructure),

Prefixes of the leaf AS-es will not be in the RIB but
in the TIB.

Any comments?. Am I too wrong?.

Regards,
Juanjo

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 26 Apr 2007 08:31:32 -0400

> Internet: we have around 2868 transit AS-es (24857-21989).

Hello;

I would like to understand why, when there is general agreement as to  
the total number
of ASNs, the proportion of transit vs leaf ASN's is so different. (if  
it is due to aggregation,
I would expect the total numbers to change a fair amount as well.)

I am looking into my code; can anyone see an problem with the way I  
have defined
"support" ?

Regards
Marshall

---

From: "tom.petch" <[email-masked]>
Date: Fri, 27 Apr 2007 18:24:01 +0200

I too am curious (and do think these metrics should inform our choices).

When there are two different results, then either the data is different and/or
the algorithm is different.  Obvious I know but it does provide the way to
resolve any such problem.  Also, it tells me that I cannot readily take it
further because I do not know the algorithm in use and do not have a clear view
of the underlying data.

The result I am used to is the one posted to nanog, eg

Total ASes present in the Internet Routing Table:                 24788
Origin-only ASes present in the Internet Routing Table:           21588
Transit ASes present in the Internet Routing Table:                3200
Transit-only ASes present in the Internet Routing Table:             71

Were I to produce such an analysis, I would have to define an Origin-only AS.
Is it one that never produces a eBGP IPv4 UPDATE with any other ASN in it than
its own?  What if it prepends its own twice?  What if private ASN leak through?

And if an update does contain a foreign ASN, what if such an UPDATE never gets
into a FIB because there is always a 'better' one (which is not the same thing
as aggregation)?

This last makes the analysis dependent on the Internet topology. I note that the
data cited above comes from an APNIC router in Japan and is based on 'BGP
routing table entries examined:' which I take to be IPv4 FIB entries.  I also
imagine that a router in Japan might well see UPDATEs coming via fewer ASN than
a router in, say, the historic center of the Internet.  1/6 v 1/3?  Perhaps.

Tom Petch

----- Original Message -----
From: "Marshall Eubanks" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, April 26, 2007 2:31 PM
Subject: Re: Fraction of transit ASes going down? [Re: [RAM] TIDR using
theIDENTIFIERS attribute]