Subject: Re: [RAM] Ramblings about "locator"

From: "Ved Kafle" <[email-masked]>
Date: Fri, 15 Jun 2007 12:03:30 +0900

> Marshall,
> 
> ...
> >> Maybe the essential point is that a locator can at least in
> >> principle be mapped to topology and an identifier can't.
> >>
> > 
> > If in Ethernet what is essentially a random number (the MAC 
> address) 
> > becomes
> > a locator then maybe the distinction will never be crisp.
> 
> Well, that horrible thought crossed my mind. I think I disagree
> with Jarno's comment, because as soon as an Ethernet address
> gets into a spanning tree it has become a locator (at level 2).

So, the distinction between an identifier and a locator is dependent on
the avalaibility of routing/switching infrastructure. 
If networks possess routing/switching insfrastructure based on a
identifier namespace, the identifier simultaneously functions as a
locator. 

Ved

>      Brian

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 15 Jun 2007 09:11:41 +0200

> identifier namespace, the identifier simultaneously functions as a

My original RAMble (sorry) ended thus:

I think that's correct and actually consistent with much that's been
said. A slightly different way to say it is that a locator is a
handle for a route.

     Brian

---

From: Stig Venaas <[email-masked]>
Date: Fri, 15 Jun 2007 10:23:18 +0200

Brian E Carpenter wrote:
>> the avalaibility of routing/switching infrastructure. If networks
>> possess routing/switching insfrastructure based on a

Yes, I would say that it functions as a locator, but I'm not sure I
would say that it is a locator. Does the fact that you know where all
the identifiers are located make them locators?

>  principle be mapped to topology and an identifier can't.

So I'm not sure exactly what "mapped to topology" should mean, but I
think I do. I would not say that MAC addresses can be mapped, their
values are not tied to the topology in any way.

Stig

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 15 Jun 2007 10:14:31 -0400

Hello;

> said. A slightly different way to say it is that a locator is a

I think that the missing piece here is _intent_.

A locator is _intended_ to be mapped to or congruent with typology.
An identifier is _intended_ to be unique and independent of typology.

Of course, once something is created, how it is actually used (or  
misused) is no longer under control,
and it is safe to say, "if it can be, it will."

So, you can't be crisp about usage; the goal should be to be crisp  
about intentions.

>     Brian

Regards
Marshall